1. Niko-V's Avatar
    Hi everyone, bought a lumia 925 on ebay recently, clean IMEI but locked to Three UK which isnt a problem.
    But the real problem is that I get NO SERVICE, not outside, not at home, no where, just no service.
    Microsoft wont take the phone for repair as they wont accept the proof of purchase from ebay (WTF is the difference? i still paid money for it and its clearly not stolen)
    The phone itself finds networks when I search for them manually but whatever I do it doesnt connect to any of the networks.
    YES, I did test the sim cards in other different phones and it definitely works fine and its not cut.

    Is there a solution for this problem?
    05-27-2015 03:12 PM
  2. djeire84's Avatar
    Hi everyone, bought a lumia 925 on ebay recently, clean IMEI but locked to Three UK which isnt a problem.

    But the real problem is that I get NO SERVICE, not outside, not at home, no where, just no service.

    Microsoft wont take the phone for repair as they wont accept the proof of purchase from ebay (WTF is the difference? i still paid money for it and its clearly not stolen)

    The phone itself finds networks when I search for them manually but whatever I do it doesnt connect to any of the networks.

    YES, I did test the sim cards in other different phones and it definitely works fine and its not cut.

    Is there a solution for this problem?

    Go to mobile and sim in settings and make sure your network selection is automatic and the access point in settings and make sure the network is active. To do this long press on the name and activate.
  3. djeire84's Avatar
    Hi everyone, bought a lumia 925 on ebay recently, clean IMEI but locked to Three UK which isnt a problem.

    But the real problem is that I get NO SERVICE, not outside, not at home, no where, just no service.

    Microsoft wont take the phone for repair as they wont accept the proof of purchase from ebay (WTF is the difference? i still paid money for it and its clearly not stolen)

    The phone itself finds networks when I search for them manually but whatever I do it doesnt connect to any of the networks.

    YES, I did test the sim cards in other different phones and it definitely works fine and its not cut.

    Is there a solution for this problem?

    Go to mobile and sim in settings and make sure your network selection is automatic and the access point in settings and make sure the network is active. To do this long press on the name and activate.
    RumoredNow and Laura Knotek like this.
    05-27-2015 03:22 PM
  4. Niko-V's Avatar
    If you read what I've said above carefully, you'll realise what you've said wont make any difference at all.
    Your solution does not WORK!
    05-28-2015 04:52 AM
  5. djeire84's Avatar
    If you read what I've said above carefully, you'll realise what you've said wont make any difference at all.
    Your solution does not WORK!

    Ok don't give out. Sometimes that solution does work for other users that had similar issues. Have you tried resetting your phone and starting from a fresh install? Settings.. About.. Reset phone. This might help.
    05-28-2015 05:01 AM
  6. djeire84's Avatar
    If you read what I've said above carefully, you'll realise what you've said wont make any difference at all.
    Your solution does not WORK!

    Also you should get your phone unlocked too. If its locked to a particular network your not going to get it to work with other networks. I see its locked to three, what network sim are you trying get to work with the phone?
    05-28-2015 05:04 AM
  7. Niko-V's Avatar
    Also you should get your phone unlocked too. If its locked to a particular network your not going to get it to work with other networks. I see its locked to three, what network sim are you trying get to work with the phone?
    I've tried debranding, downgrading, reflashing - just about everything. Nothing brings it back to life. And im obviously trying it with the sim that its locked to.
    05-28-2015 05:10 AM
  8. djeire84's Avatar
    I've tried debranding, downgrading, reflashing - just about everything. Nothing brings it back to life. And im obviously trying it with the sim that its locked to.

    How long ago did you purchase the sim? If its just a new sim you must register it with the Sims carrier, must top it up and you can also call your mobile carrier to help with the no service issue. The phone is fine its not hardware or software related its sim related.
    05-28-2015 05:13 AM
  9. Niko-V's Avatar
    Getting really frustrated now.. Spent 80 quid on the phone that doesnt work and Microsoft wont even accept it for repairs or anything..
    I've been reading that it could be faulty NFC antenna or the main antenna, so im now debating about ordering a new back plate and the antenna unit. But then again i ran diagnostics in NSU and it tells me that every single component is functioning fine. So its really really annoying me now.

    its definitely not a SIM issue. i have 3 three sim cards, and they all function fine in other lumia phones.
    05-28-2015 05:15 AM
  10. djeire84's Avatar
    Its the connection between this phone that's the issue. Bring the phone and sim into three and they will sort it for you. The phone is fine its the network that's the problem.
    05-28-2015 05:25 AM
  11. Niko-V's Avatar
    Its the connection between this phone that's the issue. Bring the phone and sim into three and they will sort it for you. The phone is fine its the network that's the problem.
    Yeah, wont they ask me for a receipt specifically from them? as i mentioned above, im not the first owner and the device is second hand. Microsoft refused to accept it for diagnostics even though i was willing to pay for whatever the phone needs doing to it.
    05-28-2015 05:28 AM
  12. djeire84's Avatar
    One more thing you can check make sure flight mode is switched off. If its on you wont connect to the network. Settings.. Flight mode.. Off.
    Try putting another three sim into the offending phone and test.
    05-28-2015 05:30 AM
  13. knuckles245's Avatar
    Thanks for one of the members of this forum who kindly inboxed me the cause of the problem
    What was the problem? Does your phone work now?
    Harrie-S likes this.
    05-28-2015 10:20 AM
  14. Branta's Avatar
    And so perish all who indulge in offensive and sexist harassment.
    05-28-2015 11:06 AM

Similar Threads

  1. Lumia 535 touch problem
    By jaffar fuzail in forum Microsoft Lumia 535
    Replies: 25
    Last Post: 02-01-2016, 10:26 AM
  2. Lumia 640 Getting an Update
    By Vibhav Nadkarni in forum Microsoft Lumia 640
    Replies: 6
    Last Post: 05-31-2015, 06:09 AM
  3. Why can't I turn my Nokia Lumia 625 on?
    By Windows Central Question in forum Nokia Lumia 625
    Replies: 3
    Last Post: 05-27-2015, 06:36 PM
  4. My brand new Lumia 730 hangs a lot on daily basis, why?
    By Windows Central Question in forum Nokia Lumia 730 & 735
    Replies: 1
    Last Post: 05-27-2015, 04:08 PM
  5. How do I turn the answer machine off on Nokia Lumia 920?
    By Windows Central Question in forum Nokia Lumia 920
    Replies: 1
    Last Post: 05-27-2015, 01:07 PM
LINK TO POST COPIED TO CLIPBOARD