1. thaufee's Avatar
    Hello,

    Does any one faced the 'waves on the screen' issue?

    I've bought Lumia 930 a week before from UAE, and I've seen a waves on my screen. It only happens when the screen has white (or light) background?

    Am I only the person who faces this issue? Or what about your lumia 930?

    What should I do to overcome this irritating issue!!!
    08-12-2014 01:18 AM
  2. PJLips's Avatar
    I had the same issue. I waited 2 weeks for it to correct itself but it didn't get any better. I returned the phone and I went back to my Nexus 5 sadly enough.
    08-12-2014 01:44 AM
  3. dannejanne's Avatar
    Hmm sounds like you are trying to explain some kind of electric/magnetic interference? I've only seen that on older CRT screens that I can remember but LCD's can get it too. My whites are perfectly clean and flat. Sound like you have a defect phone unfortunately.

    Definitely sounds like some kind of magnetism issue though.
    arif b santoso likes this.
    08-12-2014 01:50 AM
  4. dengwinters's Avatar
    Hmm sounds like you are trying to explain some kind of electric/magnetic interference?
    It only happens sometimes and only on white surface and only when the signal is very bad and on my phone it also needs to be on Edge or GPRS (E or G respectively).

    So far I've checked 4 phones and every one of them exhibited this issue in certain places where Edge signal is very bad.
    08-12-2014 01:54 AM
  5. dannejanne's Avatar
    It only happens sometimes and only on white surface and only when the signal is very bad and on my phone it also needs to be on Edge or GPRS (E or G respectively).

    So far I've checked 4 phones and every one of them exhibited this issue in certain places where Edge signal is very bad.
    Very weird but that kind of proofs my point of some kind of interference perhaps not necessarily magnetic but something with the signal of the phone when it struggles. Have not noticed it on mine yet and I'm on Edge occassionaly since my girlfriend lives on the contryside with bad signal.
    08-12-2014 02:01 AM
  6. ivaschuck's Avatar
    Yup, I've had the same issue, even created a post on it here somewhere. From my own experience and of people who replied to my post it seems to happen when the phone has a bad signal. I noticed it when my Wi-Fi and 4G reception was really poor. Other than that I haven't given it much thought, it only appeared a couple of times since I bought my 930.
    08-13-2014 09:55 AM
  7. thaufee's Avatar
    Yup, I've had the same issue, even created a post on it here somewhere. From my own experience and of people who replied to my post it seems to happen when the phone has a bad signal. I noticed it when my Wi-Fi and 4G reception was really poor. Other than that I haven't given it much thought, it only appeared a couple of times since I bought my 930.
    So do you now overcome this issue? If yes, what did you do?
    08-13-2014 10:57 AM
  8. thaufee's Avatar
    I had the same issue. I waited 2 weeks for it to correct itself but it didn't get any better. I returned the phone and I went back to my Nexus 5 sadly enough.
    So what's the actual problem? Hardware or software?
    08-13-2014 10:58 AM
  9. iwang's Avatar
    Same..you see waves and flickers. Mine always did.
    08-13-2014 08:32 PM
  10. ivaschuck's Avatar
    I did nothing. I am rarely in areas with bad reception so the issue doesn't manifest often enough for me to seek a solution.
    08-14-2014 06:28 AM
  11. samadkhan's Avatar
    Having the same issue while calling, in menu, with signal 4g , h+ and edge and Its from axiom uae once still the same issue, don't know what to do tried everything , gave again to service center but they gave it to me back saying no issues. Nokia care saying network issues but I don't have any network issues anywhere.
    08-14-2014 09:30 PM
  12. thaufee's Avatar
    Having the same issue while calling, in menu, with signal 4g , h+ and edge and Its from axiom uae once still the same issue, don't know what to do tried everything , gave again to service center but they gave it to me back saying no issues. Nokia care saying network issues but I don't have any network issues anywhere.
    Even I too bought from axiom UAE. Its because of the display driver. Lets hope the new firmware update which will be released exclusively for lumia 930 soon solves the problem.
    08-14-2014 10:15 PM
  13. samadkhan's Avatar
    U get any update from anywhere kindly update
    08-17-2014 09:23 PM
  14. Nikito27's Avatar
    Same here, while on EDGE the whites flicker! I'm an italian user on TIM network.
    No problems with strong HDSPA signals, just with 2G.
    Probably hardware...
    thaufee likes this.
    08-22-2014 06:46 AM
  15. thaufee's Avatar
    Same here, while on EDGE the whites flicker! I'm an italian user on TIM network.
    No problems with strong HDSPA signals, just with 2G.
    Probably hardware...
    Same here, I had this issue only on 2G EDGE network. Because of the network. If I changed it into 3G, the issue goes off. I simply changed to 3G to shoot the issue!
    09-23-2014 06:09 AM
  16. thaufee's Avatar
    U get any update from anywhere kindly update
    WAVES ON SCREEN issue solved if I changed my network to 3G from 2G. I faced this issue only on low signal 2G
    09-23-2014 06:10 AM
  17. Conodihno's Avatar
    Mine did also flickering on a 2g signal. Got it back from Nokia and its gone. They replaced faulty component 201... Dont know what that is though.
    09-23-2014 02:08 PM
  18. Conodihno's Avatar
    09-23-2014 02:08 PM
  19. sihombing89's Avatar
    It also happened to my Lumia 640XL.
    I'm not really sure since when it's happened but that really annoyed me.
    Has anybody found an option or clues how to fix it?
    11-02-2015 01:18 AM
  20. PsyOr's Avatar
    Post a video of this issue.
    I got issue of 'blinking' screen, not happens all the time but its not the 'crt/flickering' that people mention about the 2g.
    The screen blink for less then 1 second.
    Microsoft support tells that they will fix this bug (and the 2g flickering thing) in the next version (WP10).
    Seems they won't fix it (as for the latest tester versions) and I bet it won't be fixed on the final version.
    First and last time I buy Microsoft device.
    11-02-2015 03:33 AM

Similar Threads

  1. Replies: 17
    Last Post: 08-20-2014, 01:05 PM
  2. Nokia Lumia 925
    By chella kumaran in forum Nokia Lumia 925
    Replies: 3
    Last Post: 08-12-2014, 07:39 AM
  3. Need to upgrade my 920
    By TywinnLannister in forum Ask a Question
    Replies: 1
    Last Post: 08-11-2014, 11:52 PM
  4. Replies: 4
    Last Post: 08-11-2014, 10:46 PM
  5. Nokia Lumia Icon on AT&T
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-11-2014, 10:43 PM
LINK TO POST COPIED TO CLIPBOARD