The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. carlosrdd's Avatar
    So I got my 930 yesterday I upgraded from a 1020. The phone feels amazing really like the design but There's couple of problems 1st problem I noticed as many have also is the display is "bleeding" red most noticeable in greys and blacks like the keyboard looks burgundy also the camera has a purple tint in some shots.

    2nd problem is the display is not registering some touches like when trying to pull down the notification shade "most noticeable from the top right" also happens when in camera mode, it takes about 5 touches to get into the photo viewer and when playing Subway Surfers you can notice swipes are not registering sometimes.

    Now my question is, is anyone else experiencing any of these problems or knows of a fix? Thanks
    08-15-2014 08:36 AM
  2. carlosrdd's Avatar
    No one else has this problem?
    08-15-2014 09:18 PM
  3. ykcu7's Avatar
    I have exactly the same problem playing subway surfers is almost impossible. stopping most of background app helps a little bit but that is not a solution for this.
    08-16-2014 01:22 PM
  4. carlosrdd's Avatar
    I think it's the software there seems to be some kind of glitch with the touch screen but I could be wrong. Hope it's just software related.
    08-16-2014 03:46 PM
  5. Thomas Jordan's Avatar
    I have exactly the problem as you. I am going to see if I can get it exchanged. Driving me nuts. Love the phone though.
    08-16-2014 03:57 PM
  6. carlosrdd's Avatar
    Yea it's frustrating that such awesome hardware would have these problems. I did read on here that there will be some sort of update in September. Let's hope it will fix it.
    08-16-2014 10:44 PM
  7. Syd90's Avatar
    Hi I had similar issue and found a fix in the wpforum by one forum user (search for forum nokia-lumia-930/302277-lumia-930-red-display-bleeding-temporary-fix), his solution fixed my issue hope it fixes yours (Quoted words since i cant post links)

    "Hello, today I got my 930 and was shocked when I saw the bleeding on the Display.

    After playing around with it I figured it has to be the Display App/Driver, so I set the Date to 2300 and uninstalled it, and the Display works like a charm! Blacks look like they're supposed to and theres no more "bleeding"! And no Purple hue!
    All you have to do is:
    Set your date to the year 2300
    go to Settings, Store, disable automatic App Updates (Just in case)
    go to Settings, tap on Display, since by 2300 the certificate for the Display App would have expired, you can uninstall it. Now restart your phone and set the correct year again. No more Purple where black should be, no more reddish bleeding! I don't know if there are any other negative consequences about this method, but it seems to work so far."
    Thomas Jordan likes this.
    08-17-2014 03:15 AM
  8. Thomas Jordan's Avatar
    Hi I had similar issue and found a fix in the wpforum by one forum user (search for forum nokia-lumia-930/302277-lumia-930-red-display-bleeding-temporary-fix), his solution fixed my issue hope it fixes yours (Quoted words since i cant post links)

    "Hello, today I got my 930 and was shocked when I saw the bleeding on the Display.

    After playing around with it I figured it has to be the Display App/Driver, so I set the Date to 2300 and uninstalled it, and the Display works like a charm! Blacks look like they're supposed to and theres no more "bleeding"! And no Purple hue!
    All you have to do is:
    Set your date to the year 2300
    go to Settings, Store, disable automatic App Updates (Just in case)
    go to Settings, tap on Display, since by 2300 the certificate for the Display App would have expired, you can uninstall it. Now restart your phone and set the correct year again. No more Purple where black should be, no more reddish bleeding! I don't know if there are any other negative consequences about this method, but it seems to work so far."
    That has worked for me. Also I did the same on touch settings and they seem better now aswell. Thanks
    08-17-2014 07:06 AM
  9. Thomas Jordan's Avatar
    After uninstalling them I checked for updates in the store and it does not show them so maybe the last update that caused the problem has been removed from the store. So hopefully that should mean when it does pop up with an update it will be newer version with a fix for the purple and touch problems.
    08-17-2014 07:13 AM
  10. ykcu7's Avatar
    That has worked for me. Also I did the same on touch settings and they seem better now aswell. Thanks
    yap, I've just uninstalled touch settings too and now it really seems that swipes work without issues. Tested on subway surfers.
    08-17-2014 04:03 PM
  11. carlosrdd's Avatar
    Thanks for the info I will try it!

    Update: Touch still has problems on top right corner but red bleeding is completely gone!
    Last edited by carlosrdd; 08-18-2014 at 04:57 PM.
    08-18-2014 04:30 PM
  12. Thomas Jordan's Avatar
    After a day of use colour is now good but touch is still a bit dodgy
    08-18-2014 07:31 PM
  13. carlosrdd's Avatar
    Yup touch is still messed up. I'm sure they eventually fix it but I think I'm going to sell or trade my 930 for Android phone.
    08-18-2014 07:45 PM
  14. Syd90's Avatar
    Can you check if your touch sensitivity is set to high (Go to settings and than touch), if it is than set it to normal and restart the phone I think that will most likely fix the issue. Lemme Know if it resolved ur issue
    Last edited by Syd90; 08-19-2014 at 08:24 AM.
    08-19-2014 01:59 AM
  15. carlosrdd's Avatar
    I did that already with no luck even tried uninstalling the touch setting all together. That didn't help either. Maybe it has something to do with the latest dev preview. I would remove that but live folders are just to good.
    08-19-2014 12:17 PM

Similar Threads

  1. Issues in WP 8.1.1 with Lumia 1020 (not a rant, just a report)
    By bijak_riyandi in forum Update 1 for Windows Phone 8.1 (GDR1)
    Replies: 7
    Last Post: 08-24-2014, 03:16 PM
  2. Bing news live tile going blank and isn't working
    By Aashish13 in forum Ask a Question
    Replies: 3
    Last Post: 08-18-2014, 02:27 PM
  3. Not getting cyan update
    By 7508887757 in forum Ask a Question
    Replies: 4
    Last Post: 08-17-2014, 01:16 PM
  4. Not able to find cortana
    By Karthik K V in forum Ask a Question
    Replies: 0
    Last Post: 08-15-2014, 08:26 AM
  5. Backup not working
    By adesonic in forum Update 1 for Windows Phone 8.1 (GDR1)
    Replies: 1
    Last Post: 08-15-2014, 07:47 AM
LINK TO POST COPIED TO CLIPBOARD