1. atchi123's Avatar
    I have an unlocked 930 with mobile operator code 000-hk (clearly Hong Kong) and rm1045.i have a UK 4G contract with EE but don't get any 4G. Now I am pretty sure this is to do with the radio antenna in the device and the frequency band not working with EE? the question is, can I do anything about this such as re-flashing the device or some smart patch?
    Thanks!
    01-18-2015 03:25 PM
  2. kristalsoldier's Avatar
    That's odd. I have a recently acquired brand new 1520 also from HK and I am with Three. Three has been rolling out its 4G network gradually here in Somerset and I get a 4G connection all the time at certain locations.

    Edit: My unit is the RM-937 variant listed as APAC-HK. And my 1520 is as it came in the box. No flashing etc.
    01-18-2015 03:38 PM
  3. gMaesterUK's Avatar
    Don't quote me, but I believe you just need to flash your phone to the "CV GBIE" ROM which allows all the frequency ranges used by UK carriers.

    EDIT: Each carrier has different frequency ranges in use (for example 3 in HK use the 2.3GHz range, whereas EE in the UK uses 1800MHz range for 4G LTE), so sometimes it's easier to use the Country Variant which covers all known frequencies.

    G.
    01-18-2015 03:41 PM
  4. atchi123's Avatar
    Ok thanks!. Never done that before. Will do a bit more researching before I pull the trigger...
    01-18-2015 04:56 PM
  5. gMaesterUK's Avatar
    I've personally never done this, however there are quite a few members of the forum that have, just ask for help with any questions you have.

    G.
    01-19-2015 08:29 AM
  6. rockstarzzz's Avatar
    Ok thanks!. Never done that before. Will do a bit more researching before I pull the trigger...
    It is *super* easy - once you have installed all the software and drivers you need on your PC. Then its just connecting your phone, pressing a few buttons, click click click and restart. Done. There are some really good tutorials on this forum so read a few, ask a dozen questions and then go for it!

    I would say, if you are flashing, flash a Denmark or Finland ROM as that has already got Denim on it, UK CVGB ROMs are still awaiting the Denim update. This way you get two birds with one stone - 4G and Denim.
    01-19-2015 09:04 AM
  7. atchi123's Avatar
    Thanks rockstarzzz. Do you think it will fix the 4G issue?
    01-19-2015 09:05 AM
  8. Rick_Air's Avatar
    All that being said, you do have 4G coverage in your area?
    Silly question but needs checking.
    Please don't be offended
    01-19-2015 09:14 AM
  9. atchi123's Avatar
    Yes I do. No offence taken 😊 Have been to multiple places across London with no 4g.
    01-19-2015 09:25 AM
  10. lumiarna's Avatar
    And I take it you went to

    Settings

    Cellular+sim

    Sim settings

    Then select 4G

    That's quite easy to miss but that's how I activated my 4G in uk
    01-19-2015 09:33 AM
  11. atchi123's Avatar
    I did indeed.
    01-19-2015 09:34 AM
  12. lumiarna's Avatar
    Hmmm... This is slightly out of my depth... Really sorry I can't give any more ideas... But the people here are great and will be able to come up with a solution
    01-19-2015 09:40 AM
  13. kristalsoldier's Avatar
    I did indeed.
    I am still not getting this. If we both have Apac-HK phones then how come yours does not pick up 4G and mine does? Very odd. I also tried with an EE chip today and it worked.
    01-19-2015 11:24 AM
  14. High Heels's Avatar
    I've had the same problem with the NL 930 Country Variant 000-HU in Czech Republic. Strange was, that I've had LTE in Czech T-Mobile network, but after I switched to O2 Czech, I didn't see 4G item in data menu. I flashed the German Country Variant image 000-DE and it is working like a charm. I have also tried to flash original 000-HU image again, and 4G was working too (it has been probably newer image). So I recommend you to flash UK Country Variant image.
    01-19-2015 01:25 PM
  15. rockstarzzz's Avatar
    Thanks rockstarzzz. Do you think it will fix the 4G issue?


    Yes Denmark or Finland ROM both are compatible with UK 4G bands.
    01-20-2015 02:37 AM
  16. atchi123's Avatar
    so re-flashed the phone with GB ROM but still no 4G available is it possible that the phone hardware antenna itself is simply different and incompatible with the EE 4G frequency band??
    01-23-2015 10:20 AM
  17. scottymc's Avatar
    Mate is the sim activated for 4G when I upgraded to 4G , Vodafone didn't set my sim up correctly.. Carphone Warehouse did the upgrade and didn't tell Vodafone its been upgraded to 4G ... Took two weeks for them to sort it out .
    01-23-2015 01:05 PM
  18. atchi123's Avatar
    Cheers but Yeah double checked with EE and its 4G activated
    01-23-2015 01:12 PM
  19. gMaesterUK's Avatar
    Try roaming to another network, like Orange or T-Mobile (I know, same network), then go back to EE again. Sometimes this forces the SIM & network to speak. Just make sure you've got Settings >> mobile+SIM >> SIM Settings >> Highest connection speed set as 4G before doing this.

    Failing this, you could ask EE to send a new 4G SIM card to test if it's just the SIM.

    G.
    01-23-2015 03:51 PM

Similar Threads

  1. Should I get the 930 now? I have Lumia 1020.
    By Artur Verdini Meireles1 in forum Nokia Lumia 930
    Replies: 17
    Last Post: 01-22-2015, 01:59 AM
  2. Replies: 3
    Last Post: 01-18-2015, 07:40 PM
  3. Why doesn't Cortana work on the Microsoft Band?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-18-2015, 03:40 PM
  4. How do I change font size in texts?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-18-2015, 12:05 PM
  5. Where is battery fully charge icon on the Lumia 730?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-18-2015, 10:33 AM
LINK TO POST COPIED TO CLIPBOARD