1. Windows Central Question's Avatar
    I've set the Messaging alerts in 'notifications+actions' so that everything is turned on. However, I don't get any audio or vibrate alert when a text message arrives.

    I've got the same settings for Whatsapp, and it functions as expected.

    Does anyone have any ideas?

    Thanks in advance.
    03-03-2015 12:24 PM
  2. Muhamad Idaham Umar Ong's Avatar
    Hi guys,

    After going through the net trying to find a way to get my SMS/Messaging notification to work and not finding any workable solution, I've decided to go through my all of windows 10 mobile setting once again to see whether there is a way to solve this issue. And yes problem solved (for me anyway). No factory reset and no installing additional app

    I've detailed out all the action i've taken for your reference. This is not a sure fire way to solve the problem and its only work for me and my phone on the 17/1/2016 GMT+8.

    My phone spec was:
    Phone : Nokia Lumia 1020 (Lumia Cyan)
    Os build: 10.0.10586.63

    So here is the detail steps i've taken chronologically in solving my SMS/Messaging notification issue

    Previous Settings related to the issue of "Messaging"

    1. "Notification and actions" under "System"
    I'm guessing my case is similar to everyone, the "Messaging" option is not to be found in the "Show notifications from these apps"

    2. "Lock screen" under "Personalization"
    2.1 My "Choose app to show detailed status" was set to "Whatsapp"
    2.2 As always I've also chosen "Messaging" in the "Choose apps to show quick status"

    3. "Messaging" under "Privacy"
    Chosen option ON for "Let apps read or send messages (text or MMS)".

    4. "Background apps" under "Privacy"
    4.1 "Messaging + Skype" was disabled

    Solving the issue
    1. "Background apps" under "Privacy"
    Turn ON the option

    2. "Lock screen" under "Personalization"
    Change "Choose app to show detailed status" from "Whatsapp" to "Messaging"

    3. "Messaging" under "System"
    Turn ON all option (Yes, I really meant ALL OPTION)

    Then I've restart my phone and asked my wife to send me one short message through the SMS/Messaging app and I've heard the sweet sound of SMS/Messaging and what a beautiful site seeing the message on my phone lock screen. And finally the "Messaging" is shown in the "Notification and actions" (after restarting).

    Then I reverting back a few setting after solving the issue and the SMS/Messaging notification still works

    1. "Lock screen" under "Personalization"
    I've changed it back to "Whatsapp"

    2. "Messaging" under "System"
    Disable all the options under the "SMS/MMS"

    Hope this solution will work for you phone as well.

    Thank you.
  3. ven07's Avatar
    Is Quiet Hours on by any chance? :P A soft reset might help
    03-03-2015 12:39 PM
  4. Graham J Lewis's Avatar
    I'm the OP (just registered).

    Thanks for your help ven07 I've tried a reboot and checked quiet hours. No luck.

    It's odd, Whatsapp has exactly the same settings and works fine.
    ven07 likes this.
    03-03-2015 01:07 PM
  5. ven07's Avatar
    Well messaging is a systems app, so if you're desperate enough then a hard reset could be on the cards..
    03-03-2015 01:33 PM
  6. ven07's Avatar
    03-03-2015 01:33 PM
  7. Graham J Lewis's Avatar
    Ah, I've sorted it.

    In Messaging and then Settings, the 'Receive Texts Using' was set to messaging+. I changed that to Messaging (default) and it's working again (even though I had the same alerts set for messaging+).

    Thanks for your help ven07. It prompted me to dig around more.
    03-03-2015 02:29 PM
  8. SamJHannan's Avatar
    Ah, I've sorted it.

    In Messaging and then Settings, the 'Receive Texts Using' was set to messaging+. I changed that to Messaging (default) and it's working again (even though I had the same alerts set for messaging+).

    Thanks for your help ven07. It prompted me to dig around more.
    You can receive texts using another app?
    03-03-2015 02:33 PM
  9. Graham J Lewis's Avatar
    I'm not sure SamJHannan, pure sms no, I suppose its just the usual text messaging function.
    03-03-2015 02:38 PM
  10. ven07's Avatar
    Which carrier do you use Lewis?
    03-03-2015 03:16 PM
  11. Muhamad Idaham Umar Ong's Avatar
    Hi guys,

    After going through the net trying to find a way to get my SMS/Messaging notification to work and not finding any workable solution, I've decided to go through my all of windows 10 mobile setting once again to see whether there is a way to solve this issue. And yes problem solved (for me anyway). No factory reset and no installing additional app

    I've detailed out all the action i've taken for your reference. This is not a sure fire way to solve the problem and its only work for me and my phone on the 17/1/2016 GMT+8.

    My phone spec was:
    Phone : Nokia Lumia 1020 (Lumia Cyan)
    Os build: 10.0.10586.63

    So here is the detail steps i've taken chronologically in solving my SMS/Messaging notification issue

    Previous Settings related to the issue of "Messaging"

    1. "Notification and actions" under "System"
    I'm guessing my case is similar to everyone, the "Messaging" option is not to be found in the "Show notifications from these apps"

    2. "Lock screen" under "Personalization"
    2.1 My "Choose app to show detailed status" was set to "Whatsapp"
    2.2 As always I've also chosen "Messaging" in the "Choose apps to show quick status"

    3. "Messaging" under "Privacy"
    Chosen option ON for "Let apps read or send messages (text or MMS)".

    4. "Background apps" under "Privacy"
    4.1 "Messaging + Skype" was disabled

    Solving the issue
    1. "Background apps" under "Privacy"
    Turn ON the option

    2. "Lock screen" under "Personalization"
    Change "Choose app to show detailed status" from "Whatsapp" to "Messaging"

    3. "Messaging" under "System"
    Turn ON all option (Yes, I really meant ALL OPTION)

    Then I've restart my phone and asked my wife to send me one short message through the SMS/Messaging app and I've heard the sweet sound of SMS/Messaging and what a beautiful site seeing the message on my phone lock screen. And finally the "Messaging" is shown in the "Notification and actions" (after restarting).

    Then I reverting back a few setting after solving the issue and the SMS/Messaging notification still works

    1. "Lock screen" under "Personalization"
    I've changed it back to "Whatsapp"

    2. "Messaging" under "System"
    Disable all the options under the "SMS/MMS"

    Hope this solution will work for you phone as well.

    Thank you.
    mrsmac717 likes this.
    01-17-2016 12:16 AM
  12. Syed Naveed Asghar's Avatar
    I had the same problem, sorted it out by your tutorial :) Thanks buddy, you made me day :)
    02-20-2016 11:09 AM
  13. RUPINDER KANWAR's Avatar
    Have you used a pair of headphones recently? That might be the issue. Just plug them in again, listen through them, and plug them out again. The sounds may start playing through internal speakers again. Sometimes the earphone jack leaves the inner receptacle pressed.
    04-14-2016 09:53 AM
  14. QuadraFX's Avatar
    Have you used a pair of headphones recently? That might be the issue. Just plug them in again, listen through them, and plug them out again. The sounds may start playing through internal speakers again. Sometimes the earphone jack leaves the inner receptacle pressed.
    Sometimes it's enough to read the whole thread to know that the problem was solved in totally different way...

    But to stay on topic, I had exactly the same problem recently - no notifications on the phone, but my Band was alarming me about incoming messages. I realized then that I have disabled some background applications...
    It's a pity that Skype and messaging are under the same background switch.
    04-21-2016 07:40 AM
  15. Bizarro_Prime's Avatar
    There is a review on the store for the messaging+skype app that says notifications stopped working when the reviewer updated the app.
    I had the same problem and I ended up doing a full wipe on my 930. I have the update for messaging+skype waiting but I'm not doing it because everything is working as it should at the moment.
    05-23-2016 05:27 AM
  16. mrsmac717's Avatar
    Hi guys,

    After going through the net trying to find a way to get my SMS/Messaging notification to work and not finding any workable solution, I've decided to go through my all of windows 10 mobile setting once again to see whether there is a way to solve this issue. And yes problem solved (for me anyway). No factory reset and no installing additional app

    I've detailed out all the action i've taken for your reference. This is not a sure fire way to solve the problem and its only work for me and my phone on the 17/1/2016 GMT+8.

    My phone spec was:
    Phone : Nokia Lumia 1020 (Lumia Cyan)
    Os build: 10.0.10586.63

    So here is the detail steps i've taken chronologically in solving my SMS/Messaging notification issue

    Previous Settings related to the issue of "Messaging"

    1. "Notification and actions" under "System"
    I'm guessing my case is similar to everyone, the "Messaging" option is not to be found in the "Show notifications from these apps"

    2. "Lock screen" under "Personalization"
    2.1 My "Choose app to show detailed status" was set to "Whatsapp"
    2.2 As always I've also chosen "Messaging" in the "Choose apps to show quick status"

    3. "Messaging" under "Privacy"
    Chosen option ON for "Let apps read or send messages (text or MMS)".

    4. "Background apps" under "Privacy"
    4.1 "Messaging + Skype" was disabled

    Solving the issue
    1. "Background apps" under "Privacy"
    Turn ON the option

    2. "Lock screen" under "Personalization"
    Change "Choose app to show detailed status" from "Whatsapp" to "Messaging"

    3. "Messaging" under "System"
    Turn ON all option (Yes, I really meant ALL OPTION)

    Then I've restart my phone and asked my wife to send me one short message through the SMS/Messaging app and I've heard the sweet sound of SMS/Messaging and what a beautiful site seeing the message on my phone lock screen. And finally the "Messaging" is shown in the "Notification and actions" (after restarting).

    Then I reverting back a few setting after solving the issue and the SMS/Messaging notification still works

    1. "Lock screen" under "Personalization"
    I've changed it back to "Whatsapp"

    2. "Messaging" under "System"
    Disable all the options under the "SMS/MMS"

    Hope this solution will work for you phone as well.

    Thank you.
    Phone: Nokia Lumia Icon (929)
    OS Build: 10.0.10586.494

    After searching all over and trying all kinds of things, this solution worked for me. Thanks!!
    08-06-2016 08:24 AM
  17. KrishnaRao Vasudevan's Avatar
    It works fine now. I have switched off this in Background Apps. When I switched it on it worked fine. No resetting the mobile is necessary, sure. Thanks Dear Friend
    08-20-2016 08:19 AM
  18. klnh03's Avatar
    It works fine now. I have switched off this in Background Apps. When I switched it on it worked fine. No resetting the mobile is necessary, sure. Thanks Dear Friend
    08-20-2016 01:01 PM
  19. klnh03's Avatar
    My nokia 1020 also suddenly stopped giving me audio notice of text messages. I found that the phone was still in driving mode and my Bluetooth connection to my hands free speaker in car was still on. So I turned those functions off and audio alerts are back on.
    08-20-2016 01:04 PM
  20. e94mli's Avatar
    Not the exactly the same issue but what I discovered when I couldn't get text notifications was that "Show notifications on the lock screen" needs to be on for the sounds to work. Seems "Show and sound alarms and reminders when phone is locked" only applies to alarms and not other notifications.
    08-23-2016 03:01 AM
  21. Datcoldboi's Avatar
    Hi guys,

    After going through the net trying to find a way to get my SMS/Messaging notification to work and not finding any workable solution, I've decided to go through my all of windows 10 mobile setting once again to see whether there is a way to solve this issue. And yes problem solved (for me anyway). No factory reset and no installing additional app

    I've detailed out all the action i've taken for your reference. This is not a sure fire way to solve the problem and its only work for me and my phone on the 17/1/2016 GMT+8.

    My phone spec was:
    Phone : Nokia Lumia 1020 (Lumia Cyan)
    Os build: 10.0.10586.63

    So here is the detail steps i've taken chronologically in solving my SMS/Messaging notification issue

    Previous Settings related to the issue of "Messaging"

    1. "Notification and actions" under "System"
    I'm guessing my case is similar to everyone, the "Messaging" option is not to be found in the "Show notifications from these apps"

    2. "Lock screen" under "Personalization"
    2.1 My "Choose app to show detailed status" was set to "Whatsapp"
    2.2 As always I've also chosen "Messaging" in the "Choose apps to show quick status"

    3. "Messaging" under "Privacy"
    Chosen option ON for "Let apps read or send messages (text or MMS)".

    4. "Background apps" under "Privacy"
    4.1 "Messaging + Skype" was disabled

    Solving the issue
    1. "Background apps" under "Privacy"
    Turn ON the option

    2. "Lock screen" under "Personalization"
    Change "Choose app to show detailed status" from "Whatsapp" to "Messaging"

    3. "Messaging" under "System"
    Turn ON all option (Yes, I really meant ALL OPTION)

    Then I've restart my phone and asked my wife to send me one short message through the SMS/Messaging app and I've heard the sweet sound of SMS/Messaging and what a beautiful site seeing the message on my phone lock screen. And finally the "Messaging" is shown in the "Notification and actions" (after restarting).

    Then I reverting back a few setting after solving the issue and the SMS/Messaging notification still works

    1. "Lock screen" under "Personalization"
    I've changed it back to "Whatsapp"

    2. "Messaging" under "System"
    Disable all the options under the "SMS/MMS"

    Hope this solution will work for you phone as well.

    Thank you.


    NONE OF THE ABOVE mentioned steps worked for me. This Is how I managed to solve this issue for myself.

    1. Go to "Settings"
    2. Go to "Notifications & Actions"
    3. Go to the part where you can turn notifications off/on
    4. Make sure "Messaging" is turned ON
    5. Then press on messaging
    6. It will bring up another settings menu for Messaging
    7. Here you can see all notification settings for the selected app as well as view or setup the ringtone for the app.
    8. Find the setting that says "Keep Notifications Private On The Lock Screen"
    9. TURN IT OFF!!

    That's it. It fixed my problem. Sent sms from another phone & message is received playing the ringtone just as before. Shows up on lock screen & in notifications center just like before.

    Thanks! & good luck. Hope this tip is able to help anyone that is still facing this issue.
    09-29-2016 06:43 PM
  22. Dieter Gobbers's Avatar
    NONE OF THE ABOVE mentioned steps worked for me. This Is how I managed to solve this issue for myself.

    1. Go to "Settings"
    2. Go to "Notifications & Actions"
    3. Go to the part where you can turn notifications off/on
    4. Make sure "Messaging" is turned ON
    5. Then press on messaging
    6. It will bring up another settings menu for Messaging
    7. Here you can see all notification settings for the selected app as well as view or setup the ringtone for the app.
    8. Find the setting that says "Keep Notifications Private On The Lock Screen"
    9. TURN IT OFF!!

    That's it. It fixed my problem. Sent sms from another phone & message is received playing the ringtone just as before. Shows up on lock screen & in notifications center just like before.

    Thanks! & good luck. Hope this tip is able to help anyone that is still facing this issue.
    Awesome, that was the solution for me!
    07-26-2017 08:50 AM

Similar Threads

  1. Is there a music player app that allows folder view, not just artist/album/song?
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 06-17-2017, 12:15 PM
  2. Urge EA to optimize and update FIFA/FUT 15.
    By Ashwani Kumar Singh in forum Games
    Replies: 10
    Last Post: 12-23-2015, 05:18 AM
  3. CBC.ca News links never work on Windows Phone
    By fgaudet in forum Windows Phone 8.1
    Replies: 1
    Last Post: 03-03-2015, 12:28 PM
  4. Replies: 2
    Last Post: 03-03-2015, 12:07 PM
LINK TO POST COPIED TO CLIPBOARD