05-07-2014 06:07 PM
43 12
tools
  1. bruinsphan's Avatar
    Palandri I'm not sure what solution from jlesavoy you are referring to but if you mean the Access Point app then yes. I mentioned that in my very first post. I used that app from the start and it was great at getting everything working except the ability to receive mms. I continue to have the same issue. I asked in that thread if he could verify that he was receiving but he never answered. I would love to hear if anyone can receive mms on at&t.

    As far as your other questions, the phone was bought and activated on a friends Verizon account and was used for a few hours. When I got the phone all I did was pull out the Verizon sim and put my at&t sim into it. That is the beauty of gsm phones, no activation needed if they are unlocked. As long as you have a working sim and the correct apn settings its basically plug and play. Once again my only issue comes down to mms which seems crazy that they will send and amazingly fast at sending them too. As far as software updates are concerned, I'm not sure. I actually was wondering that myself. I obviously want to be able to upgrade to 8.1 when it is available so that would be my other concern as well.

    If anyone can help I would love to here from them.

    Thanks.
    palandri likes this.
    02-23-2014 09:20 PM
  2. Vmartinez39's Avatar
    I'd really like confirmation on AT&T SIM working on Lumia Icon. I'm interested in getting this device because of the fantastic camera it has.

    I bought a Lumia 928 used but was in mint condition. Only reason I got it is because the device comes unlocked and don't need to get a code or anything for it.

    I have a prepaid T-Mobile everything works Data, SMS, MMS (SMS in 2G only) and its a well documented on the 928 forums of working fully on EDGE.

    My main phone is on H2O wireless, an At&t MVNO. I have the same issue where I can't receive MMS messages and its the only reason I've not fully adopted the 928 as my main driver. I have Nexus 5 but the only reason I'm even exploring Lumia devices are because of the great camera they have.

    So yeah I'm really interested in confirming if users on AT&T and possible prepaid MVNO can receive MMS.

    Speaking from my 928 and testing all kind of MVNO carriers, the only one I got everything to work Data, MMS, SMS, in 3g/H/H+ was Net10 with the AT&T SIM. Just this weekend I finally was able to install the ACCESS POINT application everyone here talks about. It still wouldn't work. However, using my T-Mobile SIM, using Access Point was a breeze and at least didn't have to manually add APN like I did before getting Access Point.

    So yes, I'm interested if anyone got MMS to work too, and confirmed to work with prepaid wireless services even better.
    02-24-2014 12:30 PM
  3. gvp 1995's Avatar
    So did anybody actually tested Icon with T-Mo? What are the findings?
    02-24-2014 07:46 PM
  4. alinefx's Avatar
    Yeah it's lte compatible with tmobile band 4
    03-26-2014 03:16 AM
  5. Agustin Lopez's Avatar
    Where do you live? I live in Los Angeles and am not able to get LTE with a brand new Verizon Icon that I purchased. I can get LTE on my unlocked Nokia 1020 just fine but not the Icon?
    03-27-2014 03:19 PM
  6. Andygoes's Avatar
    So I thought that LTE wasn't working on my Icon - whenever I set the maximum speed to LTE, I would show no signal. After a conversation on Reddit, I decided to test it out again. Long story short, there is either a bug (or Verizon modified the firmware maliciously) that shows no signal when connected to T-Mobile's LTE (and perhaps other LTE networks abroad - haven't tested that yet). To test, install the Hardware Tests app and, on the first page, it will say what you are connected to and connection speed. You can also run a speed test in Microsoft's Network Speed Test app.

    I'm still testing it out, but I have run in to some downsides - apparently, texts don't go out very reliably (get the error "Can't send this message" immediately), and I have experienced some reboots. However, that was on a phone that I exchanged yesterday for another reason (gradient on screen) and am on my 2nd Icon now and will continue to test.

    Also, I'm in Michigan, which may make a difference. T-Mobile is continuing to roll out their LTE network on the 1700MHz band, so they may not have it up and running in your area yet.
    03-27-2014 10:28 PM
  7. camaroz1985's Avatar
    Got the same text problems with the 822 on T-mobile. Have to set data speed to 2g, or turn it off completely to send texts, either works.
    Andygoes likes this.
    03-28-2014 12:53 PM
  8. Aaron Schnieder's Avatar
    So can anyone in a strong LTE area confirm that they were able to get their Verizon Icon working on T-Mobile? Did you have to do anything to get it to work other than sticking the T-Mobile SIM in?

    What about developer unlocking the phone using tools from dev.windowsphone.com after signing up as a Win Phone developer? Would that ensure the Icon would work on T-Mobile?

    Thanks,

    Aaron
    04-03-2014 06:23 PM
  9. Andygoes's Avatar
    So can anyone in a strong LTE area confirm that they were able to get their Verizon Icon working on T-Mobile? Did you have to do anything to get it to work other than sticking the T-Mobile SIM in?

    What about developer unlocking the phone using tools from dev.windowsphone.com after signing up as a Win Phone developer? Would that ensure the Icon would work on T-Mobile?

    Thanks,

    Aaron
    I get LTE just fine. I think Verizon did something to the phone, however, to show no signal when connected to T-Mobile's LTE, in addition to occasional resets and the inability to send text messages unless forcing 2G.
    04-03-2014 11:47 PM
  10. Aaron Schnieder's Avatar
    I get LTE just fine. I think Verizon did something to the phone, however, to show no signal when connected to T-Mobile's LTE, in addition to occasional resets and the inability to send text messages unless forcing 2G.
    Thanks Andy! If you turn down the data speed to 3G does that fix text messaging or do you have to go all the way down to 2G?
    04-04-2014 12:52 AM
  11. camaroz1985's Avatar
    I had to turn it down to 2G on my 822, 3G still didn't work. Maybe with WP8.1 and the quick settings you could switch back and forth easier, but with the current way it is a PITA.
    sraina likes this.
    04-07-2014 01:23 PM
  12. VenumX's Avatar
    I had to turn it down to 2G on my 822, 3G still didn't work. Maybe with WP8.1 and the quick settings you could switch back and forth easier, but with the current way it is a PITA.
    same with me, I have tested my Lumia Icon working on LTE in Tennessee and had full LTE speeds, showed no signal unable to call / sms / mms. Change to 3g, same issue, changed to 2g calls / sms / mms working but slow speeds ( obviously ). I believe our only hope to have this fully working is either the developer preview of 8.1 ( we should know in a few days if that fixes it ) or when Nokia / Verizon release the Cyan update to our phones. And that's if Verizon didn't find a loophole in their requirement to leave the band unlocked and take advantage of it by purposely disabling the reception bars at that level.
    04-09-2014 10:54 PM
  13. Games Goblin's Avatar
    Anyone looking at buying the icon for use on T-Mo or ATT would do well to wait for the lumia 930 to launch in the US. Its basically the icon minus the CDMA radios but with GSM lte bands.

    And doesn't Verizon program the GSM part of their phones in such a way that it rejects US based sim cards but accepts only international ones?

    Posted via the WPC App for Android!
    04-10-2014 04:02 AM
  14. sraina's Avatar
    Anyone looking at buying the icon for use on T-Mo or ATT would do well to wait for the lumia 930 to launch in the US. Its basically the icon minus the CDMA radios but with GSM lte bands.

    And doesn't Verizon program the GSM part of their phones in such a way that it rejects US based sim cards but accepts only international ones?

    Posted via the WPC App for Android!
    Yes but on the Lumia 930, there will be no LTE for either T-Mobile or AT&T. Verizon accepts US SIMs and T-Mobile SIM works just fine, gets LTE data but for some strange reason the phone does not show the signal symbol on the menu bar. At times, it seems as though the phone does not have any signal
    04-10-2014 09:02 AM
  15. sraina's Avatar
    Well the 930 will not get LTE speeds on either T-Mobile or AT&T based on the specs of that device (European version). Version does not reject US SIMs. The Lumia icon works fine with T-Mobile SIM and does get LTE (Depending on coverage of course). For some reason though, the signal indicator does not show the 'LTE' symbol - quite a few users have mentioned this.
    04-10-2014 09:06 AM
  16. Games Goblin's Avatar
    Ah, I thought the 930 was going to make its way to ATT and/or T-Mobile. My bad!

    T-Mobile needs a flagship windows phone asap if they won't be bringing in the 930

    Posted via the WPC App for Android!
    04-10-2014 11:20 AM
  17. Aaron Schnieder's Avatar
    Solution posted here.

    I spun off a new thread because I didn't want the settings to get lost on the bottom of this thread.
    Games Goblin likes this.
    04-10-2014 07:42 PM
  18. sweetmusicd's Avatar
    I purchased my Icon from the MS store in California and am trying to use it up hear in Canada on the Telus network. Both Verizon and Telus work on the same band and frequencies. I was able to get SMS, MMS working after downloading Access Point and changing location settings. I can get H and H+ but when I move cellular settings to LTE the signal icon goes off and it says I have no service. The mode selection under cellular setting is grayed out and I cant choose between 1)LTE, GSM, or UMTS and 2)LTE, CDMA. It is permanently on LTE, GSM, or UMTS. I am thinking this is the issue. Did Verizon disable this feature when you are not using them so you can't get LTE if you live in North America. I think I am in the same boat as somebody trying to use this phone on ATT or TMobile. I live in an area with excellent LTE coverage and even put my nano sim into a coworkers iphone 5S and it came up LTE right off the bat. I'm frustrated because Verizion wont even say Hi to me on the phone when I try to talk with them about the issue because I am not a paying customer. I just feel like I need to get the option to switch to LTE, CDMA on my phone and then I could use LTE on my Telus network. I know the speed increase is really not that big of deal but it's just the fact that I have LTE capabilities but I can't use them. Ugggg! When will Canada get a decent Windows Phone so I don't have to go through all this??!!
    05-07-2014 06:07 PM
43 12

Similar Threads

  1. Flappy Bird 2 now available on Windows Phone
    By codingforfun44 in forum App Spotlight
    Replies: 6
    Last Post: 03-07-2014, 01:36 PM
  2. IE11 and File Explorer on WP8.1 Preview {VIDEO}
    By Zapella Tiago in forum Windows Phone 8.1
    Replies: 13
    Last Post: 02-20-2014, 07:21 AM
  3. Lenovos Yoga 2 11-inch hybrid goes on sale in the US for only $549
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-19-2014, 03:00 PM
  4. Preorder Wolfenstein: The New Order on Xbox and get Doom beta access
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-19-2014, 02:00 PM
  5. Windows Phone 8.1s new Wi-Fi settings reveal auto turn-on feature
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-19-2014, 12:30 PM
LINK TO POST COPIED TO CLIPBOARD