06-25-2016 05:57 PM
72 123
tools
  1. jlesavoy's Avatar
    Hello,

    I purchased a new icon on Thursday. I am an AT&T customer, so I replaced the VZ nano sim with an ATT nano SIM. The phone works great as a phone, I have HSPDA+ for internet, which is downloading and uploading at around 3MBs according to the speedtest.net app. BUT, I do have the following issues that I was hoping someone could help me with.

    1. The Verizon splash screen is something I would like to remove (minor)

    2. No MMS: Where is the MMSC APN field? There is one for internet under Settings -> cellular, but no MMSC APN. I compared this screen with a Lumia 1020, and it looks exactly the same, except there is a second button for APNs labeled New MMSC APN. This means that multi-media messaging is not working. SMS works fine.

    3. Voicemail and contacts are strangely unstable. What I mean by that is visual voicemail works sometimes. It keeps asking me to enter my vmail pin, which I do, and it fails. Every once in a while it accepts the pin, and the visual voicemail works for a short time. Also, if I call my voicemail, it does not automatically recognize my phone number, and therefore can not associate my phone with my vm box. The phone has similar issues identifying phone numbers that are already in my contact list. I believe this has something to do with the fact that there appears to be an extra '1' put in front of some numbers.

    Other than that, I think this phone is awesome!

    If anyone needs any help doing what I did, let me know. And if anyone can help me, I would appreciate it!

    Thanks
    02-22-2014 02:01 PM
  2. bruinsphan's Avatar
    It looks like you and I are in the same boat here so hopefully we can get this figured out as I also am very happy with this phone. I will say that I am able to send mms messages just cannot receive them. I downloaded the Access Point app and everything seems to be working except, as I said, the receiving of mms.
    02-22-2014 08:16 PM
  3. scottitude's Avatar
    Can't answer your questions but I would be surprised if using - or *trying* to use - the Icon on AT&T didn't leave gaping holes in the user experience.
    02-22-2014 08:33 PM
  4. jgbstetson's Avatar
    Have you guys tried the Nokia Access Point App yet?
    02-22-2014 08:34 PM
  5. bruinsphan's Avatar
    jlesavoy lets keep this thread going so that hopefully we can find a fix for our problems so we can continue to enjoy our phones.
    02-22-2014 08:34 PM
  6. bruinsphan's Avatar
    scottitude the phone works pretty damn good on at&t as both of us have stated with the exception of the mms issue for me and the voicemail issue jlesavoy is having (I use google voice). jgbstetson I did download and am using the Access Point app and as I said I have no problems sending mms only issue on the phone for me is receiving mms.
    02-22-2014 08:39 PM
  7. scottitude's Avatar
    It's great that you're satisfied, that's all that matters with any consumer product. For me, no mms and/or inconsistent voicemail access would be deal-breakers, especially on such a great phone like the Icon. I want a full-featured experience so I've gotten used to size of the monolithic 1520.
    02-22-2014 09:18 PM
  8. jgbstetson's Avatar
    scottitude the phone works pretty damn good on at&t as both of us have stated with the exception of the mms issue for me and the voicemail issue jlesavoy is having (I use google voice). jgbstetson I did download and am using the Access Point app and as I said I have no problems sending mms only issue on the phone for me is receiving mms.
    I had that same problem using a 1520 on T-Mobile. The solution was to wipe all the internet and mms apns under cellular settings and manually create a new access point. When I used both cellular and access point, they seemed to conflict even though they were set to the exact same thing. But that wouldn't really apply here, sorry. Good luck to you both, I really like the Icon.
    Last edited by jgbstetson; 02-22-2014 at 10:12 PM.
    02-22-2014 10:00 PM
  9. jlesavoy's Avatar
    I found the answer to the MMS issue (as it sounds like a few of you did, as well). I couldn't find the Access Point App just by searching on the Windows Store. But, I used the link in another thread here, about Rogers MMS issues on the Lumia 920, and that took me to the app, which installed, and automatically re-enabled the MMSC fields, and populated them. So, the only real issue I have remaining is the Voicemail issue. What is odd, is that if I dial the normal access number or AT&T Voicemail (253-709-4025), it doesn't recognize my phone and says it needs more information. I think the reason is because Verizon might insert a +1 in front of caller id, which is not what AT&T expects (or visa versa). What I really am trying to figure out is how I got it to work once (because it did work once).
    02-23-2014 12:21 AM
  10. bruinsphan's Avatar
    Are you able to send and receive mms? I have had no problems sending mms buy I can't receive. Can you please confirm?
    02-23-2014 12:31 AM
  11. gvp 1995's Avatar
    I am with T-Mobile, but I think the issues will be similar to ATT. Couple of questions

    - did any of you get LTE with ATT (there were conflicting suggestions if it was possible)?
    - does everybody have this issue with Voicemail?

    This mess with the numbers seems like small thing, but in reality can be very crippling. A family member is using Verizon x8 on T-Mobile, and there is a famous problem of not being able to answer text messages. I suspect the reason is the same as yours - they either stick a spare +1 when answering text, or do something similar, but T-Mobile does not recognize it. As a matter of fact, could someone test this issue? See if it is possible to have SMS conversation back and forward in one thread
    02-23-2014 12:40 AM
  12. bruinsphan's Avatar
    I have no problems having a conversation back and forth in an sms thread and once again have no problems sending mms. My only issue is when receiving an mms (which includes group texts) I cannot receive.
    02-23-2014 08:35 AM
  13. bruinsphan's Avatar
    Sorry also, no LTE only HSPA+ which I am fine with since I am coming from a Nexus 4 with no LTE. Also in case it matters or it helps anyone else I am in the Los Angeles area.
    02-23-2014 08:37 AM
  14. jlesavoy's Avatar
    Are you able to send and receive mms? I have had no problems sending mms buy I can't receive. Can you please confirm?
    I have the exact same issue. I can send but not receive MMS. I'm still working on it, though. I think my voicemail issue is actually my account, not the phone. I am on hold with ATT right now. I will post when I get it resolved.
    02-24-2014 09:22 AM
  15. bruinsphan's Avatar
    jlesavoy Thanks for the update. I was just about to call at&t and see if they could help at all also. I will wait and see what you find out otherwise I may have to return mine and go back to an at&t phone as I greatly depend on using group and picture messaging. I hate to lose the amazing screen on the icon if I don't have to. Please post your results when you have them.
    02-24-2014 10:16 AM
  16. bruinsphan's Avatar
    Any word on help from support???
    02-24-2014 12:13 PM
  17. jlesavoy's Avatar
    I haven't gotten very far with support. I think the mistake I made is that I changed the IMEI on my account for this line to the IMEI of my icon. This seems to have confused their system since they obviously don't have a Lumia 929 profile. I have two possible solutions, which I will try later today or tomorrow if I have some time. The first is to switch out my IMEI with that of a 1520 (which is the closest AT&T model to the Icon), the second, and I could use some outside advice on this one, is to reflash the icon with the NaviFirmPlus profile of a 1520 for AT&T. I am not so sure on that one, since I don't have a full understanding of the relationship between those images, drivers, and the difference in the hardware between the two devices.
    02-24-2014 03:12 PM
  18. psiu_glen's Avatar
    I haven't gotten very far with support. I think the mistake I made is that I changed the IMEI on my account for this line to the IMEI of my icon. This seems to have confused their system since they obviously don't have a Lumia 929 profile. I have two possible solutions, which I will try later today or tomorrow if I have some time. The first is to switch out my IMEI with that of a 1520 (which is the closest AT&T model to the Icon), the second, and I could use some outside advice on this one, is to reflash the icon with the NaviFirmPlus profile of a 1520 for AT&T. I am not so sure on that one, since I don't have a full understanding of the relationship between those images, drivers, and the difference in the hardware between the two devices.
    Ehhhhhhhh, outside of different screen tech, micro-SD available in 1520, wireless charging built in to Icon, CDMA/LTE radios for the Icon, not much. What could go wrong?!



    (I wouldn't do it)
    Starrbuck and hopmedic like this.
    02-24-2014 10:14 PM
  19. jlesavoy's Avatar
    I didn't say it was a good idea... Just an idea.
    02-25-2014 11:05 AM
  20. bruinsphan's Avatar
    Well I hate to say it but I think that I am out with the Icon. Unless someone can come up with a solution on the receiving mms in the next day I am going to return mine and wait for an equivalent to come to att.
    02-26-2014 12:22 PM
  21. gvp 1995's Avatar
    Well I hate to say it but I think that I am out with the Icon. Unless someone can come up with a solution on the receiving mms in the next day I am going to return mine and wait for an equivalent to come to att.
    I was thinking to get it for T-Mobile. No one reported on T-Mo yet, but based on my previous experience, and all the info I received, the following can be expected:

    1. It will be unlocked out of the box
    2. There will be no LTE speed
    3. As it is reported in this thread, to put it to work with T-Mo data plan additional tweacks may be needed (install Access Point app)
    4. No guarantee all features will work. Like receiving MMS or something like not being able to reply to text messages (similar to Verizon x8 on T-mo)
    5. No guarantee the updates will be coming. (Verizon x8 on T-Mo never received GDR3 for example)

    So I give up. I will be waiting for global version - 929.
    02-26-2014 12:53 PM
  22. jlesavoy's Avatar
    I solved the voicemail issue by changing my IMEI in my account to the IMEI of a Lumia 920 I have. Once applied, I rebooted the phone and the visual voicemail accepted my password and started to work.

    Still working on the MMS issue.
    02-26-2014 09:40 PM
  23. alfaro58's Avatar
    did u still working on mms issue or it working fine for u ?
    03-04-2014 02:07 AM
  24. jlesavoy's Avatar
    I'm still working on it. I have tried everything possible, but no luck so far.
    03-04-2014 06:43 PM
  25. carguy303's Avatar
    Is the mms issue present with a T-Mobile sim or is this an issue for all GSM carriers?
    03-05-2014 03:56 PM
72 123

Similar Threads

  1. one of the best Music Player in WP8
    By Harshana Abeysinghe in forum Applications
    Replies: 2
    Last Post: 09-25-2014, 09:01 AM
  2. Who has made the iPhone switch?
    By shaskell724 in forum Nokia Lumia Icon
    Replies: 40
    Last Post: 04-07-2014, 09:13 PM
  3. Watch the 2014 Daytona 500 with NASCAR app for Windows and Windows Phone 8
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-08-2014, 12:51 PM
  4. What is this wallpaper?
    By dlalonde in forum Wallpapers & Ringtones
    Replies: 5
    Last Post: 02-24-2014, 12:04 PM
  5. Insider showing 1gb of ram in lumia 1520.
    By stylo388 in forum Nokia Lumia 1520
    Replies: 6
    Last Post: 02-23-2014, 03:41 PM
LINK TO POST COPIED TO CLIPBOARD