1. jrotunda's Avatar
    So I made the leap from my iPhone 5S to the Icon on Friday and I'm enjoying it thus far. One thing I've noticed; however, is that the Verizon Network signal strength isn't nearly as good and I'm not sure if there's a way to reset it or others can confirm. For example at my house, where I always had 3-4 bars of LTE with my iPhone 5s and the 5 before it - I now can only get 2 with the Icon. Any ideas?
    02-22-2014 03:25 PM
  2. DeathByPlant's Avatar
    it's the same with me too, anyone know anything about this?
    02-22-2014 04:01 PM
  3. jrotunda's Avatar
    Now it's actually down to 3G at 3 bars - no LTE at all 😐
    02-22-2014 04:13 PM
  4. TheZuneLune's Avatar
    No problems with 4g for me and call quality is in par with my 928.
    02-22-2014 04:15 PM
  5. Zippier's Avatar
    So I made the leap from my iPhone 5S to the Icon on Friday and I'm enjoying it thus far. One thing I've noticed; however, is that the Verizon Network signal strength isn't nearly as good and I'm not sure if there's a way to reset it or others can confirm. For example at my house, where I always had 3-4 bars of LTE with my iPhone 5s and the 5 before it - I now can only get 2 with the Icon. Any ideas?
    We have an iPhone 5s user and 2 Windows Phone users in our house and we almost always have different sets of signal strengths. I wouldn't be surprised if it has to do with the manufacturer and how the phone reads the signal etc. If you have the old iPhone sitting around still, you might try downloading a speed checking app to each and see that they say.
    02-22-2014 05:30 PM
  6. w4rmk's Avatar
    Mine is exactly the same if not slightly better. With my iPhone 5S I get 2 bars of LTE at my house and the Icon bounces between 2 and 3 bars of LTE. This morning my wife and I went to our favorite breakfast restaurant where we eat every Saturday morning. With my iPhone 5S I would usually get no service or very poor service. I know this specifically because it's always a source of frustration for me every weekend. Today was the first day with the new Icon and the "restaurant test". The Icon dropped down to 3G with 2 bars and I was browsing the web just fine. Much better than the iPhone 5S which wouldn't give up trying to hang onto LTE resulting in almost no data throughput.
    02-22-2014 05:33 PM
  7. srmccoy's Avatar
    You also have to realize that the signal indicators on mobile phones are pretty arbitrary, and actually have little to do with actual reception. It may give you a general idea of what you're going to get, but isn't guaranteed to be accurate. Also, Apple in the past has been caught showing more bars than they should. Around the time of the iPhone 4 and the antennagate stuff they actually came out and said they were displaying signal accuracy wrong and re-calibrated it.

    As long as you're getting the speeds you should be getting and you're not dropping calls I would not worry about it.
    videoouija likes this.
    02-22-2014 06:26 PM
  8. sectime's Avatar
    I was in an area today that has AWS band activated. Both my Icon and wife's 5s had 4 bars. Download speeds were low 50's . However the upload speed s the 5s was much faster. Just another useless data point but I have not noticed any performance difference between the two.
    02-22-2014 06:38 PM

Similar Threads

  1. Email delivery failed on strong Wifi signal
    By Dadstar0410 in forum Windows Phone 8
    Replies: 6
    Last Post: 05-27-2014, 06:30 PM
  2. Download of 98MB File via mobile network?
    By cjloyola in forum Nokia Lumia 720
    Replies: 7
    Last Post: 02-23-2014, 05:03 AM
  3. T-Mobile 925 on AT&T Network
    By ad2107 in forum Nokia Lumia 925
    Replies: 3
    Last Post: 02-22-2014, 03:49 PM
  4. NOKIA ICON simultaneous data and voice on Verizon network?
    By Marcin_S in forum Nokia Lumia Icon
    Replies: 15
    Last Post: 02-19-2014, 08:29 AM
  5. My Lumia 820 loosing network connection
    By Tushar Biswas in forum Nokia Lumia 820
    Replies: 3
    Last Post: 02-11-2014, 01:25 PM
LINK TO POST COPIED TO CLIPBOARD