1. romant56's Avatar
    Hey guys,

    So amazon just sent my replacement Icon after the camera stopped working on the first one. I have not even activated it or signed in with an account yet, but the Wifi is terrible. I noticed when I first connected near my router that it only had two bars, which I thought was strange. When I go to the corner of my house, it loses the signal completely!

    My 8X nearly always has full bars when you look at Wifi under settings. In the same corner of my house where the Icon lost signal my 8X was at full or down by one bar and showed about 20 other networks of varying strengths from my neighbors' houses. The Icon showed maybe two at zero bars and only intermittently showed my own network!

    Activating the phone has nothing to do with Wifi strength, right? Did I get another broken phone???
    03-11-2014 03:55 PM
  2. cbreze's Avatar
    Hey guys,

    So amazon just sent my replacement Icon after the camera stopped working on the first one. I have not even activated it or signed in with an account yet, but the Wifi is terrible. I noticed when I first connected near my router that it only had two bars, which I thought was strange. When I go to the corner of my house, it loses the signal completely!

    My 8X nearly always has full bars when you look at Wifi under settings. In the same corner of my house where the Icon lost signal my 8X was at full or down by one bar and showed about 20 other networks of varying strengths from my neighbors' houses. The Icon showed maybe two at zero bars and only intermittently showed my own network!

    Activating the phone has nothing to do with Wifi strength, right? Did I get another broken phone???
    Have you tried a factory reset yet? Wouldn't hurt.
    03-11-2014 04:08 PM
  3. romant56's Avatar
    Just did a factory reset just in case and no difference. Lost signal in my bedroom where my 8X has full bars. This is ridiculous. Oh well, back to amazon, again.
    03-11-2014 04:22 PM
  4. explosive0's Avatar
    Sorry, man. I had a few quality issues with my 920 a while back. Hopefully, the third time's a charm.
    03-11-2014 04:30 PM
  5. poddar's Avatar
    So after reading your post, I tested my Icon against my wife's iPhone. Her phone showed two of three bars/segments when the Icon showed one of four, but in six tests pitting one against the other, the Icon was at least as quick and a couple of times was quicker to complete a connection. I used the same urls on both phones testing the wifi. I haven't tested cellular, but I've used it several times and it works just fine. I've only had the phone for four days, but next to the Icon, the iPhone seems like a toy where the Icon seems like a small computer.
    03-11-2014 06:36 PM
  6. jayblazer's Avatar
    That stinks man. I just got my second Icon because the battery went bad in mine. Hopefully this one holds up.
    03-11-2014 06:41 PM
  7. anon8657740's Avatar
    From what I've seen and heard, the icon seems to not be so great at WiFi... At my school my old galaxy used to connect easier but honestly who knows. I don't necessarily think your phone is defective, I honestly think all icons are just slightly weak with WiFi but it might also just be in my head. Sometimes I see only one bar but it still loads everything pretty fast so maybe it just doesn't present the connection status very accurately. Anyway I wish u luck!
    03-11-2014 07:11 PM
  8. Indistinguishable's Avatar
    From what I've seen and heard, the icon seems to not be so great at WiFi... At my school my old galaxy used to connect easier but honestly who knows. I don't necessarily think your phone is defective, I honestly think all icons are just slightly weak with WiFi but it might also just be in my head. Sometimes I see only one bar but it still loads everything pretty fast so maybe it just doesn't present the connection status very accurately. Anyway I wish u luck!
    My WiFi has been nothing but fantastic.

    That stinks man. I just got my second Icon because the battery went bad in mine. Hopefully this one holds up.
    What do you mean the battery "went bad"?
    03-11-2014 07:45 PM
  9. jayblazer's Avatar
    See my thread. Last night my phone went from 60% to dead in about half an hour.
    03-11-2014 07:53 PM

Similar Threads

  1. UK information in my new 1520 - where to set it back?
    By TemporalPsychosis in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 03-13-2014, 12:03 PM
  2. Sandisk's 128 GB microSDXC card reportedly works with the Lumia 1520
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 5
    Last Post: 03-12-2014, 11:41 AM
  3. These are the best weather apps for Windows 8 right now
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-11-2014, 03:38 PM
  4. Replies: 2
    Last Post: 03-11-2014, 03:02 PM
  5. Microsoft looking to make Skype business friendly with new patent filing
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-11-2014, 01:02 PM
LINK TO POST COPIED TO CLIPBOARD