02-16-2015 11:07 PM
169 ... 34567
tools
  1. MobileVortex's Avatar
    I don't think it's the radio; with the recent 8.0 update my wifi iwas working great. then I did the 8.1 update and it went kaflooey again.

    HMM mine seem to be the same on both of them. Firmware update's are the only way they can change the drivers so thats why i think thats the only hope to fix my problem. If it doesnt i will be contacting Nokia/Microsoft for a replacement or some other kind of fix.
    06-05-2014 04:15 PM
  2. JetFixxxer's Avatar
    If I knew the ICON wifi was this crappy I wouldn't have purchased. I have my phone leaning about my router and it's telling me there isn't a network. It's amazing that two iPhones, Galaxy s3, Acer A500, MiiX8, and both my Roku are connected without issue. Some of these have 5ghz as well.
    06-08-2014 07:37 PM
  3. quantum tao's Avatar
    i have noticed my wifi being more inconsistent lately. i am frequently toggling off/on to get it working. also range seems to vary.
    most of the time it works fine.
    06-09-2014 07:55 AM
  4. mtalinm's Avatar
    If I knew the ICON wifi was this crappy I wouldn't have purchased. I have my phone leaning about my router and it's telling me there isn't a network. It's amazing that two iPhones, Galaxy s3, Acer A500, MiiX8, and both my Roku are connected without issue. Some of these have 5ghz as well.
    Ditto. Hoping cyan will fix but not optimistic
    06-09-2014 10:51 AM
  5. JetFixxxer's Avatar
    I guess the Icon has crappy Wi-Fi there is a thread about on the Nokia website.
    06-10-2014 07:21 AM
  6. quantum tao's Avatar
    Maybe they fixed it in the 930?
    06-10-2014 08:08 AM
  7. MikeSo's Avatar
    I think it's the radio. I posted about it here, comparing to my Lumia 521. The difference between quality in signal is striking - my Lumia 521 is so much better.
    http://forums.windowscentral.com/nok...ml#post2546236

    If it's firmware, shouldn't my Lumia 521 also suffer? It doesn't have any newer firmware than my Icon does.
    06-17-2014 06:32 PM
  8. cbreze's Avatar
    I notice my wifi signal seems very weak at times and sometimes disappears altogether. Seems to fluctuate alot also. However so far has never disconnected itself. I just don't pay attention to it anymore.
    The bigger annoyance with the wifi for me is when its on my icon has trouble waking up, always a 3 to 5 sec delay. So I seldom use it.
    06-17-2014 06:53 PM
  9. Ltauhmise's Avatar
    There has been no change to my wifi reliability. However, 8.1 DP appears to have glitched the wifi icon. It will show zero bars yet I'll have excellent connectivity to my wifi router. A minor cosmetic issue. Aside from that, the Lumia Icon is a superb device that clearly exemplifies what it means to be a flagship windows phone.
    06-17-2014 08:31 PM
  10. Brandon McLean's Avatar
    There has been no change to my wifi reliability. However, 8.1 DP appears to have glitched the wifi icon. It will show zero bars yet I'll have excellent connectivity to my wifi router. A minor cosmetic issue. Aside from that, the Lumia Icon is a superb device that clearly exemplifies what it means to be a flagship windows phone.
    I agree, it's likely the wifi indicator that is glitched. Another glitched indicator:
    wp_ss_20140617_0001.png

    I suspect that they messed up when scaling it to a larger/1080p display.
    06-17-2014 09:42 PM
  11. Hounds's Avatar
    Yes, the wifi on the Icon is the worst. I switched over from my 925 and have regretted it ever since. The signal is weak and I have to restart the wifi service everyday.
    06-30-2014 03:12 PM
  12. cbreze's Avatar
    Yes, the wifi on the Icon is the worst. I switched over from my 925 and have regretted it ever since. The signal is weak and I have to restart the wifi service everyday.
    Seems like the majority of users here have this issue. Fortunately I and some others do not have it. It's certainly strange how that works tho. Some getting a bug and some with even the same devices not getting it. I do notice my wifi signal bars are always low since 8.1 tho. Seems to make no difference as far as signal, so I just ignore it. Hopefully a future update addresses this for all.
    06-30-2014 03:37 PM
  13. MobileVortex's Avatar
    I get super frustraged with this.

    I cant even use my wifi on my deck. With my 928 i could go anywhere in my 1.5 acre yard and get a signal just fine. On the deck with my 928 i get full bars and full speed.


    If cyan doesn't fix this we need to lead a charge to the M$ support to get these all replaced or some kind of solution.
    MikeSo likes this.
    07-01-2014 09:18 AM
  14. Robinsonmac's Avatar
    Mine was ok until the last update now it complete ****. Same as the calendar app they both went backwards. They really can't afford these kind of issues while trying to gain mind & market share not only with the consumers but especially the carriers. I mean I know all man made products has defects but being the underdog you have to have the least amount otherwise things start snowballing down hill fast & theses normal defects will be amplified & more ammo to not choose Windows Phone, even if it not true. It's the perception that it is true that hurts.
    Jillxz likes this.
    07-01-2014 06:11 PM
  15. MikeSo's Avatar
    Seems like the majority of users here have this issue. Fortunately I and some others do not have it. It's certainly strange how that works tho. Some getting a bug and some with even the same devices not getting it. I do notice my wifi signal bars are always low since 8.1 tho. Seems to make no difference as far as signal, so I just ignore it. Hopefully a future update addresses this for all.
    I asked someone else this, but have you actually tried it and compared at the fringes of a WiFi network?
    Yes the indicator in the "tray" or whatever it's called is screwy, but the one on the WiFi Settings page is correct. I wonder if those who claim to have good signal have actually done comparisons with other devices, or if they only have small WiFi networks they use it in (which wouldn't give you a lot of signal issues).
    07-07-2014 05:39 PM
  16. cbreze's Avatar
    I asked someone else this, but have you actually tried it and compared at the fringes of a WiFi network?
    Yes the indicator in the "tray" or whatever it's called is screwy, but the one on the WiFi Settings page is correct. I wonder if those who claim to have good signal have actually done comparisons with other devices, or if they only have small WiFi networks they use it in (which wouldn't give you a lot of signal issues).
    It works for me at home and anywhere on my property. Wasn't much concerned about seeing how far I could extend before it dropped. When I go to various coffee houses it works inside and outside patios. I suppose its possible its not as good as before 8.1 , but it works fine even when one or no bars are present and I've not paid attention to strength as it just works.
    07-07-2014 08:27 PM
  17. Brandon McLean's Avatar
    I think it could be a combination of problems, because I can be standing right next to my router and it'll show no bars on the indicator. the download speeds would sometimes be really slow, sometimes normal in this scenario...as soon as I switch Wi-Fi off then back on, it shows the signal you'd expect (for some time, before reverting back to 3 or less bars pretty much at all times) with good download speeds regardless of the indicator. I'm sure it's and issue that'll be fixed with cyan.

    Sent from my Lumia Icon using Tapatalk
    07-08-2014 11:59 PM
  18. Tjarren's Avatar
    I haven't had any issues. I just tested mine this morning and got 124mbps down about 15 feet away from the router.

    Oh, did I mention that Google Fiber is awesome???
    07-11-2014 02:42 PM
  19. MikeSo's Avatar
    I haven't had any issues. I just tested mine this morning and got 124mbps down about 15 feet away from the router.

    Oh, did I mention that Google Fiber is awesome???
    I know some people have had issues close to the router, like the post before you, but I never did, so I'm not surprised you won't have range issues 15 feet away. Did you have any problems with the indicator? That one has issues no matter where I am.
    07-13-2014 04:32 AM
  20. gar216's Avatar
    Exact same problem.
    07-17-2014 06:01 PM
  21. MikeLip's Avatar
    I notice my wifi signal seems very weak at times and sometimes disappears altogether. Seems to fluctuate alot also. However so far has never disconnected itself. I just don't pay attention to it anymore.
    The bigger annoyance with the wifi for me is when its on my icon has trouble waking up, always a 3 to 5 sec delay. So I seldom use it.
    Is there a difference in the radios between the 928 and Icon? I finally took 8.1DP off the Icon and went back to 8.0 because the wakeup delay drove me nuts. But it never happens on the 928. 8.1 is awesome on that, making it my favorite phone ever.
    07-17-2014 06:48 PM
  22. cbreze's Avatar
    Did your icon still have the wake up delay with the wifi turned off?
    07-17-2014 07:27 PM
  23. MikeLip's Avatar
    Did your icon still have the wake up delay with the wifi turned off?
    Yes. But here is an odd thing. When I first installed it, I wiped the phone under WP8. Then I installed DP8.1 and all my apps. There were no delays for a long time. I always had my wifi on. Then one day I turned the phone off to temporarily swap the SIM into another phone. When I put the SIM back in the Icon and fired it up, bam. Delay. The delay occurred whether I had wifi coverage or not and whether I had it on or not. Sometimes it was nearly instant-on, other times it took several seconds. I wiped the phone and reinstalled apps, hoping that would fix it. Nope. I lived with it for a while, got annoyed, then went back to 8.0. Which really ticks me off since I got addicted to the swype-style keyboard and pulldown quick settings!
    07-18-2014 08:24 AM
  24. quantum tao's Avatar
    an occasional 2 second delay is not enough to make me go back to 8.0
    07-18-2014 08:26 AM
  25. MikeLip's Avatar
    an occasional 2 second delay is not enough to make me go back to 8.0
    Well, that's good. I prefer things to work properly. Maybe I'm Sheldon Cooperish about it.
    07-18-2014 08:40 AM
169 ... 34567

Similar Threads

  1. I want to remove Auto-Complete List on Mail app
    By Gavin Ding in forum Windows Phone 8
    Replies: 4
    Last Post: 03-29-2014, 02:17 AM
  2. Titanfall on SP2
    By 1jaxstate1 in forum Microsoft Surface Pro 2
    Replies: 10
    Last Post: 03-20-2014, 12:06 AM
  3. Best games/apps for two players on one device?
    By netrunn3r in forum Phone & Tablet Gaming
    Replies: 2
    Last Post: 03-16-2014, 06:53 AM
  4. Icon Worth It?
    By justwar88 in forum Nokia Lumia Icon
    Replies: 24
    Last Post: 03-14-2014, 01:39 PM
  5. Replies: 3
    Last Post: 03-13-2014, 02:22 PM
LINK TO POST COPIED TO CLIPBOARD