1. jlesavoy's Avatar
    Hello. I am restarting this thread because the one I started previously has gone off track. Short story is:

    Using "unlocked" Icon on AT&T. Everything works at HSPDA+ speeds including Visual Voicemail, Internet, SMS, etc. with the exception of INBOUND MMS. Outbound MMS works fine. Inbound shows up from "unknown" and says message not found.

    A twist: I purchased a Straight Talk sim card, which uses AT&T network and network elements. With this sim, MMS works in both directions (as well as internet).

    I have tried every MMS APN listed on the web, plus a few that are not listed that a very nice Tier 2 AT&T engineer gave me (but didn't solve the issue). it.cingular and broadband were two I hadn't seen anywhere else. But, no luck.

    I'm hoping someone on here can tell me if this sounds like an APN issue, a proxy server issue, an MMSC issue or a message formatting issue? I don't know enough about MMS message flow to know exactly which elements are involved in receiving vs. sending.

    Anyone?

    Thanks in advance.
    04-08-2014 08:39 PM
  2. Laura Knotek's Avatar
    04-08-2014 09:01 PM
  3. jlesavoy's Avatar
    Hi Laura. Thank you for responding. I do have the network+ app installed. I'm not very familiar with what that does. There are only two items inside the app. One says "Call settings" and has a button below it that says "set". And the other is a Voice call counter.

    When I click the "set" button, i am brought to a screen that says "call settings" and has nothing else on the screen at all.
    04-08-2014 09:39 PM
  4. Coolaaron88's Avatar
    Interesting this thread came about. I'm having the same issue with my Icon on AT&T.

    Sent from my Galaxy Tab Pro 8.4 Kit Katted
    04-08-2014 09:58 PM
  5. Venky Chandrasekharan's Avatar
    Same issue... Haven't been able resolve.

    Annoying the heck out of me.
    04-09-2014 12:46 AM
  6. hopmedic's Avatar
    It's the Access Point app that you need, not Network+.
    Check this thread out.
    http://forums.windowscentral.com/nok...tm#post2259713

    I have put two phones (822s) on Straight Talk now, with ATT SIMs. I would expect the Icon to work identically, with exception of needing a smaller SIM. One thing that is weird. On both phones, I entered the given information, and was unable to get MMS. Then I deleted and started again, and did this again. On the third try, it worked, even though I put the information in the same each and every time. Look at the post I linked to, and follow that, then follow the other post linked to in that post. You may have to try a couple times, as I said - I can't explain it - but it will eventually work, I'm sure.
    04-09-2014 02:51 PM
  7. jlesavoy's Avatar
    Rich,

    Thanks for the response. I have Access Point. My icon does work on Straight Talk. MMS in both directions. The issue I have is when I use my AT&T sim (I have a business account with around 56 lines), I can't get inbound MMS to work. I bought the Straight Talk sim to test the concept, because I saw that thread before. So, I remain baffled.

    Thanks. Josh
    04-11-2014 12:09 PM
  8. Vmartinez39's Avatar
    It might be the APN doesn't play nice with AT&T. I have a Lumia 928 but encountered the same Issue. No incoming MMS. I had MVNO called H2O and just refused to work even with the Access Point application.

    I have net10 and everything works. SMS, MMS, Data. The real fix will be when the Lumia 930 gets released. I hope its Unlocked and play nice with all possible APN. I'm stuck with Lumia 928. Just works best on verizon and other MVNO just not with all of them.
    04-11-2014 04:56 PM
  9. hopmedic's Avatar
    Thanks for the response. I have Access Point. My icon does work on Straight Talk. MMS in both directions. The issue I have is when I use my AT&T sim (I have a business account with around 56 lines), I can't get inbound MMS to work. I bought the Straight Talk sim to test the concept, because I saw that thread before. So, I remain baffled.
    I wish I could offer more info. I haven't done anything with actual ATT accounts. I would suspect that there's something in the settings, since the Straight Talk SIM proves that it works on ATT's network. You know the network is capable. It has to be a setting. Have you tried calling ATT tech support and asking them (I'd guess you may need second level to get to people who would truly understand the situation)?
    04-17-2014 11:42 AM
  10. jlesavoy's Avatar
    I did spend some time with AT&T support. The engineer I spoke with spent a decent amount of time working with me, but ultimately didn't know what to do other than try different APNs. The messages reach the phone, so it has to have something to do with the actual formatting of the message itself. Since an MMS message actually starts as an SMS message, then makes a call to retrieve the media, it seems like the mechanism is working. I'm sure it is a setting, somewhere. But, I believe it is most likely on the server/account side.

    -Josh
    04-17-2014 01:44 PM
  11. noelito's Avatar
    I too purchased the icon and attempted to use it on the at&t network and failed miserably with receiving mms. I have used and configured many world phones international phones, phones meant for other networks such as Rogers and each time with a little effort reading the forums playing with the apn settings until I got it right I was able to properly configure the internet and mms settings for my touch HD, hd2, Samsung ativ no problem. Not this time with the Verizon Nokia icon. I used the apn settings app I changed and added new settings I called At&t tech support they tried to send me a data packet to try and fix the problem, there is something in the way this phones firmware? That is not allowing me to receive any mms messages, instead I get UNKNOWN MESSAGE NOT FOUND. So I hope this thread serves as a warning to any prospective At&t users who want this phone, yes it is everything you want in a 5" slick slab of a phone but the caveat is you can't receive mms, so if you don't mind missing out on naked lady or naked guy picks whatevers your flavor then get the phone otherwise don't bother, I couldn't crack this problem and I'm reselling my icon back and waiting for the international variant which I'm 99% sure i'll have better luck or we maybe just get an At&t version of the icon someday like the 928
    06-24-2014 07:53 PM
  12. lumia-icon's Avatar
    Thanks to everyone that posted in this forum. I used a combination of forums to get my Icon working smoothly on Straight Talk. I think it may be possible to use this phone on AT&T as well with everything done correctly (but I haven't tried). Just wanted to share my experience in case anyone was still on the fence about getting an Icon with StraightTalk.

    This is what I did to get my Icon working on Straight Talk (AT&T sim):
    1) Update Lumia Icon
    2) Install Preview for developers app, then go to the phone update in the Settings menu [note, this installs Windows Phone 8.1 I.e. WP8.1]
    3) When your phone is completely updated, set-up the phone as normal (accept all the agreements, etc. log-in with Live Account, etc.)
    4) Search for the app "sysapp windows phone" on google, install it, then open it and make sure "extras + info" is up to date, install if you have too.
    5) Search for "Nokia Access Point app" on google for Windows Phone, install it
    6) Restart phone with Straight Talk sim in
    7) Go to Settings, then close to the bottom will be the Access Point settings
    8) Enter this info below (I live in Oklahoma, and these settings worked for me)
    Hit the plus sigh to add new
    Name: Straight Talk
    Internet APN: tfdata
    EVERYTHING Blank Under the APN INTERNET settings
    MMS APN: tfdata
    Username: Blank
    Password: Blank
    Proxy Address: 66.209.11.33
    Proxy Port: 80
    MMSC Address: http :// m m s c (dot) cing u l a r (.) ["see o em"] <-- use your imagination because I can't post links ["see o em" = com]
    Network Type: IPv4
    Authentication Type: None

    Then activate after you hit save. If it didn't work, try deleting it, then re-entering all the information. Hope this helps someone. I'm loving my Icon on Straight Talk. MMS works both directions, I get HSPA+ speeds (generally 3-8mbps down in my area, 1-3 mbps upload). I am pretty happy overall. Upgraded from the Lumia 920 because I wanted the larger screen and better camera. It was frustrating trying to get this to work but I am happy I did. Take care all!

    - Ryan
    Laura Knotek likes this.
    11-26-2014 10:07 PM
  13. gordonfink's Avatar
    Has anyone figured out the MMS issue with AT&T?

    I have a mint condition Icon, and went and got a nano sim, but don't want to make the switch w/o the MMS working. I'm upgrading from a 920, and it's either this or the 1520, but I sure like the 5" screen much better

    Thanks much
    12-05-2014 02:40 PM
  14. noelito's Avatar
    No do not purchase the Verizon Lumia icon, no one has been able to properly configure the mms settings, buy the international 930, they're very cheap now and mms works great on at&t please see my previous responses on the ordeal I went through with the Verizon icon on at&t
    12-05-2014 02:47 PM
  15. gordonfink's Avatar
    Thanks much. I suppose I'll sell this Icon, and try to find a 930.
    I happened to pick up a mint condition Icon, so I was going to try to force it, but I guess I'll resell it and find the other. I really like the 1520 as well, but I think it's just too big.
    12-05-2014 02:57 PM
  16. noelito's Avatar
    The 930 is easy to find on eBay and cheap with more color options
    12-05-2014 03:02 PM

Similar Threads

  1. will updating to windowsphone 8.1 fix screen problem on lumia 620?
    By dan1232878 in forum Windows Phone 8.1 Preview for Developers
    Replies: 6
    Last Post: 05-21-2014, 01:54 AM
  2. Replies: 2
    Last Post: 04-09-2014, 08:59 AM
  3. Spilled soda on my Type Cover 2?
    By txDrum in forum Microsoft Surface Pro 2
    Replies: 7
    Last Post: 04-08-2014, 10:21 PM
  4. Foundbite updated with redesigned feed, introduces Foundbite Pioneer and more in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-08-2014, 08:30 PM
LINK TO POST COPIED TO CLIPBOARD