The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
07-12-2016 12:51 AM
60 123
tools
  1. Aaron Schnieder's Avatar
    Ok, after spending some time using the phone extensively after getting it work on T-Mobile here is an overview of what works (and what doesn't) that will hopefully answer all of the major questions.

    Nokia Icon Win Phone 8 on T-Mobile using LTE
    ----------------------- What Works ------------------
    - Calls
    - SMS messages (send/receive)
    - MMS messages (send/receive)
    - Internet Explorer web browsing

    ----------------------- Issues ------------------
    - Visual Voicemail does work; but works intermittently depending on internet access
    - App connectivity that requires the internet (Nokia Music, App Store, Visual Voicemail, Pandora, etc.) works intermittently
    - Signal strength seems to be a lot worse than when I had Nexus 5 on T-Mobile
    - So in general I have found the connectivity to be intermittent at times, especially internet access within apps

    ----------------------- Settings ------------------------

    - Hard reset the phone to factory settings (don't know if you have to do this, but I did - so I recommend it if it doesn't work with just changing settings.)
    - Keep the tmo sim in the phone during the hard reset
    - Download and install Nokia Access Setup link
    - Restart the phone
    - Go into Settings -> access point (down near the bottom)
    - Add a new APN, name it "tmo" (or whatever you want) and put in the following settings:

    Access Point Name: fast.tmobile.com
    Username
    Password
    Proxy Address:
    Proxy Port:
    Network Type: IPv4v6
    Authentication Type

    MMS APN:

    MMS Access Point Name: fast.tmobile.com
    Username
    Password
    Proxy Address: 216.155.165.50
    Proxy Port: 8080
    MMSC Address: http://mms.msg.eng.t-mobile.com/mms/wapenc
    Network Type: IPv4v6
    Authentication Type

    - Activate the new "tmo" APN
    - Go to Settings -> cellular -> Change "Network selection" to "T-Mobile"
    - Activate the original APN (You should have one labeled "T-Mobile LTE" by default)
    - Activate the new "tmo" APN you created again

    It should work now. I notice that the connection signal indicator goes null after I send/receive MMS messages and at other random times for a second, but it seems to self heal and recover. After I rebooted once I had to activate the "T-Mobile LTE" APN in Settings -> access point and then activate "tmo" again.

    Hope that works for you.

    Aaron
    Last edited by Aaron Schnieder; 04-11-2014 at 06:05 PM. Reason: Updated issues section
    04-10-2014 05:44 PM
  2. Guytronic's Avatar
    Hey thank you for posting this.
    04-10-2014 06:06 PM
  3. thelumialover's Avatar
    It's funny that your post went on today. I placed an order for the Lumia Icon with Verizon. I really, really, really did not want to switch because of the price plan difference, but I am tired of the L925 and ready for a higher-end WP device. It's in the mail now and should arrive by Monday. I can return the device with no penalty by refusing the package.

    I had two questions for you, though:

    1) Does visual voicemail work using your T-Mobile SIM?
    2) Do you have any other hiccups while using the service? Do you lose signal or have any reboot issues?

    Thanks so much! Greatly appreciated. I can buy the phone directly from Microsoft tomorrow for full price.
    04-10-2014 06:35 PM
  4. Aaron Schnieder's Avatar
    It's funny that your post went on today. I placed an order for the Lumia Icon with Verizon. I really, really, really did not want to switch because of the price plan difference, but I am tired of the L925 and ready for a higher-end WP device. It's in the mail now and should arrive by Monday. I can return the device with no penalty by refusing the package.

    I had two questions for you, though:

    1) Does visual voicemail work using your T-Mobile SIM?
    2) Do you have any other hiccups while using the service? Do you lose signal or have any reboot issues?

    Thanks so much! Greatly appreciated. I can buy the phone directly from Microsoft tomorrow for full price.
    1) Does visual voicemail work using your T-Mobile SIM?
    No, that is the one thing I haven't gotten working. I use Google Voice though for voicemail, so it mitigates the issue.

    2) Do you have any other hiccups while using the service? Do you lose signal or have any reboot issues?
    The only other hiccup is the connection status indicator shows a dead connection every once and a while. It recovers after a second or so and goes back to being connected without needing any interaction from me. No signal or reboot issues yet - but its only been an afternoon so far.
    04-10-2014 06:45 PM
  5. thelumialover's Avatar
    Thanks so much! :)

    If you don't mind my asking, what app do you use for Google Voice? I might use this as well, as I'd hate to keep calling into voicemail.
    04-10-2014 06:48 PM
  6. Aaron Schnieder's Avatar
    Thanks so much! :)

    If you don't mind my asking, what app do you use for Google Voice? I might use this as well, as I'd hate to keep calling into voicemail.
    MetroTalk... Unfortunately Google is shutting down their API for non-android devices next month... so then we lose this option.

    I am going to still try to get the native voicemail client running. If anyone else is able to make it work, please let us know.
    04-10-2014 07:04 PM
  7. thelumialover's Avatar
    Thanks so much for your honesty, man! I really appreciate it!

    I think I am going to move forward with the switch to VZW. I can't believe I'm saying this, but Visual Voicemail is truly worth the extra money to me. I make so many calls in a day...I wouldn't know what to do without it. The $50/mo extra I'll be paying to be on VZW is worth that alone.

    Thanks so much! I can't wait to get the Icon!!
    04-10-2014 07:27 PM
  8. foehammer12's Avatar
    THANK YOU!!! This is so awesome!!! I can get the phone I want on the network I want :)

    1 question though. I will be able to get 8.1 when it releases?

    Thanks again, will order Icon in the next couple of days.
    04-10-2014 09:50 PM
  9. S_C_B's Avatar
    I just saw an Icon on Craigslist, and I passed it up cuz I wasn't positive I could get T-Mobile LTE. I just may have to go back and buy it!
    04-10-2014 10:17 PM
  10. tgp's Avatar
    MetroTalk... Unfortunately Google is shutting down their API for non-android devices next month... so then we lose this option.
    You shouldn't need any app to use GV voicemail. Basically you're just forwarding your number to GV, which then takes the call. I'm not 100% sure that's how it works, but I think it is. Someone please correct me if you can confirm otherwise. Google Voice as we know it is going away soon, but it's being rolled into Hangouts. I doubt there'll be any change to the voicemail service.
    04-10-2014 10:36 PM
  11. Aaron Schnieder's Avatar
    Thanks so much for your honesty, man! I really appreciate it!

    I think I am going to move forward with the switch to VZW. I can't believe I'm saying this, but Visual Voicemail is truly worth the extra money to me. I make so many calls in a day...I wouldn't know what to do without it. The $50/mo extra I'll be paying to be on VZW is worth that alone.

    Thanks so much! I can't wait to get the Icon!!
    I updated the original post... I got Visual VoiceMail working.... but only over WiFi. It looks like there are general internet connectivity problems on T-Mobile.
    04-11-2014 11:39 AM
  12. Aaron Schnieder's Avatar
    THANK YOU!!! This is so awesome!!! I can get the phone I want on the network I want :)

    1 question though. I will be able to get 8.1 when it releases?

    Thanks again, will order Icon in the next couple of days.
    Updating to Win Phne 8.1 shouldn't be an issue.
    04-11-2014 11:40 AM
  13. Aaron Schnieder's Avatar
    I just saw an Icon on Craigslist, and I passed it up cuz I wasn't positive I could get T-Mobile LTE. I just may have to go back and buy it!
    Make sure you read my update below before you do that. :) Internet not working in apps is a deal breaker for me. I am probably going to switch to Verizon month to month even though I got everything else working.
    04-11-2014 11:40 AM
  14. Vistary's Avatar
    Very interesting, the only issue on my Icon with T-Mobile is that sometimes i can not send SMS, and I didn't setup any APN.
    Also, sometimes the signal does become null, but I can access internet on that 'null' network.

    Every app works fine regardless if it's on WiFi or not.
    04-11-2014 01:49 PM
  15. Aaron Schnieder's Avatar
    Yeah, actually I have found that sometimes internet works in apps without WiFi and sometimes it doesn't. Seems to be rather spotty and random.
    04-11-2014 06:04 PM
  16. 7kubo's Avatar
    Hello i have icon with win 8.1. and t-mobile sim, i did exctly what it in the firt post, but my sms still do not work :( i have to switch to 2G to work) any advice?
    thank you
    04-15-2014 03:02 PM
  17. Vistary's Avatar
    Hello i have icon with win 8.1. and t-mobile sim, i did exctly what it in the firt post, but my sms still do not work :( i have to switch to 2G to work) any advice?
    thank you
    My sms didn't work on 8.0, but now works on 8.1 without any extra setup
    04-15-2014 03:30 PM
  18. Aaron Schnieder's Avatar
    Hello i have icon with win 8.1. and t-mobile sim, i did exctly what it in the firt post, but my sms still do not work :( i have to switch to 2G to work) any advice?
    thank you
    I updated to 8.1 and everything is still working (actually better than before the update) using the settings above. You may want to double check that everything is setup exactly as above - I noticed that if anything is different then it just doesn't work.
    04-15-2014 03:45 PM
  19. 7kubo's Avatar
    Thank you guys for quick answers, but... i works great wit LTE(showing no signal) and 2G (showing E or G) ,but still do not work with 3G (showing H or H+)
    can anybody confirm working sms with 3G network?
    thanks
    04-16-2014 01:05 AM
  20. Superhyper's Avatar
    Thank you guys for quick answers, but... i works great wit LTE(showing no signal) and 2G (showing E or G) ,but still do not work with 3G (showing H or H+)
    can anybody confirm working sms with 3G network?
    thanks
    Hi 7kubo,

    Mine works fine on 3G, but I have not yet seen it show H or H+. I'm guessing that will depend on whether the area you're in has been refarmed yet or not.
    04-17-2014 12:44 PM
  21. Superhyper's Avatar
    Does anyone actually have SMS working? I've noticed that in the Messaging settings the SMS Center field is blank, and it isn't possible to manually fill it in. That information should come from the SIM card, but it doesn't seem to be working.
    04-17-2014 12:45 PM
  22. NIde's Avatar
    Aaron - thank you for starting this thread. I wouldn't have made the plunge to buy an Icon & try it on T-Mobile without you :-). I created an account to pass along my findings - the Icon on T-Mobile where I live isn't perfect, but I think what isn't working can be fixed. I've been playing with this for about a week.

    My situation is similar to 7kubo's. I didn't need to manually change anything through Access Point (I've confirmed identical behavior with and without custom settings). The setting that affects mine most is the speed (LTE/3G/2G). Basically, you can pick any two of: fast data, reliable data, or SMS. I have a theory & I'm hoping by knowing the area where folks live we can understand how towers affect the issue. I live near Seattle, which is a refarmed area.

    At 2G, I get consistent SMS and data but inordinately slow speed (~200 kbps).

    At 3G, I get (what I consider) "fast" data - nearly 10 mbps download, however SMSes consistently fail with "SMS error 1".

    At LTE, my phones get the same speed as at 3G (when it works), but are continually bouncing between towers, as described by Aaron. SMSes typically send, but occasionally fail, which probably corresponds to if it's looking for another tower when I send the message. My phones seem to work "better" after the 8.1 update, and my suspicion is 8.1 is just better at finding towers when connections cut out, because it still definitely hops between towers and occasionally fails SMS and data.

    I have two phones, and today set one to LTE and the other to 3G. The LTE one drained the battery dramatically faster than 3G. I suspect it consumes more battery to be always looking for a signal.

    My SMS error seems to be identical to an issue with reported on T-Mobile forums with unlocked Lumia 822s: Nokia Lumia 822 can not send SMS over 2G | T-Mobile Support. Unlike this thread, in my call to T-Mobile support I was told they expect any 3G/4G phone to work, and they were willing to work with me to track it down.

    Since Superhyper got it to work on 3G, I suspect the farming status of where you live is in play. Superhyper - do you know if your area is refarmed?

    Note - I've also been unable to make tethering work, but I'm first working on SMS since that will be a dealbreaker.
    7kubo likes this.
    04-18-2014 12:22 AM
  23. sraina's Avatar
    NIde - Just curious as to where are you located ( or where are you using this service)
    04-18-2014 08:50 AM
  24. sraina's Avatar
    Does anyone actually have SMS working? I've noticed that in the Messaging settings the SMS Center field is blank, and it isn't possible to manually fill it in. That information should come from the SIM card, but it doesn't seem to be working.
    Yes I have it working just fine
    04-18-2014 08:52 AM
  25. NIde's Avatar
    Hi sraina - I'm near Seattle. Your SMS works when set to 3G?
    04-18-2014 02:38 PM
60 123

Similar Threads

  1. Does the Xbox Music pass ever go on sale?
    By Jeffrey Fox in forum Groove Music
    Replies: 8
    Last Post: 04-22-2014, 01:31 AM
  2. How is this new Icon for Clipr?
    By venu238 in forum Applications
    Replies: 10
    Last Post: 04-13-2014, 03:14 AM
  3. Time to bring other Mobile Nations Blogs apps to Windows Phone
    By rdubmu in forum Site Feedback & Help
    Replies: 1
    Last Post: 04-11-2014, 08:15 AM
  4. Replies: 2
    Last Post: 04-10-2014, 05:50 PM
  5. Nokia phones and further wp updates
    By snakerider in forum Nokia Lumia 930
    Replies: 2
    Last Post: 04-10-2014, 05:41 PM
LINK TO POST COPIED TO CLIPBOARD