1. laity78's Avatar
    Upgraded from the 928 to the Icon 2 weeks ago an noticed the Wifi range has only half the strength that my 928 had. Note I have a very powerful Cysco Router. For instance my 928 had 3 bars of WiFi in my bedroom an my 3 year old iPod touch still has 2 bars of WiFi but my Icon will read the router at 1 bar but won't get any data. The Icon will only read my WiFi within about a 20ft range. Also note not a router or my Xfinity high speed internet issue cuz my Xbox 360, my Blackberry Playbook & as i said my ipod touch get flawless WiFi connection. Anbody else have any WiFi issues?
    Last edited by laity78; 05-19-2014 at 03:18 AM.
    05-19-2014 03:08 AM
  2. wpgeek820's Avatar
    Upgraded from the 928 to the Icon 2 weeks ago an noticed the Wifi range has only half the strength that my 928 had. Note I have a very powerful Cysco Router. For instance my 928 had 3 bars of WiFi in my bedroom an my 3 year old iPod touch still has 2 bars of WiFi but my Icon will read the router at 1 bar but won't get any data. The Icon will only read my WiFi within about a 20ft range. Also note not a router or my Xfinity high speed internet issue cuz my Xbox 360, my Blackberry Playbook & as i said my ipod touch get flawless WiFi connection. Anbody else have any WiFi issues?
    Is your Icon running WP 8.1?
    05-19-2014 06:45 AM
  3. MikeSo's Avatar
    05-19-2014 07:33 AM
  4. quantum tao's Avatar
    Upgraded from the 928 to the Icon 2 weeks ago an noticed the Wifi range has only half the strength that my 928 had. Note I have a very powerful Cysco Router. For instance my 928 had 3 bars of WiFi in my bedroom an my 3 year old iPod touch still has 2 bars of WiFi but my Icon will read the router at 1 bar but won't get any data. The Icon will only read my WiFi within about a 20ft range. Also note not a router or my Xfinity high speed internet issue cuz my Xbox 360, my Blackberry Playbook & as i said my ipod touch get flawless WiFi connection. Anbody else have any WiFi issues?
    the latest verizon firmware update fixed wifi for me. you need to be on 8.0 to get it. you can upgrade to 8.1 afterward if you like.
    http://forums.windowscentral.com/nok...ate-today.html
    05-19-2014 07:39 AM
  5. wpgeek820's Avatar
    True. But no worries if you are on 8.1. Nokia's firmware update which is expected to launch within a month will fix issues like these.
    05-19-2014 07:46 AM
  6. mtalinm's Avatar
    i can conifmr this. i was on 8.1 but downgraded to 8.0 with the new vzw firmwware and wifi was back to normal.

    then i went back to 8.1, hoping the fix would persist. but it did not.
    05-19-2014 07:59 AM
  7. laity78's Avatar
    No im not running 8.1, but just had Verizon's firmware update an that didn't fix anything
    05-19-2014 12:54 PM
  8. Olof Lagerkvist's Avatar
    Is there a setting in your router where you can choose between 20 or 40 MHz channel width? Sometimes it makes things better to change the automatic setting to instead hard set 20 MHz. You would not be able to make use of the full 40 MHz bandwidth that your phone probably supports, but you will at least get the same Wifi performance as your other, probably supporting 20 MHz only devices, get.

    Sent from my Surface 2 using Tapatalk
    05-21-2014 01:06 PM
  9. MikeSo's Avatar
    Is there a setting in your router where you can choose between 20 or 40 MHz channel width? Sometimes it makes things better to change the automatic setting to instead hard set 20 MHz. You would not be able to make use of the full 40 MHz bandwidth that your phone probably supports, but you will at least get the same Wifi performance as your other, probably supporting 20 MHz only devices, get.

    Sent from my Surface 2 using Tapatalk
    For me, that's definitely not it. See the link to the thread I started. The Lumia 521 I have has significantly better WiFi range than my Lumia Icon. I'm starting to wonder if it's simply the physical radio itself that is of poor quality in the Icon (considering I had the exact same issue in both 8.0 with the latest firmware update, as well as in 8.1).
    05-21-2014 06:36 PM
  10. Olof Lagerkvist's Avatar
    I thought that 521 has 20 MHz channel width only? I could be wrong there though.

    But if that's the case, it's not surprising if you get a lot better WiFi range with that one compared to the Icon that definitely should have both 20/40 modes available. That is, if the router is set to auto channel width.

    Such things have happened to me a few times with modern dual channel width routers/access points and using new vs. older clients with vs. without 20/40 MHz channels. That's why I thought it was worth mentioning.

    Sent from Windows Phone using Tapatalk
    05-22-2014 01:24 AM
  11. MikeSo's Avatar
    I have no idea, but it's irrelevant, since I can't go around changing router settings on public Wi-Fi networks.

    I'm sorry for being cranky, I know you're trying to help and I appreciate any ideas. This is getting to be extremely frustrating though, since I rely on public Wi-Fi a lot. Both my Lumia 900 and 521 had no issues at all in the locations I go to now where the Icon can barely pick up a signal, and sometimes flat out can't.
    05-22-2014 07:54 AM
  12. quantum tao's Avatar
    I have no idea, but it's irrelevant, since I can't go around changing router settings on public Wi-Fi networks.

    I'm sorry for being cranky, I know you're trying to help and I appreciate any ideas. This is getting to be extremely frustrating though, since I rely on public Wi-Fi a lot. Both my Lumia 900 and 521 had no issues at all in the locations I go to now where the Icon can barely pick up a signal, and sometimes flat out can't.
    since the verizon update and 8.1 update my wireless issues are solved. do you think it is possible your phone might be defective? maybe you could even just get a loaner to try in the areas you are having reception trouble.
    05-22-2014 09:04 AM
  13. MikeSo's Avatar
    since the verizon update and 8.1 update my wireless issues are solved. do you think it is possible your phone might be defective? maybe you could even just get a loaner to try in the areas you are having reception trouble.
    When you say your wireless issues are solved, does that include the range issue? The update solved the problem I had where it would say "No internet connection" even though WiFi was connected. I have not noticed that happening since the update. However, it did NOT solve the range issue. What issue did you have that it solved for you?

    Considering several other people on the forum have mentioned the range issue, I highly doubt a loaner would solve it, but I am considering taking it back to Verizon and trying at this point.

    I suspect every single Icon has this issue, it probably just depends on how you use it whether it's something that affects you or not. If I mainly used it at home or at work for WiFi, and if my bedroom wasn't far enough away from the router that it's at the edge of the router's range, I would probably not have noticed it much. With public WiFi hotspots, it becomes a glaring problem.
    05-22-2014 10:22 AM
  14. quantum tao's Avatar
    I don't use public hotspots, but everywhere I normally connect it's working fine. 10 + routers. My usage environment is different than yours and yours is different than theirs... Only way to know for sure is to put another icon in your situation.
    05-22-2014 10:57 AM
  15. MikeSo's Avatar
    I don't use public hotspots, but everywhere I normally connect it's working fine. 10 + routers. My usage environment is different than yours and yours is different than theirs... Only way to know for sure is to put another icon in your situation.
    Yeah, I suppose that might be what I'll end up doing. Since my Lumia 521 works perfectly in these places, I know for sure that my Icon isn't working like it should. The question is if mine is an anomaly or if they are all like this, I guess. Based on how many people in the forum have problems, I am not hopeful, sadly.
    05-22-2014 11:00 AM
  16. quantum tao's Avatar
    If you are in western new York I would help you test it.
    05-22-2014 11:52 AM
  17. Olof Lagerkvist's Avatar
    I have no idea, but it's irrelevant, since I can't go around changing router settings on public Wi-Fi networks.

    I'm sorry for being cranky, I know you're trying to help and I appreciate any ideas. This is getting to be extremely frustrating though, since I rely on public Wi-Fi a lot. Both my Lumia 900 and 521 had no issues at all in the locations I go to now where the Icon can barely pick up a signal, and sometimes flat out can't.



    Okay I see, you experience the same problem with public hotspots as well. Then I definitely agree that there probably rather is something wrong with the phone, either your one or the phone model in general, not with any specific Wifi settings.

    Otherwise, for others seeing similar problems when connected to their home router, my initial advice could still be something worth to try.



    Sent from Windows Phone using Tapatalk
    05-22-2014 06:42 PM

Similar Threads

  1. MMS issues with my 1020 since 8.1
    By rickylago2 in forum Nokia Lumia 1020
    Replies: 5
    Last Post: 06-21-2014, 02:16 PM
  2. Replies: 1
    Last Post: 05-19-2014, 03:06 AM
  3. when they wil release Offcila update for lumia 1520
    By zahir hussain1 in forum Nokia Lumia 1520
    Replies: 7
    Last Post: 05-19-2014, 03:02 AM
  4. Lumia 720 on WP 8.1 Stop Ringing Midway
    By lumia720 in forum Windows Phone 8.1 Preview for Developers
    Replies: 1
    Last Post: 05-19-2014, 02:53 AM
  5. Kind of a dumb question (Regarding the upcoming file manager).
    By Qaddafi in forum Windows Phone 8.1 Preview for Developers
    Replies: 1
    Last Post: 05-19-2014, 02:28 AM
LINK TO POST COPIED TO CLIPBOARD