1. Neil Hinkle's Avatar
    Has anyone else had issues with their wireless charging not working anymore? I have three charging plates and my Icon suddenly won't connect on any of them. It was working fine last night and every night for the past few months but earlier today I accidentally knocked it off of my desk at work (it hit the roller pad for my chair, literally the only hard surface in the room, screen down) so I'm wondering if something is wrong with my phone.

    I searched the forums but didn't see anyone saying anything about it with the Icon. Running DP 8.1 right now but I'm hoping I didn't just break QI charging in it.
    09-16-2014 10:24 PM
  2. Nerdy Woman's Avatar
    I was running 8.1.1 DP on my 920 prior to getting cyan and my Qi charger would work intermittently or worse, seem to drain the battery (phone was charging the charger?).

    Since you didn't have any problem with DP prior to the attempt to kill a Nokia today, I suspect it may have been injured in the fall. :'(
    09-16-2014 11:19 PM
  3. Indistinguishable's Avatar
    My guess is that the Qi charging coil in your phone was bumped. You could attempt to take the Icon apart to fix or replace it, but I wouldn't know the first thing about that. There is a guide for taking apart the Icon.
    09-17-2014 08:16 AM
  4. berty6294's Avatar
    Have you tried turning the device off and back on again? I know that sounds silly, but I have had the same issue a couple times and a simple reboot fixed it :P lol
    09-17-2014 09:06 AM
  5. Neil Hinkle's Avatar
    I was running 8.1.1 DP on my 920 prior to getting cyan and my Qi charger would work intermittently or worse, seem to drain the battery (phone was charging the charger?).

    Since you didn't have any problem with DP prior to the attempt to kill a Nokia today, I suspect it may have been injured in the fall. :'(
    Yeah, I had no problems other than the usual battery/heating issues that people have been reporting for a while. It's kind of funny because that was the first time I've dropped it and I had just taken it out of my case to clean some dust that had collected on the edges.

    My guess is that the Qi charging coil in your phone was bumped. You could attempt to take the Icon apart to fix or replace it, but I wouldn't know the first thing about that. There is a guide for taking apart the Icon.
    I had considered that, but I don't know enough about the internals of this phone. Definitely don't want to mess it up worse if that's what the problem is.

    Have you tried turning the device off and back on again? I know that sounds silly, but I have had the same issue a couple times and a simple reboot fixed it :P lol
    Haha, yes. I've come across that problem before too and was hoping a reboot would sort it, but no luck. I'm thinking that this really is a hardware issue on my end.
    09-17-2014 09:22 AM
  6. psiu_glen's Avatar
    If you look at the green/orange back thread, it has a lot of info on the back removal and Qi charging. The back pops off (officially with a suction cup in the right place, IIRC others have done it jn other ways). The Qi and NFC coils are on there. Should be easy to spot any superficial bump damage/misalignment, anyway.
    09-18-2014 09:24 AM
  7. Neil Hinkle's Avatar
    If you look at the green/orange back thread, it has a lot of info on the back removal and Qi charging. The back pops off (officially with a suction cup in the right place, IIRC others have done it jn other ways). The Qi and NFC coils are on there. Should be easy to spot any superficial bump damage/misalignment, anyway.
    Thanks for the tip! I had a suction cup at work so I popped off the back and reseated the coil. I don't have a charging pad here but I'll give it a try when I get home. Maybe I'll get lucky. I noticed that there were links to buy replacement Qi and NFC coils in the thread. I guess if worse comes to worse I could always buy replacements and give that a try.

    Edit: Got home and tried it. It works again!!
    Last edited by Neil Hinkle; 09-18-2014 at 04:57 PM. Reason: Update
    DavidinCT and psiu_glen like this.
    09-18-2014 01:02 PM
  8. Indistinguishable's Avatar
    Thanks for the tip! I had a suction cup at work so I popped off the back and reseated the coil. I don't have a charging pad here but I'll give it a try when I get home. Maybe I'll get lucky. I noticed that there were links to buy replacement Qi and NFC coils in the thread. I guess if worse comes to worse I could always buy replacements and give that a try.

    Edit: Got home and tried it. It works again!!
    Nice! Excellent work.
    09-18-2014 10:14 PM
  9. psiu_glen's Avatar
    Glad to hear!
    09-19-2014 02:54 PM

Similar Threads

  1. Angry birds Stella windows phone why not released?
    By fizze17 in forum Ask a Question
    Replies: 12
    Last Post: 11-29-2014, 12:53 PM
  2. Charger Output... Why the slow charge?
    By M Reno in forum HTC One (M8) for Windows
    Replies: 3
    Last Post: 10-27-2014, 09:35 AM
  3. Twitter's push notification doesn't work
    By DCRHAAFMTP in forum Ask a Question
    Replies: 13
    Last Post: 09-23-2014, 04:44 PM
  4. Certain Contact Names Not Recognized
    By Aadesh Gandhi in forum Windows Phone 8.1
    Replies: 0
    Last Post: 09-16-2014, 04:26 PM
  5. Volume down key doesn't work on l520
    By micvaldo in forum Ask a Question
    Replies: 0
    Last Post: 09-16-2014, 02:29 PM
LINK TO POST COPIED TO CLIPBOARD