1. etlahrs's Avatar
    I thought that getting Denim would allow me to connect my fitbit to my Icon for syncing, but so far it won't connect. Has anyone been able to get this working?

    Thanks.
    02-17-2015 08:34 AM
  2. MikeSo's Avatar
    I only have the Fitbit Flex, but it connects after Denim.

    What are the steps you are taking to try to make it connect? You should see it paired in the BT settings, and then just be able to use the Fitbit app to sync. Is the probelm that it doesn't pair, or that it doesn't sync in the app?
    02-17-2015 09:21 AM
  3. hyperblowfish's Avatar
    I had the same issue with my Charge. I actually had to reset the device (the Charge, not the phone) in order to get it to pair. I'm pretty sure it had to do with the fact that I'd paired the Charge to an iPhone first (don't hate me, the Denim update took far too long) and not matter what I tried to do it would never pair properly with the Icon. I used this guide to do a factory reset after performing a sync to ensure that my most recent data would be available when I repaired with the Icon: help.fitbit.com/articles/en_US/Help_article/Why-can-t-I-set-up-my-new-tracker-using-the-Fitbit-app-for-Android
    02-17-2015 10:47 AM
  4. etlahrs's Avatar
    It isn't even showing in my BT devices that are connected to it.
    02-17-2015 10:55 AM
  5. cndspec's Avatar
    We had to connect my husband's Charge to his 920 through the Fitbit app itself. Synced no problem though. If I remember correctly there are some Windows 8.1 specific instructions on their website, including that it doesn't work one pfd.
    02-17-2015 11:05 AM
  6. Albatross2's Avatar
    My Lumia 735 (with Denim) syncs just fine with my Charge HR. May be an issue specific to the ICON or your phone in particular.
    02-17-2015 11:13 AM
  7. tallarob's Avatar
    Works for me. I have the FitBit Zip. Sometimes it takes a little while and sometimes I seem to have to tell it to sync under options. Other times it syncs automatically when I open the app.
    02-17-2015 11:13 AM
  8. MikeSo's Avatar
    Stupid question maybe, but do you have Denim for sure? It sounds like your phone isn't picking up the Charge's BT and it should do so automatically in Denim as long as BT is turned on in the phone.
    02-17-2015 12:17 PM
  9. tallarob's Avatar
    Update for the FitBit app just dropped. Maybe this will help.
    02-17-2015 12:32 PM
  10. etlahrs's Avatar
    I have Denim, 8.10.14.....
    I updated the app today, but it still just sits there saying Looking for Tracker. It has never found it. Anyone know if I try to do it as a new device if it would wipe everything that is there? Or even allow it since it is the same fitbit?

    Thanks.
    02-17-2015 05:52 PM
  11. MikeSo's Avatar
    I have Denim, 8.10.14.....
    I updated the app today, but it still just sits there saying Looking for Tracker. It has never found it. Anyone know if I try to do it as a new device if it would wipe everything that is there? Or even allow it since it is the same fitbit?

    Thanks.
    8.10.14 etc is the Windows 8.1 version number, and you can run that without the Denim firmware. What enables the BT functions for Fitbit is the firmware, which for Denim on Icon is 02540.00019.15024.38022 (at Settings -> About -> More Info).
    Just to be sure, is this the firmware version your Icon has?

    If the Charge isn't even showing in your list of Bluetooth devices in the settings for the phone, it's probably not app related, but an issue with the phone itself.
    02-17-2015 06:27 PM
  12. DarkKrystof's Avatar
    So, just got a Charge from my wife for Valentine's day. I have a Lumia 928 on Verizon running denim, and this newest version of the app. I cannot get my Charge to sync to my phone to save my life. Rebooted the tracker and the phone multiple times, but to no avail. Looks like you're not the only one with issues. Would love a solution.
    02-18-2015 12:34 AM
  13. MikeSo's Avatar
    So just yo be clear, neither of you get the Charge to show up in the phone settings under "Bluetooth"? And you have both double checked that you are running the firmware version for Denim?
    02-18-2015 07:36 PM
  14. etlahrs's Avatar
    I have tried uninstalling the app and trying again from a fresh install, but nothing. On my iPad, it lists the charge in the Bluetooth devices after using the app to connect it. I have made sure to even turn off the Bluetooth on the iPad so that the charge isn't connected to anything when trying to get it connected to my phone, an Icon.

    I think I will try contacting Fitbit support because I have followed their help and FAQs, but to no avail. I really want to get it working as I love the app, but the lack of sync really sucks when I am out and not around my PC or iPad to sync it.
    02-19-2015 10:41 AM
  15. MikeSo's Avatar
    I have tried uninstalling the app and trying again from a fresh install, but nothing. On my iPad, it lists the charge in the Bluetooth devices after using the app to connect it. I have made sure to even turn off the Bluetooth on the iPad so that the charge isn't connected to anything when trying to get it connected to my phone, an Icon.

    I think I will try contacting Fitbit support because I have followed their help and FAQs, but to no avail. I really want to get it working as I love the app, but the lack of sync really sucks when I am out and not around my PC or iPad to sync it.
    Does the Charge HR connect properly to your Icon? Does it show as connected in the Bluetooth settings? Not in the Fitbit app, but in the settings for the phone.
    What is the firmware version on your Icon?
    02-19-2015 12:40 PM
  16. BornStar's Avatar
    Someone already mentioned this but if you connected your Charge to an iOS device at any time in the past you're going to need to factory reset the Charge. The instructions are linked to in the third post.

    When I upgraded my Icon to Denim I wasn't able to sync my Charge HR until after I did a factory reset and then used the WP8.1 app to setup my Charge HR again on my account. You'll go through it like it's a brand new device replacing your old one. Obviously you'll want to make sure you've synced it recently before you go through the factory reset process.
    MikeSo and etlahrs like this.
    02-19-2015 01:31 PM
  17. etlahrs's Avatar
    Thank you, I had to reset the device and then "bond" it to my Icon. Now it is working and brought my last sync information back to the Fitbit too.
    zei20t and MikeSo like this.
    02-19-2015 09:57 PM
  18. FearL0rd's Avatar
    I'm having Bluetooth issues also paring with my car. Looks like Denim broke the Bluetooth connection
    02-20-2015 09:17 PM
  19. etlahrs's Avatar
    I'm having Bluetooth issues also paring with my car. Looks like Denim broke the Bluetooth connection
    I have not had any issue with my Bluetooth connection to either of our cars.
    MikeSo likes this.
    02-22-2015 09:55 AM
  20. FearL0rd's Avatar
    I got it fixed after a painful hard reset
    02-22-2015 09:58 AM

Similar Threads

  1. Apps not working
    By zack251 in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 02-18-2015, 01:12 AM
  2. Replies: 2
    Last Post: 02-17-2015, 10:08 AM
  3. How do I track my missing Windows phone on Cherry Mobile Alpha?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-17-2015, 10:03 AM
  4. Seven things to know about the Microsoft Lumia 435
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-17-2015, 08:11 AM
  5. Transform photos into beautiful works of art with Autodesk Pixlr for Windows
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-17-2015, 07:50 AM
LINK TO POST COPIED TO CLIPBOARD