The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
04-08-2016 03:26 PM
90 1234
tools
  1. Andygoes's Avatar
    And battery life? Are you all getting terrible battery life using the icon on tmobile? Mine barely lasts 6 hours, if that!
    03-10-2015 05:45 PM
  2. FearL0rd's Avatar
    And battery life? Are you all getting terrible battery life using the icon on tmobile? Mine barely lasts 6 hours, if that!
    No problems with Denim
    03-11-2015 06:36 AM
  3. Andygoes's Avatar
    No problems with Denim
    Interesting. I've been off charge for less than two hours and I'm already down to 81% already. No heavy use. :/
    03-11-2015 08:06 AM
  4. FearL0rd's Avatar
    Interesting. I've been off charge for less than two hours and I'm already down to 81% already. No heavy use. :/
    Mine is fine... Try a hard reset... Maybe you have a unit with problems.
    03-11-2015 08:13 AM
  5. wustlmike19's Avatar
    Quick question. I have an ICON working on T-mobile, beautifully --MMS, LTE, the works. However, during the times i cannot send an SMS, like when there is no reception, I do not get the option to "retry." Any thoughts?
    03-19-2015 01:26 PM
  6. wustlmike19's Avatar
    Correction: I cannot send sms when i am on 3g, everything else works fine....anythoughts, anyone?
    03-19-2015 05:31 PM
  7. Grimlock's Avatar
    I was skeptical about this, but it works like a charm! Now my Icon has MMS both ways, tethering, and visual voicemail. All on AT&T. No LTE though.

    Edit: Here are the internet apn settings that I used for att: http://i.imgur.com/dK3JYP9.png
    I was curious if you ended up getting LTE to work with At&t (I saw info here and another thread). I noticed the icon is cheaper on eBay than the m8 but don't want to get the icon if I can't get it working 100%.
    03-24-2015 10:46 PM
  8. FearL0rd's Avatar
    I was curious if you ended up getting LTE to work with At&t (I saw info here and another thread). I noticed the icon is cheaper on eBay than the m8 but don't want to get the icon if I can't get it working 100%.
    I dont think it does have the att base bands
    03-25-2015 06:21 AM
  9. shawns77's Avatar
    I can also confirm after the denim update in Canada that I get full LTE with everything working, all I had to do was manually set the apn.
    Same here on rogers. The only problem I've had from day one with this phone is not being able to receive mms videos. They always get converted to an .amr file(audio only) with a thumbnail image. I can't seem to find any information on why the hell this is happening!
    03-26-2015 01:12 AM
  10. jobinthomas's Avatar
    Awesome, maybe I can buy an ICON now.
    03-26-2015 03:26 PM
  11. heywhitmarsh's Avatar
    Correction: I cannot send sms when i am on 3g, everything else works fine....anythoughts, anyone?
    I have the same issue... every once in a while a message will go through on 3g hspa, but there doesn't appear to be a consistent workaround. MMS works totally fine on 3g hspa though so I don't know where the problem is
    03-26-2015 05:12 PM
  12. erik1220's Avatar
    I am having the same issues. Calls and everything besides SMS seem to be working fine. Anyone have any idea as to why and if there is a solution to bypass this?
    03-27-2015 02:52 PM
  13. heywhitmarsh's Avatar
    I am having the same issues. Calls and everything besides SMS seem to be working fine. Anyone have any idea as to why and if there is a solution to bypass this?
    I've tried every combination of internet apn and access point installs and uninstalls and I've found a workaround.

    SMS can only be sent on 3G (hspa or hspa+) if cellular data is toggled off.
    I've reliably been able to send SMS over 3G with cellular data toggled off, and if the setting is in the action center its very quick to do. (it may take like 10-15 seconds after hitting the toggle for messages to go through)

    SMS can be received on 3G just fine when cellular data is on.
    pankaj981 likes this.
    03-27-2015 06:22 PM
  14. jobinthomas's Avatar
    Very nice, I'll give this a try and report back if it works

    EDIT: Looks like this has been a reliable workaround for me as well. Thanks heywhitmarsh
    Last edited by jobinthomas; 04-04-2015 at 12:22 AM. Reason: adding findings
    04-03-2015 03:38 PM
  15. Willy Soughers's Avatar
    Do you guys think it will work with cricket too? I am about to join cricket service very soon.
    Didn't check I someone replied to you and I know its been a while since you posted, but yes. I can confirm everything works with cricket since they use att as the mvno. I've been using cricket for a couple weeks. You may even be able to use lte since in some areas, cricket still supports they're old cdma standards. Visual vm will not be included though, that's a limitation of the carrier though. You need their official app or a cricket device to use it natively.
    04-04-2015 11:15 AM
  16. krazyatom's Avatar
    Cools thanks for checking!
    04-04-2015 04:52 PM
  17. xrs22's Avatar
    What's apn for Verizon for Icon?
    04-04-2015 05:06 PM
  18. bblount's Avatar
    I am using the Icon on Cricket Wireless and I followed your instructions. Everything works except for LTE. Thank you for your help.
    Willy Soughers likes this.
    04-06-2015 09:53 AM
  19. XillaKun's Avatar
    This worked for me on Cricket. Thanks alot
    04-12-2015 03:44 PM
  20. krazyatom's Avatar
    I can confirmed that it works with tmobile without changing any settings except mms.
    04-12-2015 04:05 PM
  21. Nokia_Lumia's Avatar
    Will this also presumably work for a Verizon Lumia 822 with Denim?
    04-12-2015 04:11 PM
  22. krazyatom's Avatar
    Will this also presumably work for a Verizon Lumia 822 with Denim?
    No idea, but I had to hard reset my icon use tmobile tethering.
    04-12-2015 05:02 PM
  23. bblount's Avatar
    Does wifi hot spot work for anyone using Cricket with this fix?
    Last edited by bblount; 04-15-2015 at 08:11 AM.
    04-13-2015 09:18 AM
  24. heywhitmarsh's Avatar
    I can confirmed that it works with tmobile without changing any settings except mms.
    Can you send SMS on 3G (HSPA or HSPA+) with mobile data on?
    erik1220 likes this.
    04-13-2015 10:12 PM
  25. bo_woods's Avatar
    I am using the Icon on Cricket Wireless and I followed your instructions. Everything works except for LTE. Thank you for your help.
    Did you have to change any settings at all? No mms,sms or calling issues? And how fast is the internet speed?
    04-17-2015 07:09 PM
90 1234

Similar Threads

  1. Voice dictation missing on Lumia 635
    By Raymond Scott in forum Windows 10 Mobile Insider Preview
    Replies: 5
    Last Post: 10-02-2015, 09:02 AM
  2. Is anybody having problems with Windows 10 TP 9926 build?
    By jnbnb in forum Windows 10 Insider Preview
    Replies: 17
    Last Post: 02-20-2015, 09:06 AM
  3. Pebbles website is counting down
    By Lloyydd in forum Smartwatches
    Replies: 2
    Last Post: 02-20-2015, 03:16 AM
  4. 100GB free OneDrive storage through Bing Rewards is now available for everyone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 02-19-2015, 07:08 AM
  5. soundhound crashes on start
    By mich7 in forum Nokia Lumia 730 & 735
    Replies: 0
    Last Post: 02-19-2015, 05:16 AM
LINK TO POST COPIED TO CLIPBOARD