04-08-2016 03:26 PM
90 123 ...
tools
  1. FearL0rd's Avatar
    This is the steps that I did in My Icon to have everything working with Denim
    It is working for TMOBILE-US.. Maybe other carriers

    1 - Cellular + SIM
    2 - SIM settings
    3 - Turn on Manual Internet APN
    4 - Click on edit internet APN
    5 - Configure the APN: fast.tmobile.com
    6 - Install Access Point https://www.windowsphone.com/en-us/s...2d?signin=true
    7 - Open the Application (It will fail)
    8 - Reboot
    9 - Change the date to year 2115
    10 - Open Access point again (It will as to unistall)
    11 - Click on unistall
    11.5 - Change the date back and turn on the automatically
    12 - Cellular + SIM
    13 - SIM settings
    14 - Turn off Manual Internet APN
    15 - Send a MMS to yourself to activate.
    16 - Enjoy!!!!

    Confirmed on tmobile-us, tellus-canada
    Last edited by FearL0rd; 07-14-2015 at 08:38 AM.
    02-19-2015 06:55 AM
  2. PepperdotNet's Avatar
    I think you forgot:

    step 11.5 reset the date to the correct date
    aximtreo, FearL0rd and ven07 like this.
    02-19-2015 08:19 AM
  3. HyperChrisX's Avatar
    Doesn't seem to be working for me. I still get a "Can't send media content. Contact your mobile operator to adjust your settings" message after it fails.
    02-19-2015 10:51 AM
  4. FearL0rd's Avatar
    Doesn't seem to be working for me. I still get a "Can't send media content. Contact your mobile operator to adjust your settings" message after it fails.
    This is what I did and it is working. try a hard reset before the steps. I have other people using the same process and got it working.
    Last edited by FearL0rd; 02-19-2015 at 12:51 PM.
    02-19-2015 12:37 PM
  5. HyperChrisX's Avatar
    Yeah, I thought I might need a reset first. I'm not home right now and don't have a charger on me to do that at the moment though.
    02-19-2015 01:01 PM
  6. xrs22's Avatar
    Will this cause you to get pic and video messages? Cause I gotta turn my cellular data on to open media content all the time then turn off cellular.
    02-19-2015 01:09 PM
  7. AR2186's Avatar
    While this method seems to work, what you really want to do is set the MMS APN properly. If you are the type of person who is comfortable editing the registry, I'd suggest heading over to XDA's Windows Phone 8 development and hacking forum for my method for unhiding the MMS APN settings so you can use the phone on any GSM network you want (subject to cellular band compatibility) easily and on the fly

    You likely have to hard reset the phone with the OP's method because the MMS APN settings end up sticking with no way to change then based on the first SIM you put in (I had this problem coming back to VZW, couldn't even get LTE to work). Much cleaner to just reenable the hidden settings
    HyperChrisX likes this.
    02-19-2015 01:33 PM
  8. FearL0rd's Avatar
    Will this cause you to get pic and video messages? Cause I gotta turn my cellular data on to open media content all the time then turn off cellular.
    Yes any mms
    02-19-2015 05:12 PM
  9. xrs22's Avatar
    I'll give a try for the Verizon method I saw somewhere.
    Lord Icon
    02-19-2015 05:37 PM
  10. juan6996's Avatar
    I was skeptical about this, but it works like a charm! Now my Icon has MMS both ways, tethering, and visual voicemail. All on AT&T. No LTE though.

    Edit: Here are the internet apn settings that I used for att: http://i.imgur.com/dK3JYP9.png
    Last edited by juan6996; 02-21-2015 at 05:17 AM.
    02-20-2015 06:06 PM
  11. sweatshopking's Avatar
    can't get this method to work. Hmmm. Since the other method is patched, idkwtf to do now. I'll try a reset and see how it goes i guess.
    Last edited by sweatshopking; 02-21-2015 at 09:07 PM.
    02-21-2015 08:49 PM
  12. Legoboyii's Avatar
    Dude, thank you.
    Totally unrelated to your plan after the first few steps but. Setting the manual internet APN got my TMo MMS working on my AT&T unlocked Lumia 635. You're a real life saver xD
    Last edited by Legoboyii; 02-21-2015 at 09:06 PM.
    02-21-2015 08:55 PM
  13. sweatshopking's Avatar
    After a reset, and IF I DIDN'T INSTALL A BACKUP, it's working. Took a few resets to get to work, but seems to be working.
    02-22-2015 06:16 AM
  14. Gunbust3r's Avatar
    Saving this thread for later. Glad to hear the Icon MMS works correctly on T-Mobile unlike the 928...
    02-26-2015 08:22 AM
  15. David Fleetwood's Avatar
    How to add WIFI calling to the T-Mobile HTC 8X - WMPoweruser

    Does this trick work to get WiFi calling working on the Icon on T-Mo?
    02-26-2015 02:44 PM
  16. FearL0rd's Avatar
    How to add WIFI calling to the T-Mobile HTC 8X - WMPoweruser

    Does this trick work to get WiFi calling working on the Icon on T-Mo?
    I didn't find any way to do it
    02-26-2015 10:48 PM
  17. krazyatom's Avatar
    Do you guys think it will work with cricket too? I am about to join cricket service very soon.
    02-26-2015 11:56 PM
  18. FearL0rd's Avatar
    It should. I dont know about the lte
    02-27-2015 08:04 AM
  19. David Fleetwood's Avatar
    I didn't find any way to do it
    Did you try the method listed in the article? It seems to be device independent and WP8 seems to build the feature in so it should just be a matter of activating it. Changing your phone listed to a 925 and then changing back should activate it...
    02-28-2015 01:49 PM
  20. FearL0rd's Avatar
    I didn't.
    02-28-2015 07:15 PM
  21. wustlmike19's Avatar
    Does this include th LTE working? I've seen other threads where they've gotten the lte working but not too well
    03-01-2015 11:24 AM
  22. FearL0rd's Avatar
    Does this include th LTE working? I've seen other threads where they've gotten the lte working but not too well
    100% working on TMOBILE
    Donny James likes this.
    03-01-2015 11:30 AM
  23. wustlmike19's Avatar
    03-01-2015 12:08 PM
  24. Iain_S's Avatar
    I can also confirm after the denim update in Canada that I get full LTE with everything working, all I had to do was manually set the apn.
    03-03-2015 08:36 PM
  25. Andygoes's Avatar
    Do you find issues with SMS when not on LTE?
    03-08-2015 03:38 PM
90 123 ...

Similar Threads

  1. Voice dictation missing on Lumia 635
    By Raymond Scott in forum Windows 10 Mobile Insider Preview
    Replies: 5
    Last Post: 10-02-2015, 09:02 AM
  2. Is anybody having problems with Windows 10 TP 9926 build?
    By jnbnb in forum Windows 10 Insider Preview
    Replies: 17
    Last Post: 02-20-2015, 09:06 AM
  3. Pebbles website is counting down
    By Lloyydd in forum Smartwatches
    Replies: 2
    Last Post: 02-20-2015, 03:16 AM
  4. 100GB free OneDrive storage through Bing Rewards is now available for everyone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 02-19-2015, 07:08 AM
  5. soundhound crashes on start
    By mich7 in forum Nokia Lumia 730 & 735
    Replies: 0
    Last Post: 02-19-2015, 05:16 AM
LINK TO POST COPIED TO CLIPBOARD