1. arbyjr's Avatar
    Since before the denim update became available for the icon, I have been waiting so that I could use the treasure tag. I had the developer preview on my phone since the day that I first got it, so the treasure tag would not work with the DP. So street the update the first thing I did was got the treasure tag WS-2. I have a habit of losing my keys alot, and was hoping that this would help. Well I picked up the treasure tag, and everything went smoothly and no problems pairing to my phone. The problem I'm having is the batteries in the tag keep dying very quickly. The first day of was paired and about 4 hours later the tag started beeping for no reason and after looking I noticed that the battery had went dead. This I didn't worry much about because I thought that maybe it just was a bad battery from the start. So I picked up a 4 pack of band new batteries and after about 6 hours of inserting a new one that too was dead. Next battery again about 6 hours and dead again. Any ideas? The paperwork says that the batteries should last about 6 months, but this is odd. Is this normal, had anyone else had better problems like this? One I said I'm waiting on VZW to send it at replacement, but it's been 3 day minus the weekend, but the lady on the phone said that it should be next day shopping.

    plesaes forgive me for reposting this, and also if its in the wrong place...
    02-24-2015 07:55 PM
  2. arbyjr's Avatar
    Ok so nobody knows I'm still waiting on the replacement from VZW, they were supposed too sent it next day shipping, but it's been now almost a week and in still waiting...
    02-25-2015 02:04 PM
  3. Harrie-S's Avatar
    I have a WS-2 treasure tag on my 925 but this is a country variant.(8.1 + P4D)
    The battery lasted not 6 months but a think 2-3 months.
    But with some nameless battery only about a months.
    02-25-2015 02:36 PM
  4. vepac's Avatar
    Mine only seems to last 2-3 months.
    02-27-2015 05:46 AM
  5. hotphil's Avatar
    It's very easy to get the button depressed into the "on" position. That may well flatten the cell quicker.
    ​Might be an idea to reset the Treasure Tag and see how it goes.
    You may want to un-pair it before resetting it. And possibly uninstall the app/hard reset the phone - I've had all sorts of issues with "ghost" Tags showing up.
    ​Not to mention that none of the "mute", or "known zones" type settings ever worked in the app. For any of my Tags.
    02-27-2015 05:53 AM
  6. arbyjr's Avatar
    I finally got the replacement tag, and it's like might and day difference, there must have been a defect with the first one.
    but thanks for the replies...
    02-28-2015 11:08 AM

Similar Threads

  1. Problems with phone after 8.1 update....anyone else?
    By jmaudi0 in forum Nokia Lumia Icon
    Replies: 13
    Last Post: 02-27-2015, 12:41 PM
  2. Battery, once for all!
    By Marko Marjanovic in forum Ask a Question
    Replies: 2
    Last Post: 02-26-2015, 01:07 PM
  3. Replacement Battery for Lumia 830
    By Pastorhss in forum Nokia Lumia 830
    Replies: 12
    Last Post: 02-25-2015, 11:24 AM
  4. Is windows phone having problem operating in the Philippines?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-24-2015, 06:52 PM
  5. My 830 loses battery quick. Is it because of the win10 preview?
    By AVerifiedDeath in forum Nokia Lumia 830
    Replies: 1
    Last Post: 02-23-2015, 08:12 PM
LINK TO POST COPIED TO CLIPBOARD