12-12-2016 11:57 PM
1,191 ... 4142434445 ...
tools
  1. johnzot's Avatar
    SteveNoza,
    Any update on how the battery is doing, in relation to 8.1? I am very anxious to install W10M, but, worried about battery life. For now, 8.1 lasts a full day, with casual use.
    Thanks in advance
    07-04-2016 11:30 PM
  2. SteveNoza's Avatar
    SteveNoza,
    Any update on how the battery is doing, in relation to 8.1? I am very anxious to install W10M, but, worried about battery life. For now, 8.1 lasts a full day, with casual use.
    Thanks in advance
    I haven't done a full on work day yet, but I haven't ran out of battery with casual use. I did the update Friday night and it got really hot then, but I left it on the charger overnight. W01M is still working great, with just a few times of experiencing lag doing stuff. I'm liking 10 way more than 8.1.
    07-04-2016 11:54 PM
  3. speedfrk305's Avatar
    Just bought a nice Icon off ebay to replace my venerable 822- took it to the Verizon store to get a SIM and activate it and they did a reset. When it was all done, it had an older version of WP10 on it that ended in 418 No idea why it didn't install the new version. Took a full day to update all the apps and it basically had to stay on the charger and got pretty hot. After that, I checked for updates and it showed the latest version- 420 needed to be installed. That happened uneventfully. Everything works but battery life is terrible and the speaker on speaker phone sounds terrible- tinny and distorted, but I don't think that is related to WP10. Not sure I can keep using it like this. Plus, my 822 had glance and tap to wake which I had gotten very used to. But the camera is awesome. Any suggestions for tweaking this thing to help the battery life? Any suggestions on the speaker?
    07-09-2016 10:25 PM
  4. jayblazer's Avatar
    It really does take a couple of days for your battery life to get to normal after an O.S. update.. I love/hate every update because I know my battery is going to suck for a few days. As for the tinny sounding speaker phone I would try the volume down + wake reset and see if that fixes it for you I have that every now and then on mine.
    07-10-2016 07:07 AM
  5. speedfrk305's Avatar
    It really does take a couple of days for your battery life to get to normal after an O.S. update.. I love/hate every update because I know my battery is going to suck for a few days. As for the tinny sounding speaker phone I would try the volume down + wake reset and see if that fixes it for you I have that every now and then on mine.
    Thanks... it does seem like the battery is doing better. Lasted almost all day today but it is Sunday so I won't have a good feel for it until tomorrow. How do you do the volume down + wake reset and what does it do- set certain things back to default?
    07-10-2016 08:15 PM
  6. jayblazer's Avatar
    you just hold both of them till "nokia" comes up on the screen then let go. It wont change any settings it just resprings the phone and is great for fixing little hiccups. It will at first take you to the feedback screen but just keep holding..
    07-10-2016 09:40 PM
  7. Rich215's Avatar
    Though I have been using the andoird platform and hardware for many months now...I still have 2 Icons. I always kept one on 8.1 and used it as a wifi/camera basically. The other one I used with Fast Ring OS on Verizon for many months last year and then stopped about March.

    Now I have both setup with the official release from Verizon and will go from there. One phone I am setting up for a family member to use now.

    My question is about how the Verizon Win10 version is compared to the current fast ring builds with daily use?
    07-11-2016 10:45 AM
  8. dksf42's Avatar
    What is the installed base - or best estimate - of TOTAL number of Lumia Icons "SOLD to date"?

    We know that Verizon "dropped the Icon after less than a year" ... but, the Microsoft store "were directly selling them for many months after" as I had a number of friends buy them that way.

    So ... I have read as low as 600,000 and as high as 1,000,000 ?

    Anybody "know or may have read somewhere"?
    07-11-2016 03:01 PM
  9. Mikael Petersson's Avatar
    My girlfriend bought a Lumia Icon two years ago when we were in Orlando on vacation (we are from Sweden) and I was happy to read the news about the upgrade finally coming to Icon. I downloaded the Upgrade Advisor on her phone and it states that the phone is ready for the update but the update is not there when I search for updates. We tried a few times when we were in the US and now that we are home I have tried changing region and language and have restarted a few times but no luck.

    I have no idea what is blocking the update and don't want to hard reset it since it's not my phone and she would not be happy if anything is lost.

    Anyone have a suggestion what I could try? Contact Microsoft?
    07-12-2016 04:55 PM
  10. YoDaMic's Avatar
    My girlfriend bought a Lumia Icon two years ago when we were in Orlando on vacation (we are from Sweden) and I was happy to read the news about the upgrade finally coming to Icon. I downloaded the Upgrade Advisor on her phone and it states that the phone is ready for the update but the update is not there when I search for updates. We tried a few times when we were in the US and now that we are home I have tried changing region and language and have restarted a few times but no luck.

    I have no idea what is blocking the update and don't want to hard reset it since it's not my phone and she would not be happy if anything is lost.

    Anyone have a suggestion what I could try? Contact Microsoft?
    Try checking for updates on the phone while the Upgrade Advisor is checking. Haven't done this on my Icon as I'm on the Fast Ring, but it worked on my girlfriend's 735. Good luck.
    07-12-2016 10:15 PM
  11. MSFanboy2's Avatar
    Two weeks update
    1. Battery usage hasn't really approved. I've tried to isolate it by installing/uninstalling most used apps. Nothing helps. It just seems to be a device problem. I've switched off the background activity for most of the apps. Just getting 12 hours worth of juice right now at a very moderate use.
    Haven't had the courage to do a hard reset as there is some data associated with apps that i just can't lose.
    2. Mail app does not allow me to send an email. Send arrow effectively has no response.
    3. There is this funny issue with Music. Sometimes i just can't start any music app to play/stream. be it groove or Spotify or Iheartradio, it opens but a song never starts. A restart of phone fixes this issue. I can live with it but it is annoying,
    4. Facebook app is crap plus it uses a ton of data. It tries to sync contact and calendar 5 times a day. Mobile Facebook is much better.
    07-18-2016 01:29 PM
  12. Indistinguishable's Avatar
    1. Battery usage hasn't really approved. I've tried to isolate it by installing/uninstalling most used apps. Nothing helps. It just seems to be a device problem. I've switched off the background activity for most of the apps. Just getting 12 hours worth of juice right now at a very moderate use.
    I know you're not on the insider fast ring - But the latest insider update from last night seems to be running much better. I can't say that the battery is totally fixed - but I can say it's running much cooler. Which is typically an indication that the phone isn't working as hard and the battery will be more efficient.

    2. Mail app does not allow me to send an email. Send arrow effectively has no response.
    3. There is this funny issue with Music. Sometimes i just can't start any music app to play/stream. be it groove or Spotify or Iheartradio, it opens but a song never starts. A restart of phone fixes this issue. I can live with it but it is annoying,
    These are odd issues. It does sound like a hard reset would be helpful.

    Haven't had the courage to do a hard reset as there is some data associated with apps that i just can't lose
    Which apps are you afraid to lose data for? Many of the crucial apps will already have data backed up.
    Shamshi-Adad likes this.
    07-19-2016 08:19 AM
  13. Y2HBK's Avatar
    I'm still having issues where Outlook mail live tile never updates. It's been like this on SEVERAL builds. No issues with Lumia 950. Resizing the tile fixes it every time but it doesn't update again until I resize. I've done a soft and hard reset. No app updates available. Really getting tired of the issues. I've actually been using my iPhone again because of this one problem.
    07-24-2016 03:15 PM
  14. Nate Silver's Avatar
    Outlook live tile has been working on my Icon for the last couple of Redstone builds. Wish I could say the same for the MS Health live tile, its been busted forever.
    07-24-2016 06:27 PM
  15. speedfrk305's Avatar
    Noticed yesterday that if you enable car mode, maps won't show traffic since data is disabled. That bug needs to be fixed... Also, stopped by a store to get something and needed an online coupon in an email. Wouldn't download the images in the email since data (LTE icon by the bars) was off. This is with car mode disabled but I was out of the car and in the store, anyways. I've also had it drop the hotspot connection for no apparent reason. Very annoying bugs. Anyone know if putting a case on the Icon affects the antennas? This is just a rubberized case so it won't slip out of my hand as easy.
    pmhgeneral likes this.
    07-24-2016 08:18 PM
  16. Y2HBK's Avatar
    Outlook live tile has been working on my Icon for the last couple of Redstone builds. Wish I could say the same for the MS Health live tile, its been busted forever.
    It's odd. One of my co workers said if they restore back to 8.1, upgrade to win10 via upgrade advisor and set everything up THEN upgrade to fast ring it works fine. But if he hard resets he's screwed again unless that process is repeated.
    07-25-2016 05:25 AM
  17. pmhgeneral's Avatar
    Noticed yesterday that if you enable car mode, maps won't show traffic since data is disabled. That bug needs to be fixed... Also, stopped by a store to get something and needed an online coupon in an email. Wouldn't download the images in the email since data (LTE icon by the bars) was off. This is with car mode disabled but I was out of the car and in the store, anyways. I've also had it drop the hotspot connection for no apparent reason. Very annoying bugs. Anyone know if putting a case on the Icon affects the antennas? This is just a rubberized case so it won't slip out of my hand as easy.
    I'm having this same problem, the LTE is gone and I have no data, were did you find the setting for car mode?
    07-25-2016 06:52 PM
  18. SteveNoza's Avatar
    Anyone know if putting a case on the Icon affects the antennas? This is just a rubberized case so it won't slip out of my hand as easy.
    I put a skin on my Icon early on, with no notable reception loss.
    speedfrk305 likes this.
    07-26-2016 08:07 AM
  19. speedfrk305's Avatar
    Go into settings>System>Driving mode. Mine prompts me when I get in the car and it connects to bluetooth. I just say "no" now since I need traffic on the maps.
    07-26-2016 11:27 PM
  20. djarchow's Avatar
    My biggest problems are the Wifi, 'no internet' bug and bluetooth.

    My phone connects to my home wifi about 50% of the time but I haven't had a working wifi connection at work for weeks. It works if I restart the phone and stay at my desk. If I move around the building at all it drops the connection and says no internet and that doesn't change until I reboot. Even worse is that it doesn't fall back to using my cellular data when this happens so I don't get any emails, etc. So I just leave my wifi off now.

    Bluetooth in my car is mostly unusable now. I can occasionally get Cortana to send a text but responding to one doesn't work. Calls over bluetooth rarely work and the person on the other end can't hear me, or I am distorted. When calls do work, bluetooth on the phone crashes when hanging up the call. Then there is the problem with bluetooth hanging when you try to turn it off in the action center.

    I may try a hard reset if it doesn't get fixed soon but given how frequently fast ring patches have been coming I hate to go through the hassle of a hard reset if I don't have to or the next build will break things again.
    07-27-2016 09:44 AM
  21. chefster74's Avatar
    I'm having the same issues and I got my W10 directly from Verizon. Last night I couldn't send a text with a picture attached. That did it for me, I'm really pissed. Most of the time wifi connects to home. or work. but sometimes it just doesn't. Oddly, the bluetooth in my car was working with my Icon and now it's not. I love Pandora and now it's just not working. I did a hard reset, but not a clean one. Tonight I'm going to do a clean hard reset and see if it helps. I just spent nearly an hour on the phone with Verizon. We covered a lot of things, they're solution is getting a different phone. I'm not willing to do that yet. I still have my 928 which I used daily as a wifi device. I may go back to it. I thought W10 would be great to have, but until they figure out what's up I may just give it up.
    07-27-2016 10:55 AM
  22. djarchow's Avatar
    I did a hard reset, but not a clean one. Tonight I'm going to do a clean hard reset and see if it helps..
    What is different about a clean hard reset from a regular hard reset?
    07-27-2016 04:33 PM
  23. spicypadthai's Avatar
    What is different about a clean hard reset from a regular hard reset?
    I'm assuming restoring from a backup vs. no restore, with no restore = clean.
    07-27-2016 04:40 PM
  24. jayblazer's Avatar
    Mine also sucks at connecting to Wi-Fi I'm on insiders slow ring.. ugh I have to reset every day at work then again when I get home..
    07-27-2016 05:29 PM
  25. chefster74's Avatar
    You're correct, Spicy, it's an option given when you wipe your phone. Now here's something, I was looking to back up my texts and pix and low and behold, while I was looking through my settings I came across cellular data........and it was off!!!!! WTF?? It just turned itself off? I don't remember doing it. So to that I'll say whatever, because Pandora works again in my car:) So now no pain in the butt reset, YAY!
    07-27-2016 09:46 PM
1,191 ... 4142434445 ...

Similar Threads

  1. For those with sound blaster cards
    By Asskickulater in forum Windows 10 Insider Preview
    Replies: 2
    Last Post: 06-20-2015, 10:19 AM
  2. W10 for phone comes for PFD or only in Insider preview?
    By Karthik Sampath in forum Ask a Question
    Replies: 5
    Last Post: 05-30-2015, 04:16 AM
  3. my lumia 720 is not charging
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 05-30-2015, 02:45 AM
  4. Why isn't my Lumia 930 charging above 98?
    By deepak12345 in forum Windows Phone 8.1
    Replies: 1
    Last Post: 05-30-2015, 01:42 AM
  5. Replies: 1
    Last Post: 05-30-2015, 01:04 AM
LINK TO POST COPIED TO CLIPBOARD