1. mjaiteh's Avatar
    I just upgraded from a 925 on T-Mobile to an Icon on Verizon. My MMS was working 100% find on T-Mobile. Now I'm getting "Get media content now" on my Icon and the media is not being downloaded.......

    I've searched the forums and online and a variety of methods. Including these:

    http://forums.windowscentral.com/nok...n-verizon.html

    I am using a Verizon Sim Card.

    Any hep would be beneficial and greatly appreciated. Thanks!

    Love this thing, why did I wait so long?
    07-07-2015 11:36 PM
  2. gernerttl's Avatar
    Is this from a group text, or is it individual text messages? Also, did you port your number from T-Mobile? Though I don't think that would cause the problem. Where did you get your Icon? Is it a used device? If so, you may need to do a hard reset and don't restore from backup. Before doing that, I would talk to a Verizon tech support rep though.
    07-08-2015 02:45 AM
  3. xrs22's Avatar
    I usually have to switch to cellular to "get media" then switch back to wifi if I'm at home. I'm on Verizon too, even with the 928 had this problem but not with att phones.
    07-08-2015 02:54 AM
  4. mjaiteh's Avatar
    Is this from a group text, or is it individual text messages? Also, did you port your number from T-Mobile? Though I don't think that would cause the problem. Where did you get your Icon? Is it a used device? If so, you may need to do a hard reset and don't restore from backup. Before doing that, I would talk to a Verizon tech support rep though.
    Individual text. Number was ported successfully. Icon was purchased manufacturer refurbished from eBay. I did not restore from backup. Thanks I wanted to but they stop service at 6pm so I was too late.
    07-08-2015 07:15 AM
  5. mjaiteh's Avatar
    I usually have to switch to cellular to "get media" then switch back to wifi if I'm at home. I'm on Verizon too, even with the 928 had this problem but not with att phones.
    I've also tried that but unfortunately it makes no difference....
    07-08-2015 07:16 AM
  6. Splacknuk's Avatar
    For me the solution in the thread you annotated solved my issue on the Icon. I think it was the GroupMessaging for me.
    07-08-2015 07:57 AM
  7. mjaiteh's Avatar
    I can't send either.....
    07-08-2015 08:47 AM
  8. odin09's Avatar
    No issues sending or receiving on my Icon thankfully.
    07-08-2015 08:53 AM
  9. SteveNoza's Avatar
    I just upgraded from a 925 on T-Mobile to an Icon on Verizon. My MMS was working 100% find on T-Mobile. Now I'm getting "Get media content now" on my Icon and the media is not being downloaded.......

    I've searched the forums and online and a variety of methods. Including these:

    http://forums.windowscentral.com/nok...n-verizon.html

    I am using a Verizon Sim Card.

    Any hep would be beneficial and greatly appreciated. Thanks!

    Love this thing, why did I wait so long?
    I have had the same problems with mms/sms, a soft reset fixed everything.
    07-08-2015 10:45 PM
  10. gernerttl's Avatar
    Individual text. Number was ported successfully. Icon was purchased manufacturer refurbished from eBay. I did not restore from backup. Thanks I wanted to but they stop service at 6pm so I was too late.
    Ok. Like I said try talking to VZW tech support. They are actually pretty good. This may sound silly, but you might want to check to see which services you are signed up for. It's possible that MMS messaging got turned off for your account. I know it sounds crazy, but just double check...weirder things have happened.

    I've been with VZW since 2008 and I've only had this problem once and it was a group text and the person who sent it was on Sprint using a GS3. That was an issue with Sprint and the GS3 though since I've never had the problem again.

    Except for the above mentioned one time issue, I've never had this problem with any of my phones; which include: Icon, 928, Galaxy Note 2, Galaxy Nexus, Fascinate, Black Berry (Storm 2 and Curve).

    One final thought. There could be an issue with porting your number from T-Mobile. Like said in my previous response, I don't think that would cause a problem, but I'm not a tech guy, so I don't know how porting a number from one carrier to another works or how that would affect services.
    07-09-2015 12:53 AM
  11. mjaiteh's Avatar
    Spent an hour on the phone with Verizon yesterday. They tried everything to no avail. Last resort was a master reset, and that's the only thing that worked. I tried avoiding it because it actually took me a while to get things setup but now my mms is working flawlessly. Lesson learned. Bite the bullet and do a factory reset. Thanks for all the input.
    gernerttl likes this.
    07-09-2015 06:57 PM

Similar Threads

  1. How can I track my Lumia 620?
    By WPCentral Question in forum Nokia Lumia 620
    Replies: 4
    Last Post: 08-08-2015, 09:01 AM
  2. Lumia 925 to 730 - Worth It for Dual Sim? (on T-Mobile US)
    By Skaughtto in forum Nokia Lumia 730 & 735
    Replies: 2
    Last Post: 07-08-2015, 05:49 PM
  3. Nokia Lumia 521 battery door THAT FITS!
    By vrlny in forum Nokia Lumia 521
    Replies: 2
    Last Post: 07-08-2015, 01:06 AM
  4. My contacts are in my Google account, how can I download them to my Lumia 640 XL Dual?
    By Windows Central Question in forum Microsoft Lumia 640 XL
    Replies: 1
    Last Post: 07-07-2015, 11:45 PM
  5. Problems with my Lumia 530
    By Windows Central Question in forum General Desktop, Laptop & Tablet Discussion
    Replies: 0
    Last Post: 07-07-2015, 10:21 PM
LINK TO POST COPIED TO CLIPBOARD