1. loki993's Avatar
    My Icon has never gotten the data signal I feel like it should get. It seems spotty. In buildings lots of time Ill drop down to 3g, even 1x at time. It also seems that when its in these "weaker" areas it gets stuck because I can reboot and get LTE back.

    Anyone have similar issues? Anything can be done about it
    10-07-2015 01:43 PM
  2. loki993's Avatar
    Noone has had any signal issues with this phone?
    10-09-2015 06:46 AM
  3. Beast of Haeven's Avatar
    I have. I haven't been on the forums in a while but I remember reading one of the updates kind of screwed up how the phone handles the cell signal. I remember having no signal issues what so ever, receiving an update and have questionable signal and connection after.

    I'm not sure if upgrading to the preview program and getting windows 10 would be a viable fix our not.
    10-20-2015 11:20 AM

Similar Threads

  1. Replies: 13
    Last Post: 10-19-2015, 02:52 PM
  2. Any information at all about potential 4G/LTE models?
    By red grenadine in forum Microsoft Surface Pro 4
    Replies: 5
    Last Post: 10-12-2015, 02:05 PM
  3. The Microsoft Lumia 640 LTE is finally available in India for Rs 17,399
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-07-2015, 08:11 AM
  4. Custom app icon
    By theoneNonlySUN in forum Windows 10 Mobile
    Replies: 3
    Last Post: 10-06-2015, 12:25 PM
  5. Misleading Connectivity Icons
    By Windows Central Question in forum Nokia Lumia 930
    Replies: 0
    Last Post: 10-06-2015, 03:22 AM
LINK TO POST COPIED TO CLIPBOARD