05-06-2016 11:37 PM
71 123
tools
  1. FearL0rd's Avatar
    Just load RootTool from XNA and deploy using using XAPDeploy in developer mode or Using device portal and do the changes below

    http://forum.xda-developers.com/atta...3&d=1441629736

    [JAILBREAK][GUIDE] Interop Unlock for Window€ | Windows 10 Development and Hacking

    1 - Go to Settings
    2 - Update & Security >> For Developers
    3 - Enable Developer Mode
    4 - Enable Device Discovery
    5 - Install Visual Studio 2013 in the computer
    6 - Connect the phone on the USB
    7 - Open the XAPDeploy "C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v8.0\Tools\XAP Deployment\XapDeploy.exe"
    7.1 - Download Root_Tool.xap
    8 - Deploy the APP Root_Tool.xap using XAPDeploy
    9 - Open Root Tool (For All Windows Device)
    navigate to HKLM>System>Platform>DeviceTargetingInfo and change the value of:
    PhoneManufacturer to Nokia
    PhoneManufacturerModelName to RM-1045_1009
    PhoneModelName to Lumia 930

    After the update finishes change back to the original if you want. Maybe you will need to change again to get future updates

    Im not responsible if you brick your phone. This is what I did in my phone.


    --- 4/4/2016

    I just did a hardreset to test if it is going to brick the phone and everything still working fine. no bugs at all

    ---


    Kudos
    Last edited by FearL0rd; 04-13-2016 at 07:53 AM.
    03-31-2016 07:44 PM
  2. ven07's Avatar
    Cool I'm familiar with the tweaks so know my way around. Was wondering if this would work as I was looking at the icon :D How is it handling so far? I'd like to know about the user experience?:)
    03-31-2016 08:22 PM
  3. FearL0rd's Avatar
    Cool I'm familiar with the tweaks so know my way around. Was wondering if this would work as I was looking at the icon :D How is it handling so far? I'd like to know about the user experience?:)
    I just did it and it is running good. Takes long time the first redstone boot
    03-31-2016 08:25 PM
  4. ven07's Avatar
    I just did it and it is running good. Takes long time the first redstone boot
    Mind if I bother ya after a few days to see how it's going? apart from the normal bugs lol
    wpn00b likes this.
    03-31-2016 08:35 PM
  5. Hernan_Giuliano's Avatar
    Great, thanks!!! Do you know if this change the network frequencies?
    04-01-2016 06:01 AM
  6. FearL0rd's Avatar
    Great, thanks!!! Do you know if this change the network frequencies?
    I don't think soo I still get LTE on T-Mobile without problems
    04-01-2016 10:03 AM
  7. realwarder's Avatar
    Does MMS work? I thought the Icon had issues with MMS on other carriers - does this make that work fine?
    04-01-2016 10:47 PM
  8. DavidinCT's Avatar
    Great, thanks!!! Do you know if this change the network frequencies?
    Was wondering this too, Will it still work with CDMA/4G on Verizon ? Any Verizon customers try this ?

    And if you just leave it as a 930, any ill effects from it ?
    wpn00b likes this.
    04-02-2016 08:15 AM
  9. FearL0rd's Avatar
    Does MMS work? I thought the Icon had issues with MMS on other carriers - does this make that work fine?
    In icon mms works on lte no on 3g always been like that
    04-02-2016 02:46 PM
  10. FearL0rd's Avatar
    Was wondering this too, Will it still work with CDMA/4G on Verizon ? Any Verizon customers try this ?

    And if you just leave it as a 930, any ill effects from it ?

    It should since Redstone is not a full os update
    04-02-2016 02:47 PM
  11. Hernan_Giuliano's Avatar
    I don't think soo I still get LTE on T-Mobile without problems
    You're a genius! Redstone running perfectly on my Icon. LTE working normally (bands 4, 17 - Claro Argentina). Thanks again!!!
    ven07 and wpn00b like this.
    04-02-2016 09:30 PM
  12. prashp1's Avatar
    Does anyone know how to change IP type for Internet Settings since it's hidden?
    04-03-2016 11:33 AM
  13. FearL0rd's Avatar
    Does anyone know how to change IP type for Internet Settings since it's hidden?
    I have another topic about this search for MMS
    04-04-2016 06:47 AM
  14. FearL0rd's Avatar
    Mind if I bother ya after a few days to see how it's going? apart from the normal bugs lol
    it has been running fine.
    ven07 and wpn00b like this.
    04-04-2016 06:48 AM
  15. IcyPwnage's Avatar
    I'll give verizon a until may to get this sorted and then I may go down the rooting the phone route. Some of the phone + desktop syncing stuff that is coming in redstone seems pretty sweet.
    ven07 and wpn00b like this.
    04-04-2016 08:21 AM
  16. prashp1's Avatar
    I have another topic about this search for MMS
    I searched in that topic forum, but I am not able to see any IP type for Internet Settings. It's only for MMS. I posted same question in that forum. Thanks
    04-04-2016 10:28 AM
  17. FearL0rd's Avatar
    I searched in that topic forum, but I am not able to see any IP type for Internet Settings. It's only for MMS. I posted same question in that forum. Thanks
    I dont think we can change the IP provided by the Carrier DHCP
    ven07 likes this.
    04-04-2016 12:45 PM
  18. FearL0rd's Avatar
    :) ?
    04-08-2016 09:10 AM
  19. Grzenek's Avatar
    So, forgive me my greenness here. I swapped to development mode, downloaded XNA RootTool, unzipped it and have trouble to find XAPDeoloy to push it. Can you be more specific?
    Thanks.
    04-08-2016 12:57 PM
  20. FearL0rd's Avatar
    So, forgive me my greenness here. I swapped to development mode, downloaded XNA RootTool, unzipped it and have trouble to find XAPDeoloy to push it. Can you be more specific?
    Thanks.
    If you try to unzip and you see a lot of files you don't have to unzip just rename to .xap


    1 - Go to Settings
    2 - Update & Security >> For Developers
    3 - Enable Developer Mode
    4 - Enable Device Discovery
    5 - Install Visual Studio 2013 in the computer
    6 - Connect the phone on the USB
    7 - Open the XAPDeploy "C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v8.0\Tools\XAP Deployment\XapDeploy.exe"
    7.1 - Download Root_Tool.xap
    8 - Deploy the APP Root_Tool.xap using XAPDeploy
    04-08-2016 01:17 PM
  21. Grzenek's Avatar
    This is great. Thank you!!!
    04-08-2016 03:16 PM
  22. DavidinCT's Avatar
    I'll give verizon a until may to get this sorted and then I may go down the rooting the phone route. Some of the phone + desktop syncing stuff that is coming in redstone seems pretty sweet.
    I was thinking this way too. I so want to try this and just get this done but, I'll have to wait a little longer.

    I'm using Tap to pay on my LG G3 for now and love it.... I'll go back when we get 10 on the ICON... OFFICAL 10
    ven07 likes this.
    04-09-2016 09:12 AM
  23. mewcatchew's Avatar
    Are you able to access field test mode by doing this?
    04-10-2016 12:12 AM
  24. Grzenek's Avatar
    OK. So I am on 10.0.14295.1000 for two hours now. So far, so good. It is actually pretty responsive.
    Thanks a lot!!!
    ven07 and wpn00b like this.
    04-10-2016 12:29 AM
  25. Whisker's Avatar
    Okay forgive me but I might be mentally challenged. I deployed the root tool but where do you change the settings HKLM>System>Platform>DeviceTargetingInfo. Is this done on the computer or the phone because I cant seem to find this setting. Thanks for any help.
    04-10-2016 07:54 PM
71 123

Similar Threads

  1. Replies: 7
    Last Post: 04-01-2016, 07:15 AM
  2. Importing Google Apps Email into Outlook.com on Chrome?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-31-2016, 07:22 PM
  3. Hands-on with NexDock and Continuum with Windows 10 Mobile
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-31-2016, 07:20 PM
  4. Dual Sim XL on At&t microcell?
    By RichHowerton in forum Microsoft Lumia 950 XL
    Replies: 0
    Last Post: 03-31-2016, 07:11 PM
  5. Replies: 1
    Last Post: 03-31-2016, 12:33 PM
LINK TO POST COPIED TO CLIPBOARD