Shop Cyber Monday deals at:Amazon | Walmart | Best Buy | Microsoft | Dell

04-06-2012 05:59 PM
27 12
tools
  1. tal99's Avatar
    Hi,

    since Mango (?) I have a very severe bug: although WiFi is connected and working fine my WP7.5 phone uses the GSM data connection. For me this is mostly annoying, because it its painfully slow at home but if you don't have an unlimitted data plan this means that you use up your included data while believing you are connected via WiFi.

    I'm not sure who widespread this is. I searched the WPCentral forums but found nothing, on pocketpc.ch there are a couple of users with this behaviour across different phones/manufactures/networks) and I believe at least some of those who complain about excessive data usage will probably experience this behaviour, too.

    I also came across this post on MS answers and added myself to the list. So in case there are more WP owners with this problem, please add yourself to that MS answer question in order to push it to Micorsoft's attention.

    have for others this is even more severe since yo
    WP7.5 chooses Data connection over Wifi - Microsoft Answers

    For me this means turning of GSM data connection when at home and then everything is fine (but I loose push notifications and when I leave home I have to remember turning data back on - very annyoing).

    Final word: Nonetheless I love my WP7 phone and wouldn't want to switch assuming that a fix will come. And as a software developer I know to well that a bug like this can happen on any plattform esp. since I believe that this probably isn't easy to reproduce (for me WiFi works fine for some time and suddenly while surfing network got switched to GSM). So in case some MS employee likes some detailed information from me I'm happy to assist ;)
    12-19-2011 06:37 AM
  2. palandri's Avatar
    There was a thread about WiFi not being able to communicate with a certain WiFi channel. Maybe resetting your router will temporarily solve the problem.
    12-19-2011 07:45 AM
  3. TheWeeBear's Avatar
    Yes it was the Radar palandri, the channel was changed from 11 to 5, I think, and that cured the non connection problem.

    Think this is the thread here...

    http://forums.windowscentral.com/radar/182884.htm

    As you said, it might be worth trying another WiFi channel. :)
    jfa1 and muffasa like this.
    12-19-2011 07:52 AM
  4. jimski's Avatar
    Looks like the OP is talking about it switching over randomly while in the house for example, so probably not the channel issue, unless his router is set to auto.

    I have never experienced this on my Surround running Mango. WiFi is always running as soon as I wake up my phone. And my data usage has been consistent, pre-post Mango, so no change with the upgrade.

    Sent from my HTC Surround using Board Express
    12-19-2011 08:11 AM
  5. dragonide's Avatar
    Looks like the OP is talking about it switching over randomly while in the house for example, so probably not the channel issue, unless his router is set to auto.

    I have never experienced this on my Surround running Mango. WiFi is always running as soon as I wake up my phone. And my data usage has been consistent, pre-post Mango, so no change with the upgrade.

    Sent from my HTC Surround using Board Express
    same here,
    Never experienced this ...
    12-19-2011 08:26 AM
  6. sinlessearth's Avatar
    I have a T-mobile US branded HD7 that is running on Telekom.de. current OS is 7720.68. I have the same issue. Both my GSM data and WIFI will be connected but sometimes it will try to use the GSM to update webpages..etc so I will have to go to setting and turn off cellular data to get WIFI to work. Yes very annoying. Does not happen all the time but enough to bother me.
    12-19-2011 08:47 AM
  7. tal99's Avatar
    Looks like the OP is talking about it switching over randomly while in the house for example, so probably not the channel issue, unless his router is set to auto.
    Exactly. WiFi is still working fine. For example if I turn off GSM data connection the phone easily switches back to WiFi.

    The thing is that I probably wouldn't even notice this bug if my GSM connection at home wouldn't be so terrible slow (I have a flatrate so I don't care how much data my phone uses)!

    Typically if I turn on my phone at home, I'm on WiFi just fine and suddenly (while surfing,..) it gets slow. If I check which network is used (I even installed an app called "System Information" to check on it) I'm on GSM although WiFi is still perfectly connected.
    12-19-2011 01:17 PM
  8. iluvokra's Avatar
    I have just discovered the same problem as well: I have an unbranded HD7 in Australia. I discovered that the 7740 and tethering updates were available only a day or so ago, and applied them successfully. Now, my cellular data connection is preferred over my WiFi, even though the latter is connected (and works fine if the cellular data connection is switched off).:@
    12-28-2011 05:46 PM
  9. going west's Avatar
    Is there a way to tell which connection my phone is using? I'm afraid mine may be doing this as well, but I can't be sure. In any case it sure is burning up a lot of data--more than is should be...especially since I spend most of my time in recognized wifi zones.
    12-29-2011 12:28 AM
  10. tal99's Avatar
    Is there a way to tell which connection my phone is using? I'm afraid mine may be doing this as well, but I can't be sure. In any case it sure is burning up a lot of data--more than is should be...especially since I spend most of my time in recognized wifi zones.
    I use an app called "System Information" (free in the Marketplace) which in its network section tells you what connection is the currently active. I use that to check if I have the feeling WLAN isn't used.

    Note that at least for me at the start of a wlan session I'm usually connected just fine and after a few minutes suddenly WLAN isn't used anymore although the WLAN symbol still is shown. Si it's probably best to check back after a few minutes.
    12-30-2011 04:42 AM
  11. martin_strahilovski's Avatar
    But is there a way to make your router channel on auto so every time you have another channel? :) could that fix the problem or you need a specific channel?
    12-30-2011 06:54 AM
  12. tal99's Avatar
    But is there a way to make your router channel on auto so every time you have another channel? :) could that fix the problem or you need a specific channel?
    No, because WiFi is working just fine but WP sometimes(!) chooses GSM data nonetheless. This is very anoying since GSM data is slow and for some people expensive.

    I just verified that WiFi is working just fine by accessing from my WP a computer on my LAN with local IP address (which therefore is ONLY possible using WiFi not GSM). This worked perfectly from my WP while at the same time internet access was using GSM data. I additionally verified that internet access through my WLAN is working fine by using another WP and that just worked without a problem at the same time.

    Conclusion: it really seems that somehow sometimes WP thinks it cannot access internet through WiFi anymore although being connected just fine and therefore sticks to GSM.
    01-09-2012 05:18 AM
  13. Rocket_Girl's Avatar
    It certainly could be fine w/, carriers to 'prefer' data...since most customers have data limits, that could mean more $$ for carriers.
    01-09-2012 06:59 AM
  14. welsbloke's Avatar
    Sounds like this could be a router issue though especially with you accessing a local device fine via WLAN and being forced down GSM for Internet access.

    What model router are you using? Might be worth making sure the firmware is up to speed. You would be suprised how often a router can cause issues like this.
    01-09-2012 09:03 AM
  15. Dormage's Avatar
    I quickly read the posts and the way I see it you might be checking the used connection in a wrong way. Having slow speeds may not necessarily mean the phone is using data connection.
    The app you mentioned shows active connections in this case both should be active.

    I would recommend logging in your router and monitoring traffic.
    If searching the logs isn't your thing you can use a traffic monitoring program like Wireshark to trace data transmitted over Wifi. Open a page and see if Wireshark picked up the http request.

    I might be shooting blanks but I did try it on my Omnia 7 and it does show up in my logs.
    01-09-2012 10:48 AM
  16. mberdych's Avatar
    Yes, there is a problem with wifi. Multiple devices, different people. Wifi gets slow suddenly, sometimes data stops, after a while it is fine. I am experiencing the same with my Titan. I have Time capsule router, experiencing this, now testing a Comtrend router and it seems better, although not solved. There is something wrong with wifi on Mango.
    01-09-2012 11:23 AM
  17. jeremyshaw's Avatar
    Yup, I have this issue HTC Titan, AT&T branded running 7720. Don't have any hard evidence, but some things I've noticed are adding up.

    Will see if my forced 8170 upgrade fixes this, but I no longer use my titan as primary.
    01-09-2012 12:06 PM
  18. jdevenberg's Avatar
    I noticed yesterday that my wife's Titan was connected to wifi, and when I tried a voice search it said "Sorry, Voice search not enabled over network". So even though the phone was on wifi it was trying to send data over the cellular network.
    01-09-2012 12:47 PM
  19. tal99's Avatar
    To bad latest update doesn't fix that problem. So I still am stuick with turning 3G off when at home and WiFi off when leaving home :mad:

    I'm really surprised that this problem isn't more "front-page" like discussed (I find it to be much more severe than the just fixed disappearing keyboard). Reason probably is that not everybody suffers from this bug, although there are quite a few people who have this problem (WP7.5 chooses Data connection over Wifi is one of the most "me too" open bugs at Microsoft Answers). Additionally I believe there are lots more who have this problem but don't know about it and just complain about excessive data usage, slow WiFi or slow 3G data.
    01-25-2012 12:00 PM
  20. drg's Avatar
    Can everyone who has this problem please report it here

    WP7.5 chooses Data connection over Wifi - Microsoft Answers

    I really want MS to realise this is a major issue with a lot of people.
    02-01-2012 04:09 AM
  21. tal99's Avatar
    Can everyone who has this problem please report it here

    WP7.5 chooses Data connection over Wifi - Microsoft Answers

    I really want MS to realise this is a major issue with a lot of people.
    Seems like our effort on pushing thesevere bug on MS answers might have helped. At least it seems that Microsoft has acknodlegde the issue. Since we know that fixing of bugs is sometimes slow I'd recommend you keep adding your vote to "me too" in case you also encounter that problem.

    I really hope it becomes a top priority for MS to fix this since in comparrision the much talked-about "disappearing keyboard" in my opinion was far less severe than this issue which one could cost real money and will surely make some users leave Windows Phone. I stumble again and again about users asking about "excessive data" and quite often it turns out that it was infact this issue.
    02-10-2012 07:49 AM
  22. VictorE#AC's Avatar
    I'm hoping this gets fixed soon. I installed Supreme Shortcuts ( [APP] Supreme Shortcuts - 2012-01-05 - Version 2.2.3 - French Language Fix + more - Page 16 - xda-developers) to pin the Cellular Data tile to my home screen to toggle my data connection.
    03-08-2012 11:17 AM
  23. bananapeal's Avatar
    I'm on limited data so this issue is particularly annoying. I had to add the cell-data switch to my home screen to make sure I'm using wifi when I'm at home/school. Then I leave the internet area I have to remember to switch data on... very cumbersome.
    Last edited by bananapeal; 03-08-2012 at 11:41 AM. Reason: i also pointed to the answers thread.
    03-08-2012 11:40 AM
  24. Rodolfo#WP's Avatar
    For the record, I don't have this "severe bug" on a Mangoed Samsung Focus. Being retired, I'm using wi-fi all day to access the web -at home, someone else's, or at one establishment or another. I can easily keep my limited-data plan under the threshold. At home, I do upgrade my network regularly and have a booster installed -in case that matters. Best "de-bugging" to all. ;)
    03-08-2012 12:36 PM
  25. zzzxyz's Avatar
    I recently got AT&T Titan and I see something suspicious myself.

    Say I am at home and connected to WiFi. When I wake up the phone, the WiFi icon on the top status bar goes through a little animation (similar to when you first connect to WiFi) as if it is now connecting to WiFi. This makes me wonder what connection was it using when it was doing background data activity.

    The cellular data usage report has been higher which makes me think that it might be using cellular network for the background activities.
    04-06-2012 12:26 PM
27 12
LINK TO POST COPIED TO CLIPBOARD