1. Snoops8's Avatar
    So I had emailed a few random people on craigslist, but afterwards deleted their information. However, now whenever I start writing an email to someone, their names will populate the sender box whenever I begin writing down a name.

    How do I clear these autocomplete email entries? It's not as if I'll ever email these people again.

    Also, is there a way to reply using my Alias on hotmail? If I get an email sent to my alias and I hit reply, then the reply is sent from my actualy hotmail address, not my alias. It kind of defeats the purpose of having an alias.
    03-15-2012 04:49 PM
  2. speedtouch's Avatar
    What email service are you using?
    03-15-2012 05:03 PM
  3. Snoops8's Avatar
    Hotmail and sometimes gmail. It doesn't matter what service is used - the phone is storing the contact somewhere locally and I can't figure out how to get rid of all the other contacts. I even removed the email accounts and they still appear in autocomplete.

    Actually is there a way to only display the contacts that are in my contact list?
    03-15-2012 07:11 PM
  4. speedtouch's Avatar
    Hmm. I am stumped, honestly. I didn't know the phone would/could store addresses locally. There is way to filter contacts from the Settings, but I don't think that applies to you since you said you've verified the offending addresses have been removed from Live/Gmail. I just don't know.
    03-15-2012 08:15 PM
  5. freestaterocker's Avatar
    Your only remedy might be a hard reset... Sorry.
    03-15-2012 09:54 PM
  6. Snoops8's Avatar
    Darn you craigslist darn you!!

    Thanks for trying everybody. I found this, which applies to Outlook but I imagine it's something similar for Windows Phone.

    Outlook's Auto-Complete or Nickname Cache (*.NK2) | Slipstick Systems

    Ah well. It could be worse. This is 1/100 of the problems I had with Android, so I can live with it if I must. Forever now on I will have strange people and their addresses stuck in my email address cache.
    03-16-2012 12:43 AM
  7. Da vid's Avatar
    Ugh, this is so frustrating! My wife changed jobs, and even though I have changed the email in both my Live and Gmail accounts on my Lumia 920, it STILL wants to autocomplete her old email first.
    04-19-2013 03:43 PM
LINK TO POST COPIED TO CLIPBOARD