1. Ben Lehtovaara's Avatar
    Hi All,

    Where are the advanced server/domain settings for connecting to a wifi network like an enterprise network?

    When I try to join the enterprise network it has found or when I search for it manually all I get is a box for a password. This is not good enough for my network as I need to enter a domain and username to authenticate who that password is for.

    On my iPhone you would try just the password the first time and it would fail and then give you additional options. It was a pain in the *** but would work eventually. I can't get any additional options here.

    I have tried:

    1) The windows phone support site says that I have to enable an option to Validate Server Certificate and then tap Choose Certificate to select a certificate that is installed. I assume that is then supposed to give me the advanced fields that are required. I can't find these options anywhere...

    2) I manually obtained the security certificate from my IT guys, emailed it to myself, opened it on my phone, and WP8 recognized it and installed the certificate but this still doesn't give me access to any additional options for my network.

    3) Called Nokia Canada support and they showed me the existing options that I can already find but seem to have no idea about advanced server/domain settings.

    This is embarassing. Shouldn't Windows Phone be able to connect to windows powered networks with ease? Did Rogers restrict wifi options somehow?

    Please help!
    11-21-2012 12:16 PM
  2. thekonger's Avatar
    Ben, it may be on your network side. I work in an enterprise windows environment and I was automatically prompted for a user id and password right away. Using domain\userName and password I was able to connect automatically. I have had issues with other mobile devices but with my 920 it was easy.

    With that said, I work at a medical institution and a lot of effort is made to ensure doctors don't waste time fiddling with their mobile phones to connect. I think some of how easy this is depends upon how your network is set up. And that applies to how iOS and Android connect also.
    11-21-2012 02:14 PM
  3. Coffee's Avatar
    I'm the same as Konger - I was prompted for a password, then it asked for the domain, no problem connecting, large enterprise network.
    11-21-2012 03:16 PM
  4. Ben Lehtovaara's Avatar
    So you entered just a password first and it failed then prompted you for a domain/username?

    That's how it worked on my iPhone and what I'd like to see on my Lumia. Not sure why its not prompting me for additional information. My IT guy suggested I need to install the security certificate for our server on my phone. I managed to do that but it didn't seem to make a difference.

    I have no idea what our IT guys could do differently on their end. Anyone have any additional insight?
    11-27-2012 06:09 AM
  5. marbla's Avatar
    Depending on your network type wp8 does not support it. We have an EAP-TTLS network at work and there simply is no support. So even if I install the server certificate I am out of luck... at least for now.
    11-27-2012 07:46 AM
  6. EliteMikes's Avatar
    The so called appolo plus update that is being talked about in blogs will address networking. It will also add vpn support
    11-27-2012 08:12 AM

Similar Threads

  1. Can anyone connect to ATT wifi hotspots?
    By wzd105 in forum Windows Central Archive
    Replies: 10
    Last Post: 11-05-2013, 09:18 PM
  2. Any Issues Connecting to Enterprise WiFi?
    By Porterhaus in forum Windows Phones
    Replies: 7
    Last Post: 03-22-2013, 10:17 AM
  3. Why is there no picture swipe sign in for WP8 Unlock Screen?
    By ny_yankees in forum Other Operating Systems
    Replies: 1
    Last Post: 11-12-2012, 10:45 AM
  4. Is there no keynote video stream?
    By Nakazul in forum General Phone Discussion
    Replies: 2
    Last Post: 09-19-2012, 02:00 PM
  5. Why is there no Pandora for Windows Phone?
    By propeller10 in forum General Phone Discussion
    Replies: 62
    Last Post: 11-25-2011, 06:26 PM