1. Weier Liu's Avatar
    So I've owned a Lumia 920 and now I have a Lumia 620. When plugged into the computer, both phones were disconnecting and reconnecting every 30 seconds or so, making it nearly impossible to sync music to the device. I'm now on a Windows 8 PC and still having this issue. Is this a driver issue? I'm surprised that my Windows 8 and Windows Phone 8 device is having such difficulty connecting to one another.
    06-06-2013 10:01 PM
  2. montsa007's Avatar
    Try these

    On the same PC
    1 - Try a different cable
    2 - Lightly blow the connector of the 620 (I have not seen but try to remove the cover and connect the cable)

    On a different PC
    1 - Try to connect with the usual cable
    2 - With a newer cable
    3 - A different OS

    Worst, remove the SD card and use a card reader.

    P.S. - I never use sync function, just copy paste like you'd do in a pen drive.
    Weier Liu and xandros9 like this.
    06-07-2013 03:09 AM
  3. cybodroid's Avatar
    I have a similar problem as well. I usually have to unplug/replug and switch USB ports like 20 times before I can get the Windows Phone app to recognize my phone. Not sure if it's the cable and I have a new one on the way, but I know it's not the PC because other devices are ready to go once plugged in just fine. I reinstalled the drivers and everything so I don't know what the deal is.

    I wish you could just sync over bluetooth/wifi..
    06-07-2013 10:48 AM
  4. Weier Liu's Avatar
    Try these

    On the same PC
    1 - Try a different cable
    2 - Lightly blow the connector of the 620 (I have not seen but try to remove the cover and connect the cable)

    On a different PC
    1 - Try to connect with the usual cable
    2 - With a newer cable
    3 - A different OS

    Worst, remove the SD card and use a card reader.

    P.S. - I never use sync function, just copy paste like you'd do in a pen drive.
    It looks like my issue was fixed when I used the original cable. I'll update if it happens again with this cable. Thanks for your help!
    06-13-2013 07:12 PM
  5. cybodroid's Avatar
    Also turns out I had a faulty cable as well. Got a new one and things sync up fine with no issues whatsoever.

    The original one was too short which is why I never used it..
    06-13-2013 08:05 PM
  6. montsa007's Avatar
    It looks like my issue was fixed when I used the original cable. I'll update if it happens again with this cable. Thanks for your help!
    I'd never really use an alternate cable unless I didn't have any options left :).
    Am glad your prob is fixed.
    06-18-2013 12:26 AM
  7. cfib90's Avatar
    I, too, had this problem. My phone would repeatedly connect/disconnect every 20 seconds.
    Cleaning the phone's micro USB port fixed the problem. Removed quite an amount of lint from there, and now it works.
    05-17-2014 02:45 PM
  8. Maxwell Zwe's Avatar
    I'm having this problem now. It's not the cable's fault, because I used my brother's HTC Desire (Android) and it synced just fine. My Lumia 1020 (using the same cable) connects and disconnects every 5 seconds..
    05-06-2015 10:33 AM

Similar Threads

  1. Replies: 17
    Last Post: 11-13-2013, 09:43 AM
  2. Replies: 4
    Last Post: 12-16-2012, 08:02 PM
  3. Replies: 1
    Last Post: 12-16-2012, 03:17 PM
  4. Replies: 4
    Last Post: 11-18-2012, 11:13 AM
  5. How to keep screen on when plugged in?
    By RockPaperBFG in forum Other Operating Systems
    Replies: 3
    Last Post: 08-15-2011, 04:34 PM
LINK TO POST COPIED TO CLIPBOARD