1. Ashish Saraf1's Avatar
    my battery was 100 % charged today morning at 8am and by 11 am it was 97%.
    After that i suddwnly noticed a sharp drop in battery around 1pm and it was 71%.

    on switching off and on..it came back to 91% ??!!
    11-01-2013 10:22 AM
  2. Microsoftjunkie's Avatar
    This is true, we are all experiencing this problem. Some more than others. I kinda trained myself to restart my phone at least once a day in the afternoon to get better accuracy.
    11-01-2013 10:24 AM
  3. Ashish Saraf1's Avatar
    i never faced this issue in 520 !!

    does it only occur in 820 ?
    11-01-2013 11:03 AM
  4. BitPusher2600's Avatar
    Never seen this on the Ativ S Neo either. Maybe a replacement is in order? You don't have anything new running in the background tasks do you? Never hurts to take some guesses.
    11-01-2013 12:26 PM
  5. Ashish Saraf1's Avatar
    everything blocked in background task !!
    11-01-2013 01:20 PM
  6. jeetu4444's Avatar
    My lumia 1020 is new but no issue here. Check your location is on and check tap to send is on by default
    11-02-2013 06:11 AM
  7. Ashish Saraf1's Avatar
    they are off
    11-02-2013 08:17 AM

Similar Threads

  1. Real World Battery Life
    By realwarder in forum Microsoft Surface Laptop
    Replies: 85
    Last Post: 11-16-2013, 03:42 PM
  2. Battery drains very fast! :(
    By Gowtham Doraiswamy in forum Windows Phones
    Replies: 16
    Last Post: 11-05-2013, 05:16 AM
  3. App studio site problem
    By birgs in forum Microsoft News & Rumors
    Replies: 2
    Last Post: 11-01-2013, 07:36 PM
  4. Trolling Battery?
    By iAdrian23 in forum Windows Phones
    Replies: 5
    Last Post: 10-31-2013, 08:47 PM
  5. SophieLens HD problem, ''unable to connect to HERE''
    By ilias bo in forum The Photography Lounge
    Replies: 0
    Last Post: 10-31-2013, 08:05 AM
LINK TO POST COPIED TO CLIPBOARD