1. yorkshiretea's Avatar
    Hi, I used the Windows Developer thing to download and install the GDR3 update and it worked fine except nothing happens when I now connect the phone to my PC via USB. I'm using Windows 7 x64. The phone icon in 'Devices and Printers' stayed ghosted so I tried uninstalling it but now it just fails when I connect and gets listed as 'Unknown Device' with the yellow exclamation mark.

    Not sure what to do now. Any ideas?

    untitled-1.jpg
    12-14-2013 10:53 AM
  2. Ashish Saraf1's Avatar
    Go to device manager...uninstall your 920 drivers and connect again with internet connection..

    sent either from my Nokia Lumia 820 or HTC Desire HD
    12-14-2013 11:48 AM
  3. yorkshiretea's Avatar
    Go to device manager...uninstall your 920 drivers and connect again with internet connection..

    sent either from my Nokia Lumia 820 or HTC Desire HD
    Tried that. I get what you see in the image attached above after I connect again.
    12-14-2013 11:58 AM
  4. anon(7900571)'s Avatar
    Try using a different pc. If it works on different pc then there must be problem with your windows 7 machine. Good luck xxxx
    12-14-2013 12:16 PM
  5. Ashish Saraf1's Avatar
    Tried that. I get what you see in the image attached above after I connect again.
    Try soft resetting your phone or your last option us to try on another pc

    sent either from my Nokia Lumia 820 or HTC Desire HD
    12-14-2013 12:54 PM
  6. yorkshiretea's Avatar
    Sorry everyone... strange coincidence. Turns out there's something wrong with the USB cable. Used another and it's fine. Inexplicable really since it hasn't been damaged at all but there we go.
    anon(7900571) likes this.
    12-14-2013 01:00 PM
  7. anon(7900571)'s Avatar
    Sorry everyone... strange coincidence. Turns out there's something wrong with the USB cable. Used another and it's fine. Inexplicable really since it hasn't been damaged at all but there we go.
    Glad that worked for you. It's time to get a new USB cable for this Christmas lol xx
    12-14-2013 01:30 PM

Similar Threads

  1. app store not updating
    By decentdude02 in forum Windows Phones
    Replies: 18
    Last Post: 05-05-2014, 02:31 PM
  2. Hi guys help me pick my first Windows phone :D
    By KrisJoeEll in forum New to the Forums? Introduce Yourself Here!
    Replies: 41
    Last Post: 12-16-2013, 10:33 PM
  3. Graphical bug after removing touch cover 2
    By sz3824 in forum Microsoft Surface Laptop
    Replies: 2
    Last Post: 12-15-2013, 01:52 PM
  4. Replies: 4
    Last Post: 12-14-2013, 11:40 AM
  5. Nokia Lumia can't detect my home WiFi.
    By Idzaudin Idz in forum Windows Phones
    Replies: 2
    Last Post: 12-14-2013, 07:27 AM
LINK TO POST COPIED TO CLIPBOARD