Surface Pro 7 deal! Save big at Amazon right now

  1. Joseph Buhagiar's Avatar
    Hey there everyone, I just went ahead and purchased windev -$21 AUD...

    I wasnt quite sure what it was before I purchased and I was wondering why I keep getting a ip over usb trying to make my phone a development device?! its stressing me out and nothing seems to fix it...
    Last edited by Joseph Buhagiar; 02-18-2014 at 02:40 AM.
    02-18-2014 12:11 AM
  2. N_LaRUE's Avatar
    I'm a little confused why you would buy something without knowing what it was beforehand. That seems a little silly.

    What you have happening it the phone wanting you to use the IP service when plugged into USB, which is Windows Phone IP over USB Transport (IpOverUsbSvc). To activate it in Windows do the following:

    Open Control Panel and select "Administative Tools" and you will find "Services" icon in it. Double clicking it also opens the Services window.

    After performing one of the above, Find the service with the name "Windows Phone IP over USB Transport (IpOverUsbSvc)" and right click on it and Start/Restart the service.

    Try rebooting your phone afterwards as well.

    WinDev is an app development tool. To develop for WP you need a development device to test your app you need this service. No need to panic.
    02-18-2014 03:06 AM
  3. Joseph Buhagiar's Avatar
    Oooh haha, I tried that but it still comes up with the error?

    Thanks for your help though :) its really appreciated.
    02-18-2014 03:20 AM
  4. N_LaRUE's Avatar
    Oooh haha, I tried that but it still comes up with the error?

    Thanks for your help though :) its really appreciated.
    Do you have an Active SIM? I've read that's the other part of things. Did you reboot your computer as well?
    02-18-2014 03:29 AM
  5. Joseph Buhagiar's Avatar
    Yea active sim and all my apps are on it, ive been doing it all afternoon and nothings happening
    02-18-2014 04:41 AM
  6. N_LaRUE's Avatar
    I found this information on at this link: How to deploy and run a Windows Phone app

    There's a section on Troubleshooting. I know you're using WinDev but this might be useful to you. The section you want is near the bottom of the page.
    02-18-2014 04:57 AM
  7. Joseph Buhagiar's Avatar
    I get stuck running the ipoverusbenum tool, a command window opens then closes?
    02-18-2014 05:14 AM
  8. Joseph Buhagiar's Avatar
    but when i open the ipoverusbsvc line it states it cannot be started from the command line, but that a windows service must be installed first?
    02-18-2014 05:15 AM
  9. N_LaRUE's Avatar
    I have an idea. How about installing the WP8 SDK? Maybe that will solve your issues. That's if you haven't installed it already.

    Windows Phone Dev Center
    02-18-2014 05:29 AM
  10. Joseph Buhagiar's Avatar
    haha yea its installed, its fine now though... cant be bothered...... i just used the app unlocker and ill leave it at that.
    02-18-2014 05:59 AM

Similar Threads

  1. Just switched to 1020 from 920 weird caller id issue
    By MikesChevelle in forum Windows Phones
    Replies: 4
    Last Post: 03-04-2014, 08:06 PM
  2. Is Windows Phone 8.1 too little, too late?
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 1
    Last Post: 02-21-2014, 07:39 PM
  3. HTC 8x Windows Phone 8.1
    By Shane Worrell Louis in forum Other Operating Systems
    Replies: 2
    Last Post: 02-20-2014, 04:34 PM
  4. Windows Phone App Updates/Notifications
    By matthoms in forum Other Operating Systems
    Replies: 16
    Last Post: 02-19-2014, 11:01 AM
LINK TO POST COPIED TO CLIPBOARD