05-29-2016 07:15 PM
258 ... 678910 ...
tools
  1. DavidinCT's Avatar
    I did a hard reset yesterday and it fixed a lot of the little nagging problems I was having. The battery life is much better now, the WiFi no longer cuts out, and the OS seems to lag less than it was before. But the lock button problem is still there. Nothing I can't live with.
    Yea, a hard reset seems to have resolve all the little naggy things that 8.1 had. My ICON was pretty new, so I didn't really have many save games to lose. I dont see any lag, or at least that I noticed. Every once and a while, a button issue pops up, it could be me just hitting the lower part of the button but, after a 2nd press, it always turns on...instantly.

    Even at that point, the advanages of the feature set of 8.1 is worth a little naggy problems here and there. The battery issue is a LOT better but, still, if I play a game, in a 5 min window, I can see my battery drop by 10%, this is prob firmware driver related, after the offical Nokia release (or Verizon in our case), this should get ALOT better. If I just do calls, texts, email and a little app play (no games, but some use of facebook, twitter, Weave, browsing the web), I would not be shocked if I got a day and 1/2 out of it... but, if I play games, I better have a charger with me...
    05-02-2014 09:43 AM
  2. matty032's Avatar
    Update the wife's Icon. She loves it!
    05-02-2014 10:17 AM
  3. Govinddas Gujarathi's Avatar
    I recently updated to WP8.1 on my Nokia Lumia 720. The update was successful. At one point after finishing the update, I was going through the settings to check new functionality and when I was in Glance setting got a pop-up asking to restart the phone for some new features to install now or later. I chose the Install Later option, but after restarting the phone manually didn't see any new settings in the Glance screen. Then, I had to go out of station for a 3 day weekend trip into Forest areas. I had very bad experience that time. I had charged my phone fully before starting my journey and within 8 hours it drained completely and to my surprise I didn't see goodness of battery saver as seen on WP8. After reaching there, I put the phone on charging and after some time found that the screen had frozen on a time almost 2-3 hrs back and kind of hang-up and irresponsive power button. I allowed the battery to drain, as i had no options to reset the phone. After the phone was completely dead, I started charging again and again the phone turned on automatically. Unfortunately, there was no power whole night in that area and I had to stop charging phone at around 30% charge. In the middle of night I wanted to use camera flash for guiding my son, the screen didn't turn on and I could see only backlit on and nothing on the screen. This happened twice and also there was no network coverage in those areas. On searching manually I could see some networks, even though I had roaming activated, it didn't allow me to choose network.
    Thinking of going back to WP8 as I see WP8.1 is still having bugs. Can anybody suggest me how to bring it back to normal?
    05-04-2014 10:11 PM
  4. DavidinCT's Avatar
    I recently updated to WP8.1 on my Nokia Lumia 720. The update was successful. At one point after finishing the update, I was going through the settings to check new functionality and when I was in Glance setting got a pop-up asking to restart the phone for some new features to install now or later. I chose the Install Later option, but after restarting the phone manually didn't see any new settings in the Glance screen. Then, I had to go out of station for a 3 day weekend trip into Forest areas. I had very bad experience that time. I had charged my phone fully before starting my journey and within 8 hours it drained completely and to my surprise I didn't see goodness of battery saver as seen on WP8. After reaching there, I put the phone on charging and after some time found that the screen had frozen on a time almost 2-3 hrs back and kind of hang-up and irresponsive power button. I allowed the battery to drain, as i had no options to reset the phone. After the phone was completely dead, I started charging again and again the phone turned on automatically. Unfortunately, there was no power whole night in that area and I had to stop charging phone at around 30% charge. In the middle of night I wanted to use camera flash for guiding my son, the screen didn't turn on and I could see only backlit on and nothing on the screen. This happened twice and also there was no network coverage in those areas. On searching manually I could see some networks, even though I had roaming activated, it didn't allow me to choose network.
    Thinking of going back to WP8 as I see WP8.1 is still having bugs. Can anybody suggest me how to bring it back to normal?
    This thread was about the upgrade on the ICON, not the 720. As the general thing, if your dealing with the poor battery or other bugs after you did the upgrade, then the suggested thing is to do a hard reset if your device (this will clear out all your data). There is a Nokia Recovery tool, just by looking over this area you would of found it, this would bring you back to WP 8.

    Anyway about it, to recover it, you will have to do a hard reset, I believe the Nokia tool flashes a rom back in that case your data would be lost.

    Do some homework on the battery issues, like I said, a hard reset really helps.... There is plenty of other threads on this issue.
    05-05-2014 07:59 AM
  5. Indistinguishable's Avatar
    Yea, a hard reset seems to have resolve all the little naggy things that 8.1 had. My ICON was pretty new, so I didn't really have many save games to lose. I dont see any lag, or at least that I noticed. Every once and a while, a button issue pops up, it could be me just hitting the lower part of the button but, after a 2nd press, it always turns on...instantly.

    Even at that point, the advanages of the feature set of 8.1 is worth a little naggy problems here and there. The battery issue is a LOT better but, still, if I play a game, in a 5 min window, I can see my battery drop by 10%, this is prob firmware driver related, after the offical Nokia release (or Verizon in our case), this should get ALOT better. If I just do calls, texts, email and a little app play (no games, but some use of facebook, twitter, Weave, browsing the web), I would not be shocked if I got a day and 1/2 out of it... but, if I play games, I better have a charger with me...
    Update on this, I no longer have the lock button problem. It's now perfectly responsive. WP8.1 on the Nokia Lumia Icon is now flawless for me.
    DavidinCT likes this.
    05-05-2014 03:59 PM
  6. csiguy1's Avatar
    Yes, I am having the same problem with my power button not turning the phone on. We need a fix quickly on this. I am in sales and need to make many, many calls per day and cannot have this issue at all.
    05-07-2014 08:32 PM
  7. Kage Maru's Avatar
    Update on this, I no longer have the lock button problem. It's now perfectly responsive. WP8.1 on the Nokia Lumia Icon is now flawless for me.
    What did you do to fix the lock button problem? I did a hard reset on my phone and that fixed it, but for only a few days. I suspect the lock screen problem stems from the start screen needing to load for whatever reason. For me, if the lock button is responsive, when I try to unlock my phone, I'm presented with a "loading..." black screen until my start screen appears. There have been a few times where I had to do a soft reset on the phone just for it to boot up. Otherwise, it's usually a ~5 second delay from the time I press the button, to the time the lock screen appears.

    Yes, I am having the same problem with my power button not turning the phone on. We need a fix quickly on this. I am in sales and need to make many, many calls per day and cannot have this issue at all.
    Yeah, I use my phone for work as well and there has been a few times where the buggy performance has hindered my work. I have no one to blame but myself for putting unfinished software on my phone though. =/
    05-08-2014 11:25 AM
  8. cbreze's Avatar
    Have you guys tried shutting off WiFi for the start button wake up issue/delay? This fix has worked for me and some others. I'm using an icon.
    05-08-2014 01:12 PM
  9. Joel S79's Avatar
    Have you guys tried shutting off WiFi for the start button wake up issue/delay? This fix has worked for me and some others. I'm using an icon.
    The slow power button was annoying, but not a deal breaker. However, I did this and it's seemed to do the trick. :)
    05-09-2014 02:20 PM
  10. c0wb0ycliche's Avatar
    The power button delay issue came back for my Icon.

    I used Nokia Software Updater to return to 8.0, updated to the new Verizon firmware, and then upgraded to 8.1 again. I'll post if it is better.

    I love the new features, and I am well aware this is (for all intents and purposes) a "beta test," but I might go back to 8.0 if many of the issues aren't resolved with this update. Don't get me wrong, I love the Developer Program, and it is awesome to let us get our hands on new software early, but for my daily use (which is... excessive lol) the power button/wifi/battery issues seem to have escalated to a point where I'd prefer the stability to new features.

    As an aside, and this is more 8.1 than Icon related, the lack of integrated social sharing (and lack of a Twitter app that you can "share to" since they pulled the beta) is more impactful than I expected. I'm used to posting interesting articles that I find online to both Facebook and Twitter at the same time, and whereas this was one click in 8.0, in 8.1 now I can "share to" Facebook (but it posts an ugly link and not a linked page style post like it used to) and then copy the text, go into Twitter, paste it, and post there. If the default Facebook share formatted links correctly and the Twitter beta was still in the store, I might be more inclined to wait it out. But we will see.
    05-10-2014 09:23 AM
  11. Abdullah Al Mandhari's Avatar
    My power button does not respond many times since the WP8.1 update also
    05-14-2014 08:02 AM
  12. anon(5445874)'s Avatar
    Ok, so new update today. Did it fix this problem?
    05-14-2014 12:51 PM
  13. Indistinguishable's Avatar
    Ok, so new update today. Did it fix this problem?
    I'm in the process of installing now. Trying to decide if I should do a hard reset without recalling settings after the update or not to make it a completely clean slate.
    05-14-2014 12:58 PM
  14. anon(5445874)'s Avatar
    I'm in the process of installing now. Trying to decide if I should do a hard reset without recalling settings after the update or not to make it a completely clean slate.
    I say wait and see how things work. Although, a hard reset could be fun..
    05-14-2014 01:16 PM
  15. airjeff's Avatar
    When you guys post up issues/problems now can you also post if you've applied the latest update from VZW?
    05-14-2014 01:36 PM
  16. antsin3d's Avatar
    Updated successfully. Seems quicker overall, power button responds in about half the time as before (so still a little lag but not as much. Probably wouldn't notice it if I weren't used to it being laggy). Also I had lost the ability to swipe upward on bottom menu bars (had to tap the ... on the right), but now that's back. Looking good so far!
    05-14-2014 01:40 PM
  17. Dreamspell's Avatar
    "Drat. Icon still has the power-on button issue." - Daniel Rubino

    https://twitter.com/Daniel_Rubino/st...47567611478016

    05-14-2014 02:10 PM
  18. c0wb0ycliche's Avatar
    Yeah its still doing it unfortunately. Hopefully more updates are on the way!
    05-15-2014 08:30 AM
  19. c0wb0ycliche's Avatar
    It's not only doing it, it's doing it far worse for me than before the update.

    Any luck with fixes?
    05-15-2014 10:15 AM
  20. quantum tao's Avatar
    if you mean its not coming on, forcing you to soft reset or use the camera button to make it wake up, did you install the updated firmware from verizon?
    if not, then you need to roll back to 8.0 install the firmware and then update to 8.1 again.
    my icon wakes every time now and the wifi works much better and no more data cutouts.
    05-15-2014 11:57 AM
  21. Indistinguishable's Avatar
    I'm in the process of installing now. Trying to decide if I should do a hard reset without recalling settings after the update or not to make it a completely clean slate.
    Just as an fyi, I ended up doing a hard reset after the update just for the sake of a clean slate.

    I'll report here how battery life turns out after a week.
    05-15-2014 02:16 PM
  22. c0wb0ycliche's Avatar
    I went back to 8.0 with NSU, installed new firmware, went to 8.1, updated 8.1.

    No issues with WiFi, but got burning hot in my pocket (once,) and I didn't have the wake up delay until the new update. Now when I press the power button its like a good 3-5 seconds before screen comes on. Also had it reset itself once and randomly power down.

    Nothing I can't deal with until official update, but annoying nonetheless.
    05-16-2014 08:21 AM
  23. c0wb0ycliche's Avatar
    My phone has been a mess since the latest update. It's ridiculous. Non-stop "Loading..." and "Resuming..." at start screen. Unresponsive anywhere from a few seconds to a few minutes. Notification center also doesn't work during these times. Anyone else experiencing this?
    05-17-2014 07:43 PM
  24. Indistinguishable's Avatar
    My phone has been a mess since the latest update. It's ridiculous. Non-stop "Loading..." and "Resuming..." at start screen. Unresponsive anywhere from a few seconds to a few minutes. Notification center also doesn't work during these times. Anyone else experiencing this?
    I'm not getting that at all... Did you try a hard reset without restoring settings?
    05-18-2014 06:38 AM
  25. Dreamspell's Avatar
    So, since Tuesday I upgraded back to 8.1 with the new firmware installed. I was thinking of hard resetting and not restoring from a backup, but decided to see how the phone performed first.

    I haven't suffered from the screen wake delay at all nor the overheating, but I do get false battery meter readings now and then and my WiFi still isn't as good as 8.0 but better than the last time that I had 8.1, now that I have the new firmware. The purple hue from automatic brightness is also gone, though I had tweaked the color profile. I haven't gotten the "Loading" and "Resuming" on the Start Screen, but I don't have the Cortana tile pinned to my start screen, which some believe is the cause.

    My battery life is almost the same as 8.0
    05-18-2014 08:38 AM
258 ... 678910 ...

Similar Threads

  1. No 4G on Lumia 1320
    By i_Neel in forum Windows Phones
    Replies: 17
    Last Post: 01-21-2018, 11:27 PM
  2. action video poor on the Nokia Lumia 1020
    By Byron Storie in forum Windows Phones
    Replies: 3
    Last Post: 04-14-2014, 06:21 PM
  3. WP8.1 update stuck on 96%
    By Mehedi Hassan Dip1 in forum Other Operating Systems
    Replies: 16
    Last Post: 04-14-2014, 01:46 PM
  4. Help- Phone wont download updates
    By Idan Cohen in forum Other Operating Systems
    Replies: 2
    Last Post: 04-14-2014, 08:38 AM
  5. 8.1 on your 822
    By Jen Sanko in forum Windows Central Archive
    Replies: 1
    Last Post: 04-14-2014, 07:43 AM
LINK TO POST COPIED TO CLIPBOARD