1. Nikhilteja's Avatar
    Internet explorer is very lagging in Windows phone 8.1. Also the tab switching is not smooth like earlier. A 1 second lag can be observed while closing the last tab in the internet explorer.
    04-14-2014 12:51 PM
  2. herbertsnow's Avatar
    I find that everything is laggy since the update to my 520. I'm going to try a hard rest and see if that fixes it.
    04-14-2014 01:38 PM
  3. peterkrisztianszabo's Avatar
    Wow, you wrote this in April! Amazing. I got lumia cyan (final) in August and noticed this right away.
    09-26-2014 05:45 AM
  4. gauty44's Avatar
    I also have the same complaint with cyan update, and most importantly ie11 has no option to open link in new tab which was very helpful in ie10. Tab switching also not smooth
    09-26-2014 06:04 AM
  5. peterkrisztianszabo's Avatar
    It has the option to open a link in new tab! Tap and hold on a link and a short menu should show up. I use it all time!
    10-01-2014 04:40 AM

Similar Threads

  1. WP8.1 Tips & Tricks
    By a5cent in forum Other Operating Systems
    Replies: 203
    Last Post: 11-02-2015, 05:17 PM
  2. People Hub and Battery drain
    By liam-ward in forum Other Operating Systems
    Replies: 3
    Last Post: 04-18-2014, 01:07 AM
  3. Adding home and work addresses to notebook
    By ygtgngr in forum Windows 10
    Replies: 2
    Last Post: 04-16-2014, 08:43 PM
  4. Battery Drain - Charging and battery doing down?
    By dkp23 in forum Other Operating Systems
    Replies: 2
    Last Post: 04-14-2014, 01:06 PM
  5. Question about Here Drive and My Commute
    By Carkid367 in forum General Phone Discussion
    Replies: 0
    Last Post: 04-14-2014, 12:33 PM
LINK TO POST COPIED TO CLIPBOARD