1. lorisuzan's Avatar
    Hey guys does anyone know how to activate wifi when you're home or at work with 8.1? I searched everywhere and even asked cortana and I couldn't find that option. I thought they talked about that feature even during build so that's why I am asking the question here.

    Thanks
    04-14-2014 10:30 PM
  2. pvcleave's Avatar
    I believe this is what your are asking. Go to WiFi settings and turn it off. In the Turn WiFi on dialog box select near my favorite places. Then go to Cortanas notebook and put some favorite places in.

    I have had it only turn on, I do not know if it turns off when you leave.
    b23h likes this.
    04-14-2014 10:42 PM
  3. lorisuzan's Avatar
    Thank you so much ! it wasn't shown anywhere and I didn't see peopel talking aboutit
    04-14-2014 10:45 PM
  4. safesax2002's Avatar
    I believe this is what your are asking. Go to WiFi settings and turn it off. In the Turn WiFi on dialog box select near my favorite places. Then go to Cortanas notebook and put some favorite places in.

    I have had it only turn on, I do not know if it turns off when you leave.
    I suspect it doesn't turn off either. Not a deal killer but that one extra step would have been nice. Won't complain though.
    04-14-2014 10:59 PM
  5. b23h's Avatar
    I believe this is what your are asking. Go to WiFi settings and turn it off. In the Turn WiFi on dialog box select near my favorite places. Then go to Cortanas notebook and put some favorite places in.

    I have had it only turn on, I do not know if it turns off when you leave.
    It doesn't turn off when you leave. That kind of destroys its' function to do the entire job.
    04-16-2014 05:14 PM
  6. Novron's Avatar
    That's also clumsy as hell. I have favorite places (mostly to set up travel times and directions) where there are no WiFi's or ones I wouldn't want to connect to. That's like, "please burn my battery when I get near these places."
    04-17-2014 04:10 AM
  7. b23h's Avatar
    I think the Geofencing Wi-Fi is a great concept, but if it only turns ON the Wi-Fi when you get close to the location, but does not turn it OFF again when you leave, that's a pretty flawed implementation. It takes what could have easily have been a set it once feature and leave it alone, and turns it into another reason to always have to remember to toggle the Wi-Fi. I really hope that MS has it, or puts it on the list of things to fix....
    04-17-2014 11:31 AM
  8. oryan_dunn's Avatar
    I think the Geofencing Wi-Fi is a great concept, but if it only turns ON the Wi-Fi when you get close to the location, but does not turn it OFF again when you leave, that's a pretty flawed implementation. It takes what could have easily have been a set it once feature and leave it alone, and turns it into another reason to always have to remember to toggle the Wi-Fi. I really hope that MS has it, or puts it on the list of things to fix....
    Yeah, would be awesome if it would turn it off when you left an area. Also, I'd like to be able to have an option in the places menu of Cortana to disable WiFi at a location. Ie. I add work as a favorite location, but I don't want WiFi to turn on while I'm at work (since we don't have WiFi here).
    b23h likes this.
    04-18-2014 11:09 AM
  9. b23h's Avatar
    Yeah, would be awesome if it would turn it off when you left an area. Also, I'd like to be able to have an option in the places menu of Cortana to disable WiFi at a location. Ie. I add work as a favorite location, but I don't want WiFi to turn on while I'm at work (since we don't have WiFi here).
    Good point! So a list of favorite places, but instead of just the one setting under wi-fi "turn on near favorite places", there should be toggles for if wi-fi should be on at that location or not. makes sense to me.
    04-18-2014 01:36 PM
  10. b23h's Avatar
    Another WPC user suggested that I post on Uservoice about this issue.

    Wi-Fi Geofencing turns itself off when leaving favorite location – Feature Suggestions for Windows Phone

    I do want to thank oryan_dunn for his comment here in this thread about how some favorite locations may not require that the Wi-Fi turn itself back on and I did give him credit in the uservoice post.
    04-18-2014 11:01 PM
  11. anon(7901790)'s Avatar
    I've tried this and it didn't work for me. Before leaving my house, I set up my favorite Starbucks as a favorite and turned off WiFi and selected turn back on when near my favorite place. When I got to that Starbucks, it did not turn itself on. I've read in some other threads that other people couldn't get it to work either.

    I did get the turn it on after 1 hour to work.
    04-18-2014 11:15 PM
  12. b23h's Avatar
    I've tried this and it didn't work for me. Before leaving my house, I set up my favorite Starbucks as a favorite and turned off WiFi and selected turn back on when near my favorite place. When I got to that Starbucks, it did not turn itself on. I've read in some other threads that other people couldn't get it to work either.

    I did get the turn it on after 1 hour to work.
    Well that is interesting. I'm not sure what to say. I've tried it at least twice and it worked fine. I set my apartment as a favorite location and then took a walk. A far distance away from the apartment, I turned off the Wi-Fi. I continued to walk and when I came back toward the apartment I watched the phone. The Wi-Fi turned on maybe five hundred feet away...

    My first question is a real obvious one. You do have your location services as on, yes? Under Settings/Location, does it say that it is tracking geofences or not?

    Finally I am not so sure I know what you mean by "I did get the turn it on after 1 hour to work. "
    04-19-2014 12:03 AM
  13. anon(7901790)'s Avatar
    Well that is interesting. I'm not sure what to say. I've tried it at least twice and it worked fine. I set my apartment as a favorite location and then took a walk. A far distance away from the apartment, I turned off the Wi-Fi. I continued to walk and when I came back toward the apartment I watched the phone. The Wi-Fi turned on maybe five hundred feet away...

    My first question is a real obvious one. You do have your location services as on, yes? Under Settings/Location, does it say that it is tracking geofences or not?

    Finally I am not so sure I know what you mean by "I did get the turn it on after 1 hour to work. "
    Ok. This time it worked. I turned off my WiFi before leaving the house and selected turn back on when near my favorites. When I got home, I noticed that my WiFi was turned back on. Maybe the GPS got my location close enough for it to say that it can turn on. I've noticed that GPS accuracy seems to be a little off sometimes. I'm not sure if it's because I'm in Hawaii or if there are some kind of atmospheric, solar, or electromagnetic interference/anomalies that cause it to be a little off.

    I've run into this issue with both my 928 and Galaxy Note II as well. We live near Pearl Harbor/Hickam AFB and its possible that all the electronic interference from them is causing problems.
    04-20-2014 08:53 PM

Similar Threads

  1. Cortana only showing interets over wifi
    By Matthew C in forum Windows 10
    Replies: 4
    Last Post: 02-10-2015, 08:39 PM
  2. Wifi Sense Setting Disappearing
    By Ex14 in forum Other Operating Systems
    Replies: 14
    Last Post: 08-29-2014, 08:34 AM
  3. Sharing Wifi networks
    By mdb17 in forum Other Operating Systems
    Replies: 7
    Last Post: 04-23-2014, 12:01 AM
  4. Wifi eap-tls and peap is available?
    By doob9910 in forum Other Operating Systems
    Replies: 5
    Last Post: 04-22-2014, 10:40 AM
  5. WiFi Direct and GoPro
    By TheZuneLune in forum General Phone Discussion
    Replies: 0
    Last Post: 04-14-2014, 07:59 PM
LINK TO POST COPIED TO CLIPBOARD