1. Cheewii Poon's Avatar
    Since the start of my Lumia 720's lifespan and WP8.0, I've always had problems with connecting my phone to my computer via USB. At first I didn't notice a problem as it was just like another Android phone's connection, except a bit slower to recognize the phone. Note that I don't have the app to transfer photos and stuff from, I just use the normal FTP file transfer. Also i always thought it was a bit weird that when the thingy "app" that pops up in the taskbar when the phone is connected, my icon looked like a grey/black Lumia 620 (with blank screen) even though the screen said (Nokia Lumia 720 (RM-855), but thought nothing much of this.

    However, when I brought my phone to school and plugged it into my school's computer, I was surprised the connection was much faster and the icon/app was a black Lumia 720 with a blue theme and homescreen showing, and that the "app" showed my missed calls and battery percentages. Now, after the 8.1 update, it has gotten worse especially after I uninstalled the drivers and reinstalled them to try and get the Project My Screen app's controlling the phone from computer function to work.

    Now, it shows the 720 icon, bt with no additional info and takes a long time to connect and sometimes doesn't even connect. Also, the connection is easily disconnected with a little move of the wire/phone, and sometimes even when the phone is not moving the connection goes on and off. I am 99% sure the problem isn't with the cable as it's the same with other cables/works normal with other phones, and not my phone's port problem either as it works fine with other computers. It's definitely a driver issue but I just cant get the drivers to work properly on this specific laptop even after uninstalling and installing from the phone/online.
    05-12-2014 06:23 AM
  2. anon(7900571)'s Avatar
    Seems like your laptop USB port does not have enough bandwidth speed , do you have any other USB devices plugged in ?
    Guytronic likes this.
    05-12-2014 09:33 PM
  3. Cheewii Poon's Avatar
    Yes, but just a regular old wireless mouse and wired keyboard, so i don't see why that should cause a problem. How can you tell it's a bandwidth problem, by the way?
    05-14-2014 10:31 AM
  4. Zapella Tiago's Avatar
    I used to have some issues with 3.0 USB port.

    Using 2.0 port seems pretty normal.
    05-14-2014 10:37 AM

Similar Threads

  1. Replies: 2
    Last Post: 05-12-2014, 01:35 PM
  2. Bluetooth volume in car phone calls
    By Trevor Jones in forum Other Operating Systems
    Replies: 2
    Last Post: 05-12-2014, 07:55 AM
  3. Q. Can 8.1 easily be reverted to 8.0 on Nokia phones?
    By slysy in forum Other Operating Systems
    Replies: 1
    Last Post: 05-12-2014, 05:18 AM
  4. My phone started freezing up constantly.
    By nerdyniko in forum Windows Phones
    Replies: 1
    Last Post: 05-12-2014, 04:54 AM
  5. Cortana needs a "Read my missed messages feature"
    By mpovolo in forum Windows 10
    Replies: 1
    Last Post: 05-11-2014, 11:47 PM
LINK TO POST COPIED TO CLIPBOARD