1. Mr_M_Cox's Avatar
    Hi All,

    I have just got a new car - a 2004/5 BMW 525d. When i went to setup my phone to work over in car Bluetooth for voice it paired fine and then worked.

    I have notice however that when I leave the car and come back to it my phone will auto connect, show as connected to the car and indeed the car will think it is connected to the phone.

    When I then go to make a call the car triggers the phone and the correct contact is rung. At that point it drops the connection leaving my phone to go back to standard audio through the handset. Very annoying. If I turn off Bluetooth and manually turn it on and select the car it will reconnect and then work fine.

    Does anyone know why the auto connect is dropping out and/or how I could get it working more fluently?.

    Thanks.
    05-19-2014 08:33 AM
  2. adrian1338's Avatar
    I have the same problem with my BMW Professional Radio from 2007. Shows the icon but calls for some reason I can answer with the steering wheel button but the sound will only be on the Handset. Worked alright the first time I synced it though.
    05-19-2014 08:59 AM
  3. Microsoftjunkie's Avatar
    Have you tried the "advance" Bluetooth option? Supposedly, it connects differently with units that have these types of problems. Results will vary depending on units.
    05-19-2014 09:08 AM
  4. adrian1338's Avatar
    Thought about that but after the initial connection offered my audio via Bluetooth as well as access to my contacts I expected it to be not the case of that checkbox
    05-19-2014 09:12 AM
  5. eugene89us's Avatar
    Happy to see people embracing diesels in the US. I drive a 2014 Passat TDI with over 50 MPG combined mileage. Good stuff for a midsize sedan, and as opposed to popular opinion of diesels, the urea system results in exhaust that has NO SMELL (compared to exhaust smell that gassers get.) I can run my diesel inside a closed garage with absolutely zero smell - wouldn't do it for long for obvious reasons, of course. LOL

    I had a similar problem in my car after I updated to 8.1 - some people say that bluetooth now uses both AD2P and voice protocols in 8.1 when previously was over AD2P for most things. I went into advanced settings, enabled the check-box to use alternate connection, unpaired the devices, and re-paired them. Now, all my calls work perfectly. I can stream music and make phone calls, as well as have Cortana read text messages to me while I drive, so I can reply without lifting a finger from the steering wheel. Before the check-box, Cortana didn't even come on - music would stop for a text, but no Cortana and music would not restart. Sometimes, phone calls would simply drop out. Strange. With the check-box, both voice calls and Cortana are transmitted through voice protocols (car displays it as a phone call) - no problems at all. And music streams every time. So far, experience has been flawless. But then we have two different German cars, so your experience may still vary even with my resolution.
    jfa1 likes this.
    05-19-2014 09:50 AM
  6. Mr_M_Cox's Avatar
    Thanks for all the discussion and tips. I will try ticking the advance option box before I head home from work and see what happens.
    05-19-2014 10:09 AM
  7. Will6371's Avatar
    Happy to see people embracing diesels in the US. I drive a 2014 Passat TDI with over 50 MPG combined mileage. Good stuff for a midsize sedan, and as opposed to popular opinion of diesels, the urea system results in exhaust that has NO SMELL (compared to exhaust smell that gassers get.) I can run my diesel inside a closed garage with absolutely zero smell - wouldn't do it for long for obvious reasons, of course. LOL

    I had a similar problem in my car after I updated to 8.1 - some people say that bluetooth now uses both AD2P and voice protocols in 8.1 when previously was over AD2P for most things. I went into advanced settings, enabled the check-box to use alternate connection, unpaired the devices, and re-paired them. Now, all my calls work perfectly. I can stream music and make phone calls, as well as have Cortana read text messages to me while I drive, so I can reply without lifting a finger from the steering wheel. Before the check-box, Cortana didn't even come on - music would stop for a text, but no Cortana and music would not restart. Sometimes, phone calls would simply drop out. Strange. With the check-box, both voice calls and Cortana are transmitted through voice protocols (car displays it as a phone call) - no problems at all. And music streams every time. So far, experience has been flawless. But then we have two different German cars, so your experience may still vary even with my resolution.
    What head unit have you in your Passat? I have a '13 CC with RNS510 with and if I leave the car for more than half an hour my Nokia radio will not auto play.
    05-19-2014 01:42 PM
  8. pvcleave's Avatar
    I am having issues in my 2013 Mercedes. I never had any issues at all. I do not have issues with phone calls. I have issues with replying to texts. I do not do a lot of text in the car, but after the text is read, it ask if I would like to reply, etc., when I say reply it says it cannot hear me. Once it did finally recognize me when I said reply, then it asked who I wanted to text, when I said the name it came back with the wrong person.

    I kicked the voice manually and tried to dictate my message, it would either come back it could not hear anything or say there is know phone coverage, this is in areas with full bars, great coverage.

    ​Music streaming and voice calls work with no problem.
    05-19-2014 02:59 PM
  9. Mr_M_Cox's Avatar
    Unfortunately still the same result when ticking the advanced option. I have even now tried re adding the phone with no improvement.
    Given the lack of options surrounding this function I think it is a fairly good bet that I will just have to live with manually connecting the phone up for now and hope that maybe full release 8.1 will feature an update/change that will help.

    If anyone does have any other suggestions please let me know, would be much appreciated.
    05-20-2014 03:40 AM
  10. eugene89us's Avatar
    What head unit have you in your Passat? I have a '13 CC with RNS510 with and if I leave the car for more than half an hour my Nokia radio will not auto play.
    I, too, have RNS510, and I exclusively use Pandora One for streaming. Every time I get into the car and the phone connects, the phone attempts to play the audio stream. If the audio stream is still valid (hasn't expired), it will restart where it left off. Yesterday, I got in my car 5 hours after leaving it, Pandora automatically finished playing pre-buffered song, then skipped 3 previously preselected songs (which I presume expired - they just went by on RNS510 screen as if I manually skipped them) and started playing a new set of songs. I am not sure if RNS510 has a setting somewhere whether or not to autoplay, but if I leave mine in "Media" (my only media is Bluetooth) - the RNS510 will always automatically restart whatever stream I paused. Sometimes, even next morning, so long as the stream is still in phone's memory. Once in a while I need to push the play button and the RNS510 will get Pandora playing.

    Sorry, Mr_M_Cox that you were unable to find a solution to this issue. I am hoping that with Nokia firmware, your issue will be resolved. Not sure if newer models implemented different streaming protocols than in 2005 (I imagine newer Bluetooth iterations). Please keep us posted if you find a solution.
    Mr_M_Cox likes this.
    05-20-2014 06:53 AM

Similar Threads

  1. Cortana Overheat Issue
    By 1oldtimer in forum Windows 10
    Replies: 6
    Last Post: 05-20-2014, 12:31 AM
  2. Do something For Lumia 920 Camera clarity !! :unhappy:
    By Krishnan Shekharamangalam in forum Windows Phones
    Replies: 1
    Last Post: 05-19-2014, 09:31 AM
  3. Lumia 636 and 638 coming ( rumoured)
    By renjith p george in forum Windows Phones
    Replies: 2
    Last Post: 05-19-2014, 06:29 AM
  4. Lumia 920, Stopped working, no responso until battery drain.
    By FelipeVenhorst in forum Windows Phones
    Replies: 2
    Last Post: 05-19-2014, 06:15 AM
  5. i want to connect ad hoc network with nokia mobile in surface rt
    By thanasap kanta in forum Microsoft Surface Laptop
    Replies: 1
    Last Post: 05-19-2014, 05:32 AM
LINK TO POST COPIED TO CLIPBOARD