1. realwarder's Avatar
    So I had setup a VPN (L2TP with IPSEC) in 8.1.1 but I thought I'd go check if it worked any better in the second 8.1.1 update as it didn't in the first.

    Sadly it doesn't. Profiles sit there connecting and you cannot cancel them.

    Worse, if you kill (Task X) the VPN settings page it reopens itself.

    When I then opened the notification menu (swipe down) and tried to turn of Wi-Fi thinking that might disturb things, it locked the phone up.

    Soft Reset required...

    After a reboot the phone is almost not responding (I'm assuming the VPN is trying to connect). The menu eventually came up and I went into settings to turn of the *** VPN and Settings just shows Loading.

    Oops... after a power button off/on (i.e. a sleep) home then went back to the Start and the settings just showed. I messed up and hit VPN. I was going to turn Airplane mode on as I thought that might help.

    So... WARNING: Do not try and enable L2TP VPN in the latest DP.

    (Maybe if settings are perfect it will work, else stay clear, alpha code area!)
    08-23-2014 04:49 PM
  2. jamir's Avatar
    Same problem here. I no longer use the VPN.
    It's really a shame they released the VPN so poorly implemented.
    01-29-2015 07:49 PM
  3. mika8's Avatar
    When creating a new L2TP VPN profile (maybe IKEv2 too), it's a good idea to leave "Send all traffic" to Off until you have verified that VPN connection works ok. After that you might prefer to have it "On".

    If "Send all traffic" is On and there's e.g. a problem with wifi connection or VPN tunnel creation is failing, device gets unresponsive and it's hard to get VPN turned off. Activating airplane mode and rebooting might help. I use WP8.1 update 1 L2TP VPN almost daily with Send all traffic On and connect automatically, without problems.

    One possibility to trigger the problem is when having VPN on and connecting to a wifi that needs some unique and temporary password entered using web browser. Technically wifi connection is up and running before those are entered, so VPN tries to connect. But since traffic is not yet routed to internet, VPN will be jamming the device.
    02-18-2015 02:13 AM
  4. bichaels's Avatar
    Same problem but I still find it useable.

    Sometimes it connects fine.

    When it fails to connect though it seems to get stuck for quite some time during which the device becomes unresponsive etc. I'm in china so quite often a connection will be unsuccessful due to blocking. The best solution however is just to wait (assuming you have nothing urgent to do!) as eventually, after several minutes, it will come back and say there was an error connecting at which point everything is back to normal.

    Obviously not ideal and would be better if there was a simple way to cancel it when it is unable to connect so hopefully this will get better soon!
    02-26-2015 04:54 AM

Similar Threads

  1. Using the HTC One M8 for Windows as a TV remote
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 1
    Last Post: 08-25-2014, 10:49 AM
  2. Is there a way to use the Pro3 as a wacom like tablet for my PC tower?
    By JonathanWinbush in forum Microsoft Surface Pro
    Replies: 3
    Last Post: 08-24-2014, 02:53 PM
  3. foobar2000 finally coming to WP8 (as well as iOS/Android)
    By Silviu Bogusevschi in forum General Phone Discussion
    Replies: 4
    Last Post: 08-23-2014, 06:25 AM
  4. Purchased 2 apps that donīt show up in the store as paid
    By Schnuffi in forum General Phone Discussion
    Replies: 2
    Last Post: 08-23-2014, 01:16 AM
  5. SMS as pop-up alert?
    By Shervrar in forum Ask a Question
    Replies: 0
    Last Post: 08-22-2014, 07:14 PM
LINK TO POST COPIED TO CLIPBOARD