1. ITmanagerNC's Avatar
    After updating and letting all the apps re-install, reset the phone a couple times as I usually do.

    I've had a couple of app / screen freezes, but I could close them and get back to the main screen a few times. This last time, while watching a Youtube video, it froze and eventually showed this:
    cimg3117.jpg

    Hard reset returned device to normal for now. Not sure if it will return. If anyone else has experienced this confirm here.
    10-24-2014 12:40 PM
  2. xandros9's Avatar
    I've had that sort of thing happen before once every few months.
    Nothing a soft reset couldn't fix.

    Also, I don't think there's any reason to reset something twice, whether hard or soft.
    gpobernardo likes this.
    10-24-2014 06:35 PM
  3. ivdza's Avatar
    After last update i hard reset my phone and voila its awesome. My camera (Microsoft Camera app),starts instantly,without loading screen at all !! No lags,no nothing bad for now,even battery is better... :))) Lumia 520.
    10-25-2014 02:26 AM
  4. Neelim Shyam's Avatar
    Do you need Wi-Fi to download temple run?? I am requiring it.
    10-25-2014 02:32 AM
  5. AmGaD-SaLaH's Avatar
    Do you need Wi-Fi to download temple run?? I am requiring it.
    I've updated my phone yesterday , and I've downloaded Age of empires via my cellular data without a problem
    Just make sure to set the data sense to unlimited
    And try soft-reset if you face any problems
    10-25-2014 03:25 AM
  6. Aditya Soni1's Avatar
    My CPU usage increased since i updated. does anyone else felt the same?
    10-25-2014 03:33 AM
  7. LTTG's Avatar
    White noise on a PHONE?
    10-25-2014 03:52 AM
  8. th34monk3ys's Avatar
    I lost my back buttons back light since update! Looks kind of cool! Works fine just two lit up buttons!
    10-25-2014 04:10 AM
  9. ITmanagerNC's Avatar
    Another problem. This morning went to take a photo, it was slow to focus and after the picture was taken it only showed a white screen, not a review of the photo. Could only force-close the app. Photo never saved and a blank (all black) 2MB copy was uploaded to Onedrive. Very Odd.
    10-25-2014 11:54 AM
  10. TimboNJ's Avatar
    This is the first time I've had a problems with an update. Problems charging the phone for one. Today I got a black screen and the phone was frozen. I had to take out the battery to get it to work again.
    10-25-2014 02:32 PM
  11. MDK22's Avatar
    One question - for all those with problems after update.

    After everything was restored & phone was prompting for (sim & phone) password - did you reboot ?

    This would be a good habit to get into (some say hard reset afterwards !) after install & restore, RESTART the phone once more, before use.
    10-25-2014 08:43 PM
  12. gpobernardo's Avatar
    My CPU usage increased since i updated. does anyone else felt the same?
    How were you able to tell that the CPU usage of your phone increased?
    10-25-2014 08:51 PM
  13. sectime's Avatar
    I downloaded and installed the update on my 635. I get an error that my Microsoft account password has expired (it hasn't) No way to type the password in. When I click on Outlook account only sync is shown then the error message. Any ideas before I wipe the phone again?
    10-26-2014 01:08 AM
  14. gpobernardo's Avatar
    The only time I encountered the "Microsoft account password has expired" prompt was when I was using the authenticator app but failed to input the generated passcode within the given amount of time (60 seconds). I find it strange, however, that there is "no way to type the password in" in your case.

    Did or are you using two-step authentication and the authenticator app?
    10-26-2014 01:24 AM
  15. sectime's Avatar
    Yes, I do use two-step, I downloaded the update, let the phone do its thing. After phone restarted this error popped up, I wasn't asked for any passwords. I checked my account and my password had not expired on any other device. I have changed my password anyway and signed in on all of my other devices. I can't find where to change my account on the phone since the update. The password box that sits under my user name is gone. However my iCloud and Gmail password boxes are there and working.Too weird.
    10-26-2014 05:10 PM
  16. sectime's Avatar
    Found this turning,automatic date/time off then on fixed my problem.
    Error 80070490 when try to syncronize Microsoft account - Microsoft Community
    gpobernardo likes this.
    10-27-2014 12:28 AM
  17. gpobernardo's Avatar
    Thanks for sharing the solution.
    10-27-2014 12:37 AM
  18. ITmanagerNC's Avatar
    I solved my issues by using the Nokia Recovery Tool.

    Backed up device
    Nokia Recovery tool wipe and reload
    let phone restart, did NOT restore from backup
    Was careful to just get the OS running and NOT enable backups
    Downloaded and re-enrolled in DP program
    Updated OS
    Set up and restored from backup.

    Phone and apps are the same versions as they were but the device is back to being stable.

    Its a PITA to perform because some things are not backed up and there is a lot of re-typing passwords but I'm glad I did this.
    gpobernardo likes this.
    10-28-2014 07:29 AM

Similar Threads

  1. Is it normal for the Lumia 520 to take long to update?
    By Nokia Boy in forum Windows Phones
    Replies: 22
    Last Post: 07-17-2016, 03:12 PM
  2. Why aren't my photos saving right since the recent update?
    By Nikita Norman in forum Windows Phones
    Replies: 1
    Last Post: 10-26-2014, 10:49 AM
  3. Wrapping internal xap for windows phone 8.1 update 1
    By cvanaxel in forum Developers Corner
    Replies: 2
    Last Post: 10-24-2014, 03:23 PM
  4. Samsung ATIV S getting Windows Phone 8.1 Update? Kind of
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 10-24-2014, 12:11 PM
  5. Driver issue after change MFG mode
    By frank zhao in forum Windows Phones
    Replies: 0
    Last Post: 10-24-2014, 11:23 AM
LINK TO POST COPIED TO CLIPBOARD