Surface Duo is on salefor over 50% off!

  1. cshekar1987's Avatar
    My lumia 920 was unused for months (because of display cracked) , and i decided to give it a try , charged it for a day after having the display change with a local person.
    When i connected to windows pc (before display change), it showed my phone name - but without any contents. I had to unlock it, couldn't coz display was off.
    Now once the display is changed, i am not able do anything but keep stare at some light flashing icon plus wheel.
    Phone is contentiously in 'Flash Icon and wheel' ( not sure if this is what cog wheel called) mode.
    When i connected it to PC it shows as 'NOKA BOOTMGR' and then turns to 'QUALCOM MSM DEVICE' under device manager.
    After some reaserch, i downloaded 'Windows recover tool' and somehow post several tries phone got detected - tool said new firmware available - i downloaded and flashed it. Tool shows success (phone shows NOKIA logo with red background and flashing progress bar) - i click finished, but phone still shows flash icon and wheel :(
    I tried hard reset - volume down + power + camera - phone vibrates , and only pressing power down post that takes again to flash icon + wheel mode.
    Any pointers are greatly helpful

    08-07-2018 07:56 AM
  2. aximtreo's Avatar
    Not sure if this will help but download from the MS site an app called Windows device recovery tool. Open the app and plug in your 920. Normally it will recognize the phone and give you the option of loading the most recent release for your particular device. if this doesn't work, maybe one of our site guru's can offer a better solution.

    good luck and let us know if you get it up and running.
    jmshub likes this.
    08-07-2018 12:36 PM
  3. cshekar1987's Avatar
    Thanks for the reply @aximtreo , i tried this and initially phone didn't get recognised but later some trail & error method ( holding all three buttons, removing power post vibration or removing all but keeping volume down, - or taking out power cable connected ) it detected phone, asked to download some firmware - i flashed it too with the tool, phone shows the progress bar with NOKIA logo and red background, but once the tool said finish, phone got rebooted with same flash icon plus gear icon :(

    I am not getting exclamation mark on the phone too ( tried all button combinations).
    Sometime one charging icon comes (battery icon with power cable connecting/disconnecting) in red but gets dissapeared some 10 seconds later - not consistent behavior.
    08-07-2018 01:27 PM
  4. cshekar1987's Avatar
    This is how it looks

    Any pointers are greatly helpful.
    Attached Thumbnails img-3103.jpg  
    08-09-2018 12:42 AM
  5. cshekar1987's Avatar
    This is how it looks

    Any pointers are greatly helpful.
    08-09-2018 12:43 AM
  6. cshekar1987's Avatar
    Here is another strange thing happened. I tried pressing all of the buttons ( volume up + down + power + camera ) - phone vibrates, loads nokia logo, and suddenly windows icon and voila, it loads OS. Asks all of the settings, i tied my microsoft a/c, works fine. Loads windows 8 cyan. But somehow home button doesn't work ( again i came across volume levels setting to max automaticaaly and that banner never goes up or disappears some kind of bug, back button loops this volume banner - i had posted about this three years back ). So i keep pressing back to kill all the apps and then load home page - this works though.
    Not it notifies for 8.1 update i am like happy and since its also charging i click install now, post reboot it again goes to this flash icon with one wheel - i don't know what's happening ....
    experts please help ......
    08-09-2018 03:41 AM
  7. cshekar1987's Avatar
    Here's what i did the device to wake up.
    All three buttons, and when it restarted kept only volume up and down keys not any other key - then it went to two spinning wheels with some progress bar and device is back online :)
    Problem still is - whenever phone reboots, it goes back to flash icon + gear icon :(
    08-09-2018 05:57 AM
  8. anthonyng's Avatar
    That's so weird, sorry I don't have advice, just a bump. My 920 still going strong. Made it think it was a 950xl awhile back and it's running w10m
    08-13-2018 01:58 AM

Similar Threads

  1. Best 3D printers for Windows users on a budget
    By in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 08-07-2018, 07:10 AM
  2. Save on Acer, Sceptre, Planar and AOC computer monitors today only at Amazon Canada
    By in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 08-07-2018, 06:50 AM
  3. Will my data save if I lost a game disk for Xbox one and I rebuy the game
    By Devin Moran in forum Windows Central Archive
    Replies: 0
    Last Post: 08-07-2018, 06:13 AM
  4. How to create Windows 10 system restore points automatically on startup
    By in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 08-07-2018, 06:10 AM
  5. Surface Book 2 and Surface Laptop launch in India, and they're just as costly as you'd expect
    By in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 08-07-2018, 04:30 AM