1. vistascan32's Avatar
    Is anyone else having problems with lte on their phone? My phone is showing 4g with full bars but data will only work when its on cdma only. I've soft/hard reset, updated the prl, reactivated the phone but nothing helped.
    09-06-2013 09:04 PM
  2. wp_ish's Avatar
    No problems here. I have an HTC Evo 4g LTE (it sucks) and my wife has the Samsung Ativ S Neo. In our area, central florida, she gets 4g connection and great speed everywhere. On the other hand, my 4g Android from last year rarely, if ever, picks it up. So, sorry to here yours not working well, but over here the 4g works brilliantly.
    09-06-2013 09:47 PM
  3. MichaelLopez's Avatar
    4G works for me, I live in Orlando and the LTE works fine just not in my neighborhood but everywhere else it works smoothly.
    09-07-2013 01:21 PM
  4. vistascan32's Avatar
    ugh, that means I'll probably have to get my device replaced.

    thanks
    09-07-2013 08:59 PM
  5. q21701's Avatar
    I'm having the identical problem. Are you in the Philly metro area by chance?
    09-19-2013 10:22 PM
  6. vistascan32's Avatar
    Sure am. I went to the sprint forum and told them that I wasn't getting any usable lte speeds. Today I've been getting 6 down and 3 up, sporadically.
    q21701 likes this.
    09-22-2013 09:00 PM
  7. kg4icg's Avatar
    The bars isn't for your 4g strength, it is for your cell phone signal strength to make calls. Do not rely on it for your data signal strength.
    09-23-2013 07:42 AM
  8. Skippy07's Avatar
    The bars isn't for your 4g strength, it is for your cell phone signal strength to make calls. Do not rely on it for your data signal strength.
    Then, is there a way to know your data signal strength?
    09-23-2013 10:25 AM
  9. kg4icg's Avatar
    If it was Android, I tell you to download a app called signal check. Have to check for something similar in the store.
    10-13-2013 08:49 AM
  10. icthusman1's Avatar
    I have recently started having data issues on my Neo. Within the last week I have to turn Airplane Mode on and off a couple of times a day to get my phone to pull 3G and 4G data. WiFi continues to work just fine though.

    Wondering if my radios are going out already. Although, calls always come through just fine.
    10-23-2013 11:37 AM
  11. q21701's Avatar
    Still having issues when entering a 4G service area. Background tasks (like sending and receiving email seem to work fine, but I try to open up direct web content and no dice.
    10-28-2013 01:08 AM
  12. icthusman1's Avatar
    I have recently started having data issues on my Neo. Within the last week I have to turn Airplane Mode on and off a couple of times a day to get my phone to pull 3G and 4G data. WiFi continues to work just fine though.

    Wondering if my radios are going out already. Although, calls always come through just fine.
    Went into the Sprint store in Lynnwood, WA on Sat to ask about this issue. I am not sure whether this was all BS thrown at me by the Rep or not, but what he told me is that Sprint is in the process of upgrading it's towers in the Seattle Metro area to 4G. During this process, towers will go offline and this could interfere with your phone's connection. He claims that iPhone and Android users are reporting the same thing.

    Anyone got any thoughts on this? Could this be why I have been having 4G issues?
    10-28-2013 11:49 AM
  13. BitPusher2600's Avatar
    I'm thinking those of us who signed a contract for this Neo may be at a loss already because Sprint is vested into their new spectrum tech which they dub LTE2 or Sprint Spark, which this device does not support. I don't fully get it but its some kind of tri-band switching and is supposed to support ridiculously high bandwidth. I'm betting the supposed "4g/lte" our present devices are capable of now probably aren't going to see much more of a boost or growth than their present 3g customers have now.

    Spark is worth looking into if you don't mind some aggravation.
    11-01-2013 12:43 PM
  14. vistascan32's Avatar
    I used to have the same problem with my device only working on cdma and LTE being unusable (this was about a month ago). I went to sprint stores and they told me the same thing about the network.... I called sprint gave them my address, then told me I was in a live LTE market but it was unusable, so they gave me a credit on my account.

    What I think really worked for me was going on to the sprint forum and complaining about how it worked in some parts of my city and not others. Two days later I was able to use LTE (cdma and LTE mode) although it wasn't very fast.

    Try the sprint forums they seem to have reps on their who can look into your local network upgrade status.
    11-05-2013 11:43 PM
  15. kg4icg's Avatar
    Or you can just be patient about the network vision upgrades being done. Areas with lte are being tuned as adjacent towers go up plus additional equipment is going up because of Spark.
    11-06-2013 12:03 AM
  16. mgfootballer's Avatar
    0.o but waiting 2 months for these "upgrades" to finish with terrible cellular service and data connection issues? Yes, I'll just wait patiently over here...
    11-07-2013 08:58 AM

Similar Threads

  1. 4 days lumia 1020,microphone problem-issue
    By piniout in forum Nokia Lumia 1020
    Replies: 8
    Last Post: 10-25-2014, 07:49 AM
  2. Share by Bluetooth issue
    By Nick_1020 in forum Nokia Lumia 920
    Replies: 4
    Last Post: 06-18-2014, 11:47 AM
  3. Instagram Hashtag Issue
    By rynthnyltrr in forum Applications
    Replies: 51
    Last Post: 11-13-2013, 01:18 PM
  4. Issues with charging L920 with powerbank
    By angietan in forum Nokia Lumia 920
    Replies: 2
    Last Post: 11-08-2013, 09:38 PM
  5. Dropped Calls - The Neo or the Network?
    By qhendricks in forum Samsung ATIV S Neo
    Replies: 7
    Last Post: 09-06-2013, 07:17 PM
LINK TO POST COPIED TO CLIPBOARD