1. Kmn3's Avatar
    I had been overjoyed to move away from Android, picked up a Neo and couldn't have been happier... for the first week. I am now really regretting my decision, and why I have finally joined this forum.
    I have run into mutliple issues, and I am wondering if other Sprint Neo users have come across the same, and to what degree.

    First, I have been having the SD Card issue - and no, my card is not broke, corrupted, old, etc. It works fine in my laptop and it was flawless in my old phone.

    Notifications - text and email notifications are fairly good, everything else not so much. I have received a total of 3 Facebook notifications since first activating my phone. That was over a month ago. Voicemail and missed call notifications are non-existant.

    Live Tiles - Besides for Weave, email, phone, and text messages, none of them work. Not FB, not any of the Bing apps, not voicemail. Wellm maybe I shouldn't say that. BIng Weather updates once a day at best...

    Error Notifications - get about 3 groups of these a day (2-3 come in all at once). Not sure if these are related to the Network Vision upgrades, or if it is a WP8 error code. More than annoying, as they come in like a text message or call.

    Oddly enough, the one problem I have not encountered was the whole "freezing after taking a picture."

    Sorry that this is so long, but these are very annoying issues to have. Are a lot of the other Neo users encountering these issues? Have you found a way to minimize or correct them?

    Thank you for any feedback!
    11-09-2013 02:16 PM
  2. luk3ja's Avatar
    You have not explained your SD card issue...

    A missed call will show as a number on the phone tile and a voicemail will show as a tape icon on the phone tile and should also give a toast notification but not if your network is rubbish and doesn't use standard voicemail, my network is one of those rubbish ones, my network texts me when I have a voicemail instead.

    Windows Phone doesn't have error message by text or call so it must be your network or something. GDR3 which you will no doubt be getting very soon fixed a tile updating problems but check the background tasks in settings and make sure you haven't disabled any that are tiles.
    Kmn3 likes this.
    11-09-2013 08:01 PM
  3. phstratton's Avatar
    I have the same voicemail issue, because I'm with sprint and they haven't put any time into their app. Instead I use google voice which texts me when I get a voicemail.

    Also the error notifications occur whenever you're in roaming...also a sprint thing.
    Kmn3 likes this.
    11-09-2013 11:21 PM
  4. Kmn3's Avatar
    Thanks too both of you. I usually get the error notifications at home, where I seem to have decent service, but maybe there is interference near their that is causing the issue. Just wish there was a way to turn those off - it gets annoying to get the "fake" notifications.

    As to the SD card issue, I am refering to the issue referenced in this thread - sorry for not specifying that: http://forums.windowscentral.com/sam...eo-sprint.html
    11-11-2013 09:20 AM
  5. mgfootballer's Avatar
    The voicemail is a Sprint issue as stated above.

    The error codes, after talking with a Sprint rep, are for then you are jumping in and out of roam and the roam cellular tower is refusing your connection. This is also a Sprint issue because of their S**tty service
    Kmn3 likes this.
    11-11-2013 02:00 PM
  6. Kmn3's Avatar
    Thanks, mgfootballer. I am not sure why error codes would happen then - I seem to have pretty decent service where I live, but I guess not.
    11-16-2013 09:35 AM
  7. Kmn3's Avatar
    So, after about 3 months of ownership of the Neo, I am starting to find that the battery starts to get warm after use. Yes, I know this is not unheard of, but I don't remember it getting warm ever when I first got the phone. I have been worried about battery longevity since getting it, with the inability to charge with it powered off. Has anyone else noticed this?
    12-21-2013 09:12 AM
  8. Nate Tidwell's Avatar
    I got one day after Thanksgiving. After two weeks it stopped charging, couldn't found when syncing. AT&T sent another, after two weeks had the same issue.
    01-04-2014 04:41 PM
  9. CoreyJ's Avatar
    You are not alone... I've gotten the corrupt SD card issue and also get the network error msgs. I have not run into the other issues that you're running into.
    02-05-2014 05:30 AM

Similar Threads

  1. Bluetooth issues HTC 8x
    By Mac Johnston in forum HTC 8X
    Replies: 8
    Last Post: 01-24-2014, 06:42 AM
  2. Samsung ATIV S Spiderman edition
    By WP8Expert in forum Samsung ATIV S
    Replies: 4
    Last Post: 11-14-2013, 10:45 AM
  3. Camera and screenshot problem on Ativ S
    By MICROV91 in forum Samsung ATIV S
    Replies: 36
    Last Post: 11-13-2013, 08:46 AM
  4. How can you check for issues on the surface 2
    By umang_k91 in forum Microsoft Surface 2
    Replies: 18
    Last Post: 11-12-2013, 09:20 PM
  5. ATIV's GPS receiver inferior to Lumia?
    By Optiplex330 in forum Samsung ATIV S
    Replies: 7
    Last Post: 11-09-2013, 07:01 PM
LINK TO POST COPIED TO CLIPBOARD