The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. jtbarton's Avatar
    Any noteable or fatal bugs associated with bringing the Neo to the dev preview?
    07-11-2014 03:34 PM
  2. pankaj981's Avatar
    The only widespread bug known is with the camera crashing
    07-11-2014 03:43 PM
  3. Oblio3's Avatar
    My house has 3 ATIV S NEO phones.

    My experience was that on the phone where I just did the upgrade (and nothing else) everything works great. On the two phones where I did a reset, after the reset I've experienced:

    1) Data plan issues. I had to search out the APN settings for my device (and the Samsung app for APNs doesn't work on 8.1 yet.
    2) Even after setting the APNs correctly (I think) I can't receive group texts anymore. I can send/receive texts to and from individual users but not to groups (which has made me miss a few important messages).

    Anyway, I've been happy overall - but if you do upgrade, don't reset. From what I can tell it messes up the firmware and/or drivers.

    Sam
    07-16-2014 05:17 PM
  4. bleargh's Avatar
    My house has 3 ATIV S NEO phones.

    My experience was that on the phone where I just did the upgrade (and nothing else) everything works great. On the two phones where I did a reset, after the reset I've experienced:

    1) Data plan issues. I had to search out the APN settings for my device (and the Samsung app for APNs doesn't work on 8.1 yet.
    2) Even after setting the APNs correctly (I think) I can't receive group texts anymore. I can send/receive texts to and from individual users but not to groups (which has made me miss a few important messages).

    Anyway, I've been happy overall - but if you do upgrade, don't reset. From what I can tell it messes up the firmware and/or drivers.

    Sam
    Confirmed. You also can't receive MMS. Send is fine. Reset kills the phones ability to read carrier info properly (there are threads about this that I read AFTER I had to hard reset)

    Hoping for an update from Samsung to re-enable pulling carrier info from the sim correctly. Perhaps even the mini update to DP that's slowly rolling out (but I seriously doubt it)
    07-16-2014 10:24 PM
  5. danielm298's Avatar
    Running 8.1 I miss glance..we don't get it in the SSAS..we do get here drive...nice and LTE..web sight says we don't get LTE, no issues with mms..the camera pics are kinda dark..but that's fixable..other then that..this has become my go to phone, I have a 925 and 1020...
    07-19-2014 08:00 AM
  6. bleargh's Avatar
    Yes, we already know that a straight upgrade to 8.1 DP works as usual. It's when you do a hard reset afterwards that things go wrong. If you know your carriers APN settings and don't care about receiving MMS or group texting, then you'll be fine.
    07-19-2014 09:57 PM
  7. TS25006's Avatar
    Just to chime in here - running 8.1 on Sprint Network. Below are some of my issues:
    - Can't send images via text
    - Group text does not work (especially with iOS users)
    - Have to back out of certain apps and re-enter due to a black screen
    07-31-2014 12:58 PM
  8. caliborn's Avatar
    Just to chime in here - running 8.1 on Sprint Network. Below are some of my issues:
    - Can't send images via text
    - Group text does not work (especially with iOS users)
    - Have to back out of certain apps and re-enter due to a black screen
    Check out this thread. I had the same issues as you.
    http://forums.windowscentral.com/sam...ack-8-0-a.html
    07-31-2014 03:08 PM
  9. TS25006's Avatar
    Went here: <Something_Cool Speeds Blog> and followed the steps to a T. I'm back to WP8. Hallelujah!
    chrisschroeder92 likes this.
    07-31-2014 06:59 PM
  10. KEB64's Avatar
    My house has 3 ATIV S NEO phones.

    My experience was that on the phone where I just did the upgrade (and nothing else) everything works great. On the two phones where I did a reset, after the reset I've experienced:

    1) Data plan issues. I had to search out the APN settings for my device (and the Samsung app for APNs doesn't work on 8.1 yet.
    2) Even after setting the APNs correctly (I think) I can't receive group texts anymore. I can send/receive texts to and from individual users but not to groups (which has made me miss a few important messages).

    Anyway, I've been happy overall - but if you do upgrade, don't reset. From what I can tell it messes up the firmware and/or drivers.

    Sam
    How is the APNs set/checked on these phones?
    08-17-2014 03:22 AM
  11. KEB64's Avatar
    Check out this thread. I had the same issues as you.
    The blog site is down. Can you give instructions on how to roll back to 8.0?
    08-17-2014 03:26 AM
  12. KEB64's Avatar
    Awe, no love? Not sure if I'd even go back at this point. That Xbox music bug on 8.0 was maddening. FYI I had to do a factory reset due to swapping phones and lost data, called sprint and they pushed it back to me. Even fixed my wonky SMS issue I've been having since May. They say its the towers fault. Fixed now! Mms does not work even though the tech worked on it. He said it was blocked on his end, unblocked it but still no joy. BTW after I did a factory, I had apn settings that weren't available to me before. It changed a few things. Mud have been some leftover code from 8.0 stuck. I do miss 8.0 though. It was most unique. I can do without drop down notification/action center ala android thank you very much. Anyhow, looking forward to the real deal here soon. IF sprint and sammy get their acts together. Never know these days.
    08-18-2014 08:04 PM
  13. caliborn's Avatar
    The blog site is down. Can you give instructions on how to roll back to 8.0?
    Sorry. Just getting around to seeing this. I'll see if I can post them later.
    08-19-2014 12:18 PM
  14. KEB64's Avatar
    Cool. Thank you caliborn.
    08-19-2014 08:52 PM
  15. KEB64's Avatar
    Anybody get the ........157.200 update? Just got mine tonight. Is there anyplace we can go to see the change log?
    08-19-2014 11:01 PM
  16. KEB64's Avatar
    Is anybody getting intermittent screeching sounds with Xbox music app? Just started happening to me today. Streaming as well as local music.

    Edit: Appears to be a music store issue. It's only happening on certain songs in the same place. New music I downloaded or stream today. Man i hope its a music store issue and they get it sorted out. Although the music plays fine in my PC. Hmm....

    Edit 2. Okay so here's the deal. The last update gave me extended EQ controls. The high frequency slider is buggy. The whole extension is buggy. That's what was causing the noise.
    Last edited by KEB64; 08-23-2014 at 11:17 PM.
    08-23-2014 12:46 PM

Similar Threads

  1. Replies: 4
    Last Post: 07-30-2014, 03:08 PM
  2. [FREE] Music Upgrade - Mp3 search and lyrics
    By Evolution Apps in forum App Spotlight
    Replies: 3
    Last Post: 07-21-2014, 05:27 PM
  3. Outlook Calendar and Google Calendar
    By spasell in forum Microsoft Surface Pro 3
    Replies: 5
    Last Post: 07-12-2014, 11:16 AM
  4. Toyota Touch and WP8.1
    By ChrisSsk in forum Windows Phone 8.1 Preview for Developers
    Replies: 1
    Last Post: 07-11-2014, 02:28 PM
  5. Lumia Cyan and what it brings to Windows Phone 8.1 and the Lumia 930
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-11-2014, 01:00 PM
LINK TO POST COPIED TO CLIPBOARD