The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Matthew Becker1's Avatar
    I know there have been multiple threads about this, but I've found some settings that actually worked.

    WIND's APN listings on their website apply to Windows Phone 7 devices only, and will not work on WP8 handsets. For those with Samsung ATIV S (and possibly HTC or Nokia devices who have flocked to WIND), I've found these settings from Mobile Carrier Settings for WIND - Canada that worked like a total charm. Where WIND would say to leave certain fields blank, you actually need to input more information.

    Tap "Add/Edit MMS APN"
    Tap APN and type mms.windmobile.ca
    Tap WAP gateway (URL) and type in 74.115.197.70
    Tap WAP gateway port and type in 8080
    Tap MMSC (URL) and type in http://mms.windmobile.ca
    Make sure IP Type is at: IPv4v6
    Tap Save

    I just sent a test MMS and worked perfectly. For other WIND users, please confirm if this fixed your problem.

    EDIT: Some other things to troubleshoot if these instructions don't work:
    - After putting in these settings, if your MMS comes back with an error, reboot your device either by powering down, or removing the battery. I had to do this when my temporary number was scrapped in favour of the number I had ported over.
    - If your network is on "automatic" you may have to choose the network manually. That allowed me to send any MMS without problem.
    - For the SGH-T899M, by default it will have the fastest connection speed set to LTE (could also read as "4G"). You may have to change that to HSPA/WCDMA (or "3G").
    - WIND's maximum MMS size is only 300 KB (yikes). So if you try to send certain files, but your device tells you that it can't attach it, then that's a carrier restriction. There's nothing "wrong" with your phone, or your MMS settings.

    I'll add other suggestions as they come up.
    Last edited by Matthew Becker1; 08-25-2014 at 09:56 PM.
    csymons, dredd2099 and aleunge like this.
    12-20-2013 04:45 PM
  2. dredd2099's Avatar
    works

    those were the settings I had already on stock 'edit mms apn', didnt work
    re-did with the samsung apn from the windows store and voila
    lol, if you never prompted me to re-check I would have just left it as is
    ty for the push sir
    Matthew Becker1 likes this.
    12-22-2013 12:58 AM
  3. Matthew Becker1's Avatar
    So, just to confirm, you already had these settings in place before trying the Samsung APN app? Did you have the app installed prior to putting these settings in?

    I'm just curious; there might have been some interference with the two.
    12-24-2013 07:17 PM
  4. csymons's Avatar
    I used this thread to fix MMS settings on a factory unlocked Nokia 1020 Windows 8 phone. After a reboot of the device it worked perfectly.
    Wind only has Windows 7 listed on their site and that was what the Wind rep used to set up my phone - those settings did not allow internet access nor MMS service. I couldn't get the right settings from any other posting that Google came up with. Thanks for posting.
    Matthew Becker1 likes this.
    03-07-2015 10:47 AM
  5. chobo2's Avatar
    Does this still work? Mine does not work most of the time. Though maybe it is because I put 1024 for max size as I thought they increased that?
    04-01-2015 11:11 AM
  6. Matthew Becker1's Avatar
    Does this still work? Mine does not work most of the time. Though maybe it is because I put 1024 for max size as I thought they increased that?
    I left the max size blank. Other than that, these settings still work.
    04-03-2015 11:06 PM
  7. chobo2's Avatar
    I left the max size blank. Other than that, these settings still work.
    Ok, I will try that and see what happens.

    Also can you internet share? If so what phone?
    04-10-2015 05:30 PM
  8. Matthew Becker1's Avatar
    Wind allows internet sharing. I've done it a few times with my ATIV S.
    04-12-2015 01:35 PM
  9. sloly10's Avatar
    I would like to thank Matthew very much for posting this info.
    I got a Windows Phone (unlocked) and transferred to Wind but was unable to use MMS function even though I was paying for it. For 3 months I was under the impression my Windows Phone was 'broken'.
    I communicated with Wind Mobile tech support, went to their stores, tried everything. Wasted too much valuable time. What a bunch of ignorant amateurs working at Wind Mobile. They don't give you all the info to put into your phone then try to make it seem like it's your phone that is the issue.

    Thankfully there are people like Matthew who recognized the problem (and posted the solution here for all to see). This was something paid Wind employees couldn't figure out and that's their job. What a joke. Thanks Matthew....
    problim likes this.
    01-24-2016 01:16 AM
  10. problim's Avatar
    In addition to Matthew's post.
    For Windows Mobile 10, the field's seem to be labelled a bit different but these worked for me.
    Proxy server 74.115.197, Proxy Port 8080, I Ieft the MMSC port blank.
    I also set the Maximum MMS size (KB) to 1000. Seems to work for 1MB.
    04-05-2016 10:27 AM

Similar Threads

  1. Canon CameraWindow app for Windows Phone 8?
    By western_riders_dad in forum Applications
    Replies: 2
    Last Post: 12-25-2013, 07:49 AM
  2. Replies: 7
    Last Post: 12-21-2013, 07:51 AM
  3. Nokia updates Play To Beta for Lumia 1020, Lumia 925 with Black release
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-20-2013, 04:10 PM
  4. Social network Badoo has its app updated for Windows Phone 8
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-20-2013, 03:20 PM
  5. Instagram pushes out a rapid fix for their Windows Phone beta app
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-20-2013, 03:20 PM
LINK TO POST COPIED TO CLIPBOARD