The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. dotdude1's Avatar
    I've had the Epix for a while now. I've noticed that there is a bit of dust under the screen. Does anyone have any ideas on how to get it out?
    Thanks!
    02-27-2009 10:28 AM
  2. WRaholicX's Avatar
    Anyone have any ideas, I'm having the same problem.

    I found the service manual for the i780, and it seems as if the front place including screen will come off if you remove the six screws that hold the thing together.

    http://www.mediafire.com/?sharekey=0...4e75f6e8ebb871

    page 100 shows the faceplate removed
    Last edited by WRaholicX; 10-13-2009 at 01:54 PM. Reason: more info
    dotdude1 likes this.
    10-13-2009 01:49 PM
  3. jwebb56's Avatar
    Honestly, this post is the first I've heard of it for the Epix. I don't have the problem and have no idea how to solve once it gets in. The issue was rampant for the Treo Pro and it seemed to be a fit issue with the screen. I don't think anyone ever really solved other than through the return process.
    10-15-2009 06:21 PM
  4. dotdude1's Avatar
    WRaholicX-

    Thanks for the information. I did pull my Epix apart and was able to clean the back of the digitizer and the front of the LCD screen. The only problem I ran into was the ribbon cable on the left side of the front bezel. I pulled it out, and didn't realize there was a ribbon latch on the back of the main circuit board. Once I reattached the ribbon cable, it worked like a charm.

    Thanks again!
    11-02-2009 12:10 PM
LINK TO POST COPIED TO CLIPBOARD