1. btbam91's Avatar
    I shut off the phone, removed the battery to view the IMEI number. Put everything back and it doesn't turn on. The battery is fine because I put it into another Focus S and it works fine.

    I'm sad. I'm getting it exchanged tomorrow.
    11-19-2011 02:52 PM
  2. palandri's Avatar
    Press the power button until you feel the phone vibrate.
    11-19-2011 02:56 PM
  3. trakman's Avatar
    Plug it in to a charger it should automatically power it up.
    11-19-2011 03:32 PM
  4. btbam91's Avatar
    None of the above works.
    11-19-2011 03:32 PM
  5. btbam91's Avatar
    I'm going to return it tomorrow,compare it to the Titan.... and make up my mind between the two.
    11-19-2011 04:13 PM
  6. Dave Blake's Avatar
    Bummer :excl:
    11-19-2011 05:54 PM
  7. btbam91's Avatar
    Got my new phone, it's working great!
    11-20-2011 02:10 PM
  8. jfa1's Avatar
    Excellent hope it stays that way!
    11-20-2011 08:09 PM
  9. 5tephen's Avatar
    Did you get a Titan?

    Sent from my TITAN using Board Express
    11-20-2011 08:17 PM
  10. btbam91's Avatar
    I decided to Sta with the S. The Titan definitely wasn't as big as I thought it would be, but the one thing that truly turned me off was how far apart the front 3 buttons were. My brother will be getting the Titan next week.

    Sent from my Windows Phone using Board Express
    11-20-2011 09:52 PM
  11. 5tephen's Avatar
    I decided to Sta with the S. The Titan definitely wasn't as big as I thought it would be, but the one thing that truly turned me off was how far apart the front 3 buttons were. My brother will be getting the Titan next week.

    Sent from my Windows Phone using Board Express
    Completely understandable. I have big thumbs though, and they're what I usually use to press the buttons and on my HD7 I occasionally find myself hitting back instead of home or home instead of search. Slightly agitating but easily able to overlook. Love the Titan though.
    11-20-2011 10:28 PM
LINK TO POST COPIED TO CLIPBOARD