The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
04-02-2013 09:54 PM
62 123
tools
  1. MrBurrrns's Avatar
    I was searching for a way to debrand my AT&T Samsung Focus S to receive the latest update and was at first surprised to find out that none of the registry editors work and secondly, that I could not find a simple way how to unbrand it.

    So here is a simple way for anybody who was looking for the same thing.

    Please note that this will unlock and debrand your phone (and I’ve also thrown in the 3G toggle tweak) but after you update to 7.10.8107.79 through Zune, you will no longer be able to use the ProvXML method of deploying registry settings (that we are using here).

    All credit goes to Deathbyvegemite who told me what to do and Jaxbot and his WindowBreak Project which helped me figure out how to do it. :) This is really just a simple modification of his work, so I have to thank him and all the other people that have worked on this.

    Okay, so to do this, please follow these steps:

    1) Open your mobile browser and go to: http://www.kremese.sk/debrand_focus_s.zip
    2) The file will be opened. Follow the instructions and tap on “debrandfocuss.xml”
    3) Press Start
    4) Navigate to Phone
    5) Dial ##634#
    6) Type *#9908#
    7) Select DebrandFocusS
    8) Press Save and Reboot

    After that, connect to Zune and you will receive the 8107 update.
    02-02-2012 05:34 PM
  2. syang87's Avatar
    Thanks. How would I go about doing this on a Focus Flash?
    02-02-2012 06:49 PM
  3. MrBurrrns's Avatar
    Should also work on the Flash (and all other Samsung phones).
    02-02-2012 07:21 PM
  4. syang87's Avatar
    Ok. Will give it a shot. Thanks.
    02-03-2012 09:09 AM
  5. Mr_pither's Avatar
    ...and then how do we re-brand it after the procedure???
    02-03-2012 10:58 AM
  6. MrBurrrns's Avatar
    ...and then how do we re-brand it after the procedure???
    The point of this is to debrand it. If you want a branded phone, then don't do it and wait till At&T pushes the update to you (or search XDA for other ways how to update).

    There will be other updates coming in the future - this is supposed to make sure that you receive them all and don't have to wait for AT&T.
    02-03-2012 11:25 AM
  7. syang87's Avatar
    It didn't work for me. :-(
    02-03-2012 04:36 PM
  8. cfuess2's Avatar
    Do you know if that installs the KK2 samsung update or is that just the omnia 7? Does internet connection sharing still work?
    02-04-2012 08:18 AM
  9. MrBurrrns's Avatar
    Do you know if that installs the KK2 samsung update or is that just the omnia 7? Does internet connection sharing still work?
    Not sure about the firmware update, but my firmware version after the update is: 2103.11.10.1.

    Internet sharing was already there before the update and is still there.
    02-04-2012 03:25 PM
  10. Mr_pither's Avatar
    Not sure about the firmware update, but my firmware version after the update is: 2103.11.10.1.

    Internet sharing was already there before the update and is still there.
    same firmware I have on my un-updated Focus S.
    02-04-2012 03:29 PM
  11. MrBurrrns's Avatar
    It didn't work for me. :-(
    You could try to pull out your sim card and try then.

    But I think it will most likely be related to an old version of the Diagnosis tool. Can you please check which version you have?
    02-04-2012 04:02 PM
  12. Mr_pither's Avatar
    The point of this is to debrand it. If you want a branded phone, then don't do it and wait till At&T pushes the update to you (or search XDA for other ways how to update).

    There will be other updates coming in the future - this is supposed to make sure that you receive them all and don't have to wait for AT&T.
    I get that, make it like a Nexus phone sorta.

    my concern is do you then miss out on any carrier specific soft/firmware updates? do you have any issues if they were to finally turn on vis voice mail :lol: or the like?

    thanks for your efforts,

    h
    Last edited by Mr_pither; 02-05-2012 at 12:36 PM.
    02-04-2012 05:45 PM
  13. syang87's Avatar
    You could try to pull out your sim card and try then.

    But I think it will most likely be related to an old version of the Diagnosis tool. Can you please check which version you have?
    My diagnosis tool is version 1004. Is that the old one? How do I update to get the new one?
    02-05-2012 01:22 AM
  14. cfuess2's Avatar
    I also have the same diagnosis tool 1004 on my Focus Flash. Side loading apps still works. I read that there is a registry setting that can be changed to fix the "no cellular data connection" error, but WP7 Root Tools doesn't work with 2nd gen devices, yet, so there is no way to modify the registry on the phone the way they did in this post xda-developers - View Single Post - [CAB] Official WP7 Updates List: 7.10.8107 + ALL LANGUAGES complete + OEM updates. I also tried using the cab sender method first, but that did the same thing, it disables internet connection sharing.
    02-06-2012 12:26 PM
  15. Deathbyvegemite's Avatar
    Hey All, Several comments, so bare with me.

    Firstly, MrBurrrns, cheers for the kudos, and nice job on the zip. Might I suggest that you add the following to it, it will help resolve peoples data connection issues.

    <characteristic type="Registry">
    <characteristic type="HKLM\System\AutoDataConfig">
    <parm name="RunADC" value="1" datatype="integer" />

    </characteristic>

    <characteristic type="HKLM\System\AutoDataConfig">

    <parm name="ConfigurationStatus" value="0" datatype="integer" />

    </characteristic>
    <characteristic type="HKLM\System\AutoDataConfig">

    <parm name="Attempt" value="0" datatype="integer" />

    </characteristic>

    <characteristic type="HKLM\System\AutoDataConfig">

    <parm name="MaxAttemptsAllowed" value="3" datatype="integer" />

    </characteristic>

    </characteristic>


    RE: KK2 vs 8107. They are very different. KK2 is only applicable to the Samsung devices, and it will stop your ability to use the ProvXML method of registry editing. The 8107 update should be for all hardware. You must be very careful when you get an update notice as to what it is you are installing. They are seperate, and you can elect to not install the firmware update and still in stall the 8107 update and presumably future updates.

    There was a question re re-branding - edit the XML file and change the Mobile Operator from 000-88 back to ATT-US and run through everything from step 6 again.

    I'm too tired to give any more updates tonight, hit me up if you have any questions!

    Cheers
    Deathbyvegemite
    02-06-2012 11:17 PM
  16. Deathbyvegemite's Avatar
    Oh, yes, you need to update your diagnostics app to use this method. Uninstall it, reboot and reinstall it.
    02-06-2012 11:19 PM
  17. syang87's Avatar
    Oh, yes, you need to update your diagnostics app to use this method. Uninstall it, reboot and reinstall it.
    Did that and it's still on ver.1004
    02-07-2012 12:30 AM
  18. cfuess2's Avatar
    Did that and it's still on ver.1004
    Diagnostics v. 1004 might be the latest; it worked for me. Does step 6 work for you or does nothing happen? If you see the screen where you can pick the file Diagnostics is probably working and there is another problem.
    02-07-2012 02:29 PM
  19. cfuess2's Avatar
    Hey All, Several comments, so bare with me.

    Firstly, MrBurrrns, cheers for the kudos, and nice job on the zip. Might I suggest that you add the following to it, it will help resolve peoples data connection issues.

    <characteristic type="Registry">
    <characteristic type="HKLM\System\AutoDataConfig">
    <parm name="RunADC" value="1" datatype="integer" />

    </characteristic>

    <characteristic type="HKLM\System\AutoDataConfig">

    <parm name="ConfigurationStatus" value="0" datatype="integer" />

    </characteristic>
    <characteristic type="HKLM\System\AutoDataConfig">

    <parm name="Attempt" value="0" datatype="integer" />

    </characteristic>

    <characteristic type="HKLM\System\AutoDataConfig">

    <parm name="MaxAttemptsAllowed" value="3" datatype="integer" />

    </characteristic>

    </characteristic>


    RE: KK2 vs 8107. They are very different. KK2 is only applicable to the Samsung devices, and it will stop your ability to use the ProvXML method of registry editing. The 8107 update should be for all hardware. You must be very careful when you get an update notice as to what it is you are installing. They are seperate, and you can elect to not install the firmware update and still in stall the 8107 update and presumably future updates.

    There was a question re re-branding - edit the XML file and change the Mobile Operator from 000-88 back to ATT-US and run through everything from step 6 again.

    I'm too tired to give any more updates tonight, hit me up if you have any questions!

    Cheers
    Deathbyvegemite
    It looks to me like the data connections keys are in MrBurrrns xml file. see lines below, the format is a little different.

    <!-- Enable auto data config -->
    <characteristic type="HKLM\System\AutoDataConfig">
    <parm name="RunADC" value="1" datatype="integer" />
    <parm name="ConfigurationStatus" value="0" datatype="integer" />
    <parm name="Attempt" value="0" datatype="integer" />
    <parm name="MaxAttemptsAllowed" value="3" datatype="integer" />
    </characteristic>

    My data works alright, but my ability to share my internet connection has gone away.
    02-07-2012 02:54 PM
  20. syang87's Avatar
    Diagnostics v. 1004 might be the latest; it worked for me. Does step 6 work for you or does nothing happen? If you see the screen where you can pick the file Diagnostics is probably working and there is another problem.
    I can get through the whole thing (losing data connection). But when i connect to Zune it doesn't show that i need an update.
    02-07-2012 03:41 PM
  21. Deathbyvegemite's Avatar
    It looks to me like the data connections keys are in MrBurrrns xml file. see lines below, the format is a little different.

    <!-- Enable auto data config -->
    <characteristic type="HKLM\System\AutoDataConfig">
    <parm name="RunADC" value="1" datatype="integer" />
    <parm name="ConfigurationStatus" value="0" datatype="integer" />
    <parm name="Attempt" value="0" datatype="integer" />
    <parm name="MaxAttemptsAllowed" value="3" datatype="integer" />
    </characteristic>

    My data works alright, but my ability to share my internet connection has gone away.
    I guess I was more tired when I did that post than I realized, I could have sworn I didn't see it. Sorry Burrrns :)



    Sent from my SGH-i937 using Board Express
    02-07-2012 04:28 PM
  22. cfuess2's Avatar
    It looks to me like the data connections keys are in MrBurrrns xml file. see lines below, the format is a little different.

    <!-- Enable auto data config -->
    <characteristic type="HKLM\System\AutoDataConfig">
    <parm name="RunADC" value="1" datatype="integer" />
    <parm name="ConfigurationStatus" value="0" datatype="integer" />
    <parm name="Attempt" value="0" datatype="integer" />
    <parm name="MaxAttemptsAllowed" value="3" datatype="integer" />
    </characteristic>

    My data works alright, but my ability to share my internet connection has gone away.
    On some forums it says that a registry tweak like the following would work to restore internet connection sharing.

    <wap-provisioningdoc>
    <!-- ProvXML to fix Internet connection sharing -->
    <characteristic type="Registry">
    <characteristic type="HKLM\Services\ICS">
    <parm name="UserProcGroup" value="5" datatype="integer" />
    </characteristic>
    </characteristic>
    </wap-provisioningdoc>

    I just tried to make a tweek to the registry similar to what MrBurrrns, but it has not had any effect. The key may not exist or there might be another issue. I can't see the registry to know for sure.
    02-07-2012 04:42 PM
  23. cfuess2's Avatar
    I can get through the whole thing (losing data connection). But when i connect to Zune it doesn't show that i need an update.
    You're saying it is appearing in Zune, but it is not showing it needs an update? You can try clicking on settings (top right) and then click update in the left navigation.
    Last edited by cfuess2; 02-07-2012 at 10:10 PM.
    02-07-2012 09:33 PM
  24. syang87's Avatar
    You're saying it is appearing in Zune, but it is not showing it needs an update? You can try clicking on settings (top right) and then click update in the left navigation.
    I've done that too. Still nothing. :-/
    02-07-2012 11:58 PM
  25. cfuess2's Avatar
    I've done that too. Still nothing. :-/
    You can try the manual method from here, Windows Phone 7 build 7.10.8107.79 roll out started get it now and update manually | MobileTechWorld. It works pretty fast. Just take the two OS files, 7720 -> 7740 and 7740 -> 8107 and the two language files and put them all in the folder with the cab sender .bat file and run it. It will merge the updates and do it all in one shot. Just make sure you backup first in case you want to revert back. It worked perfectly on my Focus Flash except internet connection sharing, but the Zune update method whacked it too.
    Last edited by cfuess2; 02-08-2012 at 03:09 PM.
    02-08-2012 09:19 AM
62 123

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD