The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. TunisEleven's Avatar
    I try to play music, play a video, play a game, even an incoming call, no sound comes out of my phones speaker. The headphone jack still works, as all sound comes through headphones, but I have no speaker. This sucks. Anyone have any ideas?
    04-19-2011 08:55 PM
  2. cdook's Avatar
    What phone and have you tried restarting it?

    Edit: Saw this was the Focus forum. Did you have headphones plugged in? Prenodo the sound was always messed up after coming from headphones. A reboot would help.
    04-19-2011 09:07 PM
  3. TunisEleven's Avatar
    Ive rebooted, pulled the battery, re synced it. Everything. It is acting super strange. I figured I would try the changing the sound diagnostic setting (seeing the tutorial here and having done it before NoDo with no problems) to try and see if that would change anything. Heres where it gets weird. The speaker on the outside, will play the sound coming from the mic up front, the voice piece. I say something, it says it back a split second later. I try playing sound, I play music, nothing. I put in headphones, and the music plays no problem through the headphones, unplug and I got nothing. I know how the mic can get messed up with removing headphones, but its the speaker that isnt working. I just don't understand what the **** happened.
    04-19-2011 09:15 PM
  4. cdook's Avatar
    Hmm yea that's really weird. I'm not sure what would make it do that. I'd either try to exchange it or contact @WinPhoneSupport on Twitter to see if they have any ideas.
    04-20-2011 10:22 AM
  5. ameel's Avatar
    I try to play music, play a video, play a game, even an incoming call, no sound comes out of my phones speaker. The headphone jack still works, as all sound comes through headphones, but I have no speaker. This sucks. Anyone have any ideas?
    I got the same problem!!! But mine is an HTC Mozart.

    I reflashed to stock rom that is pre pre-nodo update (7004), and still doesn't work!!
    Worse now, the microphone on the earphone will not work! so if i try to call and talk using earphone, I can only hear, i can't speak. without earphone, I can only speak, not hear. My only option when making calls is to talk on loudspeaker (haven't tried bluetooth headsets yet).

    On a different note, I did some "other stuff" to my phone. I had previously (few months ago) dropped my phone and broken the digitizer. I've been using it until recently when I decided to just replace the digitizer and stopped using it. I hadn't touched my phone (after nodo update) for a few days until I got the replacement digitizer. I opened the phone and replaced the digitizer myself, and the audio problems started!! I thought i might have somehow wrecked the hardware, and opened again and looked around, but everything seems fine.

    But now that you have reported this, I'm hoping it's the same issue as yours and that it can be fixed?

    Please post if you find a solution!

    cheers
    Last edited by ameel; 04-25-2011 at 01:39 PM.
    04-25-2011 01:05 PM
  6. ameel's Avatar
    Ok. Mine was definitely a hardware issue.
    I basically forgot to take out the speaker component from the old frame and put it onto the new frame that I got. Turns out they don't ship the sound component with the digitizer and frame that I bought, duh!

    Once I did that, my internal speaker working just fine!!! If you replaced your screen recently, just make sure that you actually take off the internal speaker component from the previous phone and put it on the new one :P
    04-25-2011 11:05 PM
LINK TO POST COPIED TO CLIPBOARD