1. bradleyj's Avatar
    Hi there, I am running a brand new Rogers Samsung Focus upgraded to Mango, although I did developer-unlock it and activate the internet sharing/tethering.

    I have noticed a little glitch, and I want to know if others have this or if the unlock/tethering might have caused the problem.

    The problem is that the Data on my focus occaisionally 'stalls' or stops working if I am on both WIFI and 3G/3G+ at the same time. It is intermitent, and I can't pin down when (or why) it happens. But if i turn of either Cellular Data or Wifi then the data will work fine again.

    It seems like the phone has trouble switching between them or that they are competing or something...any of you experienced this? Any braniac developers/hackers with any suggestions to fix this?
    11-05-2011 10:17 PM
  2. jimski's Avatar
    Curious. How do you know you 3G stops working with your WiFi on? My WiFi is on 24/7 and have never noticed any issues, but that does not mean you don't have a problem. So, are you not getting background updates with WiFi on. When your screen is turned on and WiFi is turned on, it will take precedence over 3G, but 3G should be working when your screen is off.

    Sent from my HTC Surround using Board Express
    11-05-2011 10:57 PM
  3. bradleyj's Avatar
    Here's how I know that the phone is using 3g instead (or as well): I browse around the app catalog frequently clicking the top to see the network info. When using just WiFi it should stay on 3g but when it is using cell data it will switch to 3G+ (try this yourself with or without WiFi).

    However it doesn't normally do this for long...it seems to stall and then data stops. If I turn off either WiFi or cellular data then the other will work.
    11-06-2011 09:13 AM
LINK TO POST COPIED TO CLIPBOARD