11-17-2013 06:19 PM
68 123
tools
  1. MekkelRichards's Avatar
    Glad I was able to be of some help. woodbane is right about this and other little annoyances regarding WP7. These problems were non-existent in the older Windows Mobile platform and webOS was infinitely easier to play with and simply a more polished UI. Lack of apps did the platform in along with subpar hardware as well as horrible mismanagement at HP and Palm.
    A few months ago I was still with webOS on a Pre3. Sexy UI, but it was horribly buggy and slow at times. I really love it though and hope that something good will come out of it being open sourced.

    This WP7 issue most likely exists because they forgot to bake the ability to edit MMS apn settings into the settings.
    04-21-2012 03:27 PM
  2. woodbane's Avatar
    Because I'm a tinkerer and frankly this issue bugs the **** out of me, I'm considering reflashing stock ROM rolling up to Mango and then trying this before doing anything else. I'm sad like that. :S

    Sent from my SGH-i917 using Board Express
    04-21-2012 03:31 PM
  3. fatclue_98's Avatar
    A few months ago I was still with webOS on a Pre3. Sexy UI, but it was horribly buggy and slow at times. I really love it though and hope that something good will come out of it being open sourced.

    This WP7 issue most likely exists because they forgot to bake the ability to edit MMS apn settings into the settings.
    Funny you mention that, I had both a Pre2 and Pre3. The Pre2 actually ran better despite a slower cpu. In fact, my wife refuses to give up her Pre2 even though I have a Venue Pro laying in a drawer waiting to be purchased on eBay.
    MekkelRichards likes this.
    04-21-2012 03:32 PM
  4. fatclue_98's Avatar
    Because I'm a tinkerer and frankly this issue bugs the **** out of me, I'm considering reflashing stock ROM rolling up to Mango and then trying this before doing anything else. I'm sad like that. :S

    Sent from my SGH-i917 using Board Express
    Try creating the provxml folder as MekkelRichards did a few posts above. Might work.
    04-21-2012 03:34 PM
  5. woodbane's Avatar
    Honestly that really wasn't the issue, I got the folder created by deploying Heathcliffs file. I then followed the rest of the instructions but it still wouldn't work. I did find another thread on xda with a different set of instructions to get the MMS working. I may try that after a reflash.

    Sent from my SGH-i917 using Board Express
    04-21-2012 03:36 PM
  6. Shark87's Avatar
    Ok so something a little strange happened after I got data working. I tried DL an app over 3G, but it gave me a "Windows Live service unavailable". When I try over wifi, it works. I've read a few things about the error, but it just seems strange. I saw someone suggest that it might be that the connection is slow, but from my test on mobilespeedtest.com I'm getting somewhere between 2-4mbps dl speed.
    04-21-2012 11:59 PM
  7. evenmetal99's Avatar
    THANK YOU THANK YOU THANK YOU SOOOOOOOOO MUCH FOR THIS! After about a month of trying TONS of different procedures, YOURS came through. This procedure worked perfectly on my unlocked Samsung focus using straight talk. I can now send and receive MMS perfectly! I did have a tiny bit of trouble trying to get the .xml file to show up in my phone but I finally got it to work. So thank you so so much for this man. Appreciative.:lol:
    04-22-2012 08:03 PM
  8. evenmetal99's Avatar
    I mean to say Thanks to fatclue_98!
    fatclue_98 likes this.
    04-22-2012 08:05 PM
  9. woodbane's Avatar
    Hey fatclue! Just wanted to let you know that I figured out that it IS the custom ROM that's stopping this provxml file from taking properly.

    Long story short, a work colleague bought a Focus and is using it with H2O. She was also having the issue that she could not send MMS.

    I persuaded her to let me windowbreak and deploy the Straight Talk provxml file and then try sending a MMS with my SIM inserted. It worked without a hitch!

    Interestingly, as H2O also uses the ATT network it meant the settings also worked when she put her SIM back in!

    IT WAS A DOUBLE WIN!

    So guess who's going to be flashing his phone back to stock and going the windowbreak route? LOL.

    Anyhow, I'm going to let voluptuary, the maker of the custom ROM know as there has to be something that's stopping this.

    But to you sir, I say thanks a million!


    Sent from my iPad using Tapatalk
    05-12-2012 04:32 PM
  10. fatclue_98's Avatar
    Hey fatclue! Just wanted to let you know that I figured out that it IS the custom ROM that's stopping this provxml file from taking properly.

    Long story short, a work colleague bought a Focus and is using it with H2O. She was also having the issue that she could not send MMS.

    I persuaded her to let me windowbreak and deploy the Straight Talk provxml file and then try sending a MMS with my SIM inserted. It worked without a hitch!

    Interestingly, as H2O also uses the ATT network it meant the settings also worked when she put her SIM back in!

    IT WAS A DOUBLE WIN!

    So guess who's going to be flashing his phone back to stock and going the windowbreak route? LOL.

    Anyhow, I'm going to let voluptuary, the maker of the custom ROM know as there has to be something that's stopping this.

    But to you sir, I say thanks a million!


    Sent from my iPad using Tapatalk
    I know you were a bit frustrated there for a while, but I'm glad you found a way to get it done. :D
    05-13-2012 10:48 AM
  11. davidlshook's Avatar
    I just wish I could get it to work on mine now...... did every step and still no mms. I was able to get data............ this is bs that microsoft did this
    06-29-2012 09:05 PM
  12. fatclue_98's Avatar
    I just wish I could get it to work on mine now...... did every step and still no mms. I was able to get data............ this is bs that microsoft did this
    Yeah, it's BS but it's more the carriers than anything else. I just wish that WP7 had the ability to edit registries the way we could on WinMo. Matter of fact, I have my Epix on the computer right now 'cause I'm adding the Straight Talk MMS settings. 2 minute job on WinMo, that's pathetic.
    06-30-2012 05:38 PM
  13. syconu's Avatar
    when i get the file emailed to myself all it says is that i can open it and theres no donload and save option........ help plz
    08-03-2012 04:14 PM
  14. woodbane's Avatar
    You don't get an option to download and save it. Once you tap it and it opens, there's a copy saved in the 'Volatile' folder that fatclue mentioned. Copy and paste it from there to the provxml folder and apply it via the GPRS setting menu in the Diagnosis App.

    Sent from my SGH-i937 using Board Express Pro
    08-07-2012 06:21 PM
  15. syconu's Avatar
    i cant get the diagnosis app to work so can u plz help with that and i would be greatful i can get it from there but i just need to that point where i can get ##643# to work
    08-08-2012 08:56 PM
  16. keishay09's Avatar
    I have a flash focus sgh-i677 on straight talk and can't find where the mms setting is...i was a art user before I switch..so can anyone help me through it??
    08-12-2012 05:17 PM
  17. Corepc's Avatar
    I have a flash focus sgh-i677 on straight talk and can't find where the mms setting is...i was a art user before I switch..so can anyone help me through it??
    in case you have not found it yet..

    Settings cellular

    Add apn or edit apn

    apn name:att.mvno
    proxy server: proxy.mvno.tracfone.com
    proxy port: 80
    Save and Reboot Phone

    Then download Samsung wireless manager and follow the net10/straighttalk link at bottom of my sig
    08-13-2012 08:47 PM
  18. Cody Cunningham's Avatar
    i have tried that and my gprs will not say success so i dont know if im doing it wrong or if im missing something
    11-20-2012 06:21 PM
  19. kpatt2006's Avatar
    Ok, i've spent 3 straight hours trying to get my newly, straight talk activated samsung focus to send/receive MMS. I've done everything right up until emailing the straight talk xml file to my phone. What does that mean? My phone is setup with a gmail account so i emailed the file as an attachment to that email address. I could open it and look at it, but it would not let me save the document to phone, copy, cut, paste ANYTHING to it. I tried changing registry files to make my phone show up as usb storage and move the xml file over. That didn't work because I can't find it anywhere in the file explorer. I copied and pasted it into Wordpad to see if my phone would get the document but it wouldn't move the .txt file into where you said put the xml file. I searched for apps to let my phone view/copy/paste xml documents and had no luck. I really don't know what else to do. This is silly. Please help me out if you can.
    12-13-2012 02:16 AM
  20. kpatt2006's Avatar
    UPDATE: This is where I finally gave up. I have straighttalk.xml in the provxml folder. If i tap it to open, it just brings up a black screen. Anyways, it's there. So I went to the *#9908#, selected straighttalk from the drop down box then it starts "Loading GPRS Profile for straighttalk" and that's it. Nothing happens, but the screen keeps turning off eventually. I waited about 5 minutes with keeping the screen on while it says Loading..... then clicked closed, turned the phone off and back on. Still no MMS sending or receiving. How I wished I had paid a little more for a Focus S or Flash or ANYTHING really. I had no idea it would be this much trouble =(
    12-13-2012 02:50 AM
  21. 86ipods's Avatar
    Are you running a custom ROM or just the stock? If your bootloader is already unlocked and you are ready to flash a custom ROM I can show you a post on XDA that got Nokia's Network Setup app working on my Focus to adjust ALL apn settings
    12-14-2012 02:00 PM
  22. Janine81's Avatar
    I just got a samsung focus on straight talk , the voice and SMS work fine to get data working I typed in att.mvno that works fine , bing works fine my problem is when I open the market place nothing works except music when I click samsung zone it says no results same for att apps and when I hit apps it opens and it's just black with nothing except " applications " at the top and when I hit games it says no results , I really could care less about games and I don't care about mms I just want to download apps, is this a straight talk problem or the phone , I brought it brand new, please help if you can. Thanks!
    12-15-2012 09:36 PM
  23. 86ipods's Avatar
    I just got a samsung focus on straight talk , the voice and SMS work fine to get data working I typed in att.mvno that works fine , bing works fine my problem is when I open the market place nothing works except music when I click samsung zone it says no results same for att apps and when I hit apps it opens and it's just black with nothing except " applications " at the top and when I hit games it says no results , I really could care less about games and I don't care about mms I just want to download apps, is this a straight talk problem or the phone , I brought it brand new, please help if you can. Thanks!
    I've only had a similar problem one time and what fixed it for me was changing the region and language settings under your settings menu. Make sure it's correct for your location and make sure and do a reset after any changes. Not sure but this might fix your issue
    12-16-2012 10:04 PM
  24. havefunkc's Avatar
    Still works (when using the latest Root Tools). Thanx!

    Kc.
    01-28-2013 02:00 AM
  25. fatclue_98's Avatar
    Just for s**ts and giggles, I tried my own formula on a Focus S and it works too. BTW, I'm still on 7720 because I don't know if the newer builds knock out the interop unlock.
    02-02-2013 04:11 PM
68 123
LINK TO POST COPIED TO CLIPBOARD