1. cheesydevil's Avatar
    Hi good people of the WPcentral forum

    I have encountered a most severe and annoying problem, My Phone thinks it is charging even when it is not plugged in. somtimes it even alternates like crazy causing the sound fx for charge to reapeat over and over again. this is an issue I can not live with because it causes my phone to go flat very quick as my screen will only stay off on the odd chance the phone remains on the charge icon and whats more I can't turn on battery saver because the phone thinks it's charging.

    I have removed the battery dozens of times and have trawled the internet and the closest thing I find is people having problems with dodgy battery icon behaviour on this handset (omnia 7). I am on mango and my phone has decided it can not charge from the wall plug anymore. sorry for the wordiness I just thought I'd get it all out in one post.
    10-18-2011 07:18 AM
  2. palandri's Avatar
    I would try a factory reset. If that doesn't work, you need to get your phone replaced.
    10-18-2011 07:23 AM
  3. TheWeeBear's Avatar

    Yes, that's not good, sound like something's not right with your USB socket cheesydevil. (shorting?)

    As palandri suggested try a reset and if nothing changes get a replacement. :)
    10-18-2011 07:36 AM
  4. cheesydevil's Avatar
    I have been dreading that answer, what do you think about the chance the micro usb is screwed? I have no warranty as I bought the phone outright overseas and it does not have international warranty. I had to flash the ROM with an offical optus one when it got here but I doubt thats the problem or everyone in the country would be reporting it.
    10-18-2011 07:36 AM
  5. TheWeeBear's Avatar
    Oh dear, it does sound as if the USB socket is more likely to be faulty than a software problem. :(

    Other than reseting or flashing not a lot else to suggest. :(
    10-18-2011 07:38 AM
  6. cheesydevil's Avatar
    dag nabbit! I want my mummy!
    10-18-2011 07:55 AM
  7. richu75's Avatar
    I've seen the same behaviour on my Omnia while charging it with an older USB charger.
    I my case it was an older BB charger with a micro-USB cable. Seems the Samsung charger provides more power.

    Do you charge it with an non original adapter?
    10-19-2011 07:00 AM
  8. TheWeeBear's Avatar
    I've seen the same behaviour on my Omnia while charging it with an older USB charger.
    I my case it was an older BB charger with a micro-USB cable. Seems the Samsung charger provides more power.

    Do you charge it with an non original adapter?
    That would be good, if that's all it was richu75. :)
    10-19-2011 07:14 AM
  9. richu75's Avatar
    I've checked the chargers.

    The omnia's original charger delivers 5 volts at 0,7 Amps.
    In my case the old blackberry charger delivered 5 Volts at 0,5 Amps.

    Quite a difference.
    misfituk likes this.
    10-20-2011 01:59 AM
  10. Workshop2's Avatar
    Hey all, after my sister dropped my phone I am having the same problem with my Omnia. Did you ever figure this out?
    06-04-2012 02:58 AM
  11. PrittStickFace's Avatar
    This has started happening to me since last night.

    Since fully charging it overnight and disconnecting it for 1 hour this morning, my battery has already drained to 55%! The screen keeps turning itself on every 5 seconds. I've currently got my phone on vibrate to stop the beeping!

    Did anyone find a fix?
    Last edited by PrittStickFace; 11-06-2012 at 04:22 AM. Reason: spelling
    11-06-2012 04:22 AM
  12. Reflexx's Avatar
    This is risky, but worked for me.

    If you look in your USB port, you'll notice that the part that's supposed to be in the middle might be making contact with the side wall. I used a very small tool to move that middle island away from the side wall so it would stop touching.

    That was on my Samsung Focus over a year ago. It still works fine now.
    PrittStickFace likes this.
    11-06-2012 04:29 AM
  13. PrittStickFace's Avatar
    This is risky, but worked for me.

    If you look in your USB port, you'll notice that the part that's supposed to be in the middle might be making contact with the side wall. I used a very small tool to move that middle island away from the side wall so it would stop touching.

    That was on my Samsung Focus over a year ago. It still works fine now.
    Thanks for the rapid response. :)

    I just tried it with a small jewellers screwdriver. I will see how it goes and report back.

    Battery now at 6% needs another charge!
    11-06-2012 04:45 AM
  14. Reflexx's Avatar
    Good luck!
    11-06-2012 04:58 AM
  15. PrittStickFace's Avatar
    It worked OK for about 2 hours and then the battery completely died. When i fully charged it and disconnected it happened again.

    Tried with the screwdriver again and its been fine for the rest of the day.

    Thanks Winning Guy!
    11-06-2012 05:08 PM
  16. Paul Bamforth's Avatar
    My phone has been going crazy recently with the same fault. I did as suggested regarding moving the central bit inside the USB and it seems to be working fine now.
    xandros9 likes this.
    09-12-2013 07:30 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.