1. mortici's Avatar
    There are so many ads on this site and elements that its just horrible at loading on mobile IE (WP 8.1) both in desktop mode and mobile mode.

    My Icon just chugs at loading the page, going from article to article to simple navigation is just terrible.

    I know you guys have an app but seriously, even on the desktop sometimes it takes forever to load, not to mention the app is less than ideal and in most cases I would prefer to use IE to view this site than the app.

    Is there any plans to optimize or at least reduce the load times to make the experience tolerable on a mobile device?

    I can record a video to show how poor of a viewing experience this site is, surely you guys have tried going here on your WP devices....?

    Honest feedback would be appreciated...
    k0de likes this.
    02-03-2015 08:23 PM
  2. k0de's Avatar
    Blame MSFT.., Lol. But wait ads you are complaining about aren't even reverent to Windows on Phones. Dam Android, iOS and Google ads slow this site tremendously. I understand your frustration. Yes a quick fix is necessary.
    02-03-2015 08:53 PM
  3. James Falconer's Avatar
    @mortici - sorry to hear of the troubles you're having!

    Definitely record a video to show us the problems you're experiencing. We keep pushing fixes to the site consistently, and want to continue to address any issues our members encounter. The more feedback we can get, the better.

    ​Thank you!
    matt john2 and xandros9 like this.
    02-04-2015 11:43 AM
  4. matt john2's Avatar
    It was also my problem when using the site and surprisingly the issue is only with WP8.1 IE, I do noticed that browsing in IOS and Android are perfectly smooth specially on IOS, if I were to rate the site I would rate it 4/10 and buggy(BUT ONLY IF BROWSING WITH WP's IE).

    To the developers, please improve the app instead the site's issue is MS's fault from not implementing a better browser for WP 8.1
    02-04-2015 12:09 PM
  5. mortici's Avatar
    Check out WPU website, holy crap is it smooth both in Edge on my SP3 but on my WP8.1 device as well, super sleek and fast. Jesus, contact them and find out what they are using to render their site cause its gorgeous and smooth.

    The menu button sucks but in landscape mode is freaking perfect.

    The site runs like crap on Edge and WP8.1 haven't tried on W10, but if its Edge its probably gonna run like crap. I dunno if its the ads causing the slow performance or the site in general is just to heavy.
    xandros9 likes this.
    10-07-2015 10:17 AM

Similar Threads

  1. Should I buy the 920, 925, or wait for the 735 to go down in price?
    By thepolicecall911fordetails in forum Ask a Question
    Replies: 7
    Last Post: 02-04-2015, 06:44 PM
  2. New to wp
    By Sean Fanelli in forum Ask a Question
    Replies: 2
    Last Post: 02-03-2015, 10:09 PM
  3. What is Wifi Sense?
    By Sourabh Parchure5 in forum Ask a Question
    Replies: 2
    Last Post: 02-03-2015, 10:00 PM
  4. Why can't I download apps or install apps after I updated to 8.1?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-03-2015, 06:55 PM
LINK TO POST COPIED TO CLIPBOARD