1. tweedie's Avatar
    Basically, I have a few tabs open of various forums within windows central that I regularly view, and since they had updated their webpage (been a while, but its got me to a boiling point now!) the page even when switch back and forth tabs or pages, there is something like 1-2 second delay for the actual start of text content to appear (before any images/styles are applied)

    Its doing this in latest IE and chrome. I can understand initially that there might be a delay, but I've never known it to happen to other sites when just switching page/tabs to wpcentral site.

    why the delay? Looking at the dev network, its getting 3mb of data every time, makes 317 request and takes 43seconds to fully display the page. Isn't that a bit excessive? A lot of ads as well, and I really don't want to put up an ad blocker to block those to be honest.
    12-16-2015 08:27 AM
  2. RumoredNow's Avatar
    Can you post some screen shots of the reports?

    Could you screen record some loads?

    Why no AdBlocker if I may ask?
    12-16-2015 11:20 AM

Similar Threads

  1. Lumia 1520's display in pieces, what now?
    By Windows Central Question in forum Windows Phones
    Replies: 2
    Last Post: 12-16-2015, 07:16 PM
  2. Groove Music Sevice .....When in India?
    By Avinash Sahani in forum Windows Apps
    Replies: 0
    Last Post: 12-16-2015, 07:58 AM
  3. Where can I see a 950 XL in London before ordering?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 12-16-2015, 07:57 AM
  4. Replies: 1
    Last Post: 12-16-2015, 07:13 AM
  5. Baseball Riot swings bats, balls, and explosions onto Windows 10 PC and Mobile
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 12-16-2015, 07:11 AM
LINK TO POST COPIED TO CLIPBOARD